<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="preload" href="https://fonts.gstatic.com/l/font?kit=S6uyw4BMUTPHvxw6WQevLmXKyvAF38Zr4vvzO7eUBxVqG5VIaHRTe5PykWU4qMTZllljgwSeNufEDNBcqWtUR_XPzdIkBJsoRVwJR8hLoerDD44&skey=2d58b92a99e1c086&v=v16" as="font" crossorigin>
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>
		document.addEventListener("DOMContentLoaded",function(e){var s=document.querySelectorAll(".more-info-hover")[0];s&&(s.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),s.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),s.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var t=document.querySelectorAll(".htg-hamburger"),i=document.querySelectorAll(".subscribe-menu"),l=document.querySelectorAll(".full-screen-menu.search-menu"),c=document.querySelectorAll(".full-screen-menu.category-menu"),n=document.querySelectorAll("#topmenu .categories"),o=document.querySelectorAll(".subscribe-button"),r=document.querySelectorAll("#masthead .search"),a=document.querySelectorAll(".htg-close");a[0].addEventListener("click",function(e){l[0].classList.remove("visible")}),a[1].addEventListener("click",function(e){i[0].classList.remove("visible")}),r[0]&&r[0].addEventListener("click",function(e){l[0].classList.contains("visible")?l[0].classList.remove("visible"):(l[0].classList.add("visible"),t[0].classList.remove("is-active"),c[0].classList.remove("visible"),i[0].classList.remove("visible"))}),n[0].addEventListener("click",function(e){return i[0].classList.remove("visible"),t[0].classList.contains("is-active")?(c[0].classList.remove("visible"),t[0].classList.remove("is-active"),i[0].classList.remove("visible")):(l[0].classList.remove("visible"),i[0].classList.remove("visible"),t[0].classList.add("is-active"),c[0].classList.add("visible")),e.preventDefault(),!1}),t[0].addEventListener("click",function(e){i[0].classList.remove("visible"),t[0].classList.contains("is-active")?(c[0].classList.remove("visible"),t[0].classList.remove("is-active"),i[0].classList.remove("visible")):(l[0].classList.remove("visible"),i[0].classList.remove("visible"),t[0].classList.add("is-active"),c[0].classList.add("visible"))}),o[0].addEventListener("click",function(e){i[0].classList.contains("visible")?i[0].classList.remove("visible"):(c[0].classList.remove("visible"),t[0].classList.remove("is-active"),l[0].classList.remove("visible"),i[0].classList.add("visible"))}),i[0].addEventListener("click",function(e){e.target==i[0]&&i[0].classList.remove("visible")}),l[0].addEventListener("click",function(e){e.target==l[0]&&l[0].classList.remove("visible")}),c[0].addEventListener("click",function(e){e.target==c[0]&&(c[0].classList.remove("visible"),t[0].classList.remove("is-active"))});var d,v=document.querySelectorAll("#light-slider img")[0];if(v){var u=v.getAttribute("data-src");v.src=u}var m=0,L=5,b=document.querySelectorAll("#masthead")[0],f=b.offsetHeight;document.addEventListener("scroll",function(){d=!0},!1),setInterval(function(){d&&(!function(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;(s>200||!/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent))&&(c[0].classList.remove("visible"),l[0].classList.remove("visible"),i[0].classList.remove("visible"),t[0].classList.remove("is-active"));var n=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);if(Math.abs(m-s)<=L)return;s>m&&s>f?(b.classList.remove("nav-down"),b.classList.add("nav-up")):s+window.innerHeight<n&&(b.classList.remove("nav-up"),b.classList.add("nav-down"));m=s}(),d=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var y=[];document.onkeydown=function(e){y.push(e.keyCode),y.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),function(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);var l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),y=[])}});	</script>
<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);	</script>
<style>
	@-webkit-keyframes moka-slide-in {
		100% { 
			top: 50%; left: 50%; 
			-ms-transform: translateX(-50%) translateY(-50%); -webkit-transform: translate(-50%,-50%); transform: translate(-50%,-50%);
		}
	}
	@keyframes moka-slide-in {
		100% { 
			top: 50%; left: 50%; 
			-ms-transform: translateX(-50%) translateY(-50%); -webkit-transform: translate(-50%,-50%); transform: translate(-50%,-50%);
		}
	}

	@-webkit-keyframes moka-fade-in {
		100% { 
			opacity: 1;
		}
	}
	@keyframes moka-fade-in {
		100% { 
			opacity: 1;
		}
	}

	@-webkit-keyframes moka-fade-in-partial {
		100% { 
			opacity: 0.7;
		}
	}
	@keyframes moka-fade-in-partial {
		100% { 
			opacity: 0.7;
		}
	}

	#v2campaignpopup {
		background-color: white;
	}
	.darkmode #v2campaignpopup {
		background-color: black;
	}
	#v2campaignpopup_backdrop {
		position: fixed;
		top: 0;
		left: 0;
		right: 0;
		bottom: 0;
		opacity: 0; 
		-webkit-animation: moka-fade-in-partial 1s forwards; 
		-webkit-animation-delay: 0s; 
		animation: moka-fade-in-partial 1s forwards; 
		animation-delay: 0s;
		background-color: white;
		z-index: 100005;
	}
	.darkmode #v2campaignpopup_backdrop {
		background-color: black;
	}

	/* Push whole block down a smidge for close button, on mobile */
	@media screen and (max-width: 768px) {
		#v2campaignpopup {
			margin-top: 20px;
			overflow: auto;
			border: 1px solid black;
		}
		.darkmode #v2campaignpopup {
			border: 1px solid white;
		}
	}
</style>
<script type="text/javascript">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</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-16x16.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<style type="text/css">
/*
   Copyright 2009-2015, Jan-Philip Gehrcke (http://gehrcke.de)

   Tested with Firefox 39 and Chrome 43 on the following themes:

    - Twenty Ten (version 1.9)
    - Twenty Eleven (version 2.1)
    - Twenty Twelve (version 1.7)
    - Twenty Thirteen (version 1.5)
    - Twenty Fourteen (version 1.4)
    - Twenty Fifteen (version 1.2)

   Also tested with a number of popular non-official themes, such as

    - Vantage
    - Customizr
    - ColorWay
    - Zerif Lite
    - Responsive
    - Storefront
    - Virtue
    - evolve
    - Make
    - Sparkling
    - Spacious
    - Enigma
    - Sydney
    - Point
    - Interface
    - SinglePage

   Ensuring a nice and normalized visual appearance out-of-the-box with a
   number of themes requires to make certain compromises. It turned out that
   forcing the font size to an absolute value is key component, as well as
   using the !important flag for crucial componenta like font-size, margins,
   line-height (many themes apply id-based selectors to pre-blocks, which
   have a significantly higher specificity than the class-based styles
   applied here).

   I tried to cover/normalize the style via many relevant selectors. However,
   certain themes might define styles with a high specificity that affect the
   code block appearance negatively. It is difficult to impossible to anticipate
   these cases in advance, so I expect this to happen (and the past has proven
   me right in this regard). So, I need you to look out for these situations!
   In these cases, you need to identify the corresponding selectors and override
   your theme's styles by adjusting this file (wp-geshi-highlight.css), and
   placing it in your in your theme's directory. There, it survives updates of
   this plugin. It would also be great if you could contact me in these cases,
   so that I can improve this file in future releases.
*/

.wp-geshi-highlight pre, .wp-geshi-highlight span {
    color: #444;
    overflow: visible;
    margin: 0 !important;
    padding: 0;
    border: none;
    box-shadow: none;
    background: none;
    font-size: 12px !important;
    line-height: 20px !important;
    font-family: Consolas, Monaco, 'Lucida Console', monospace;
    word-wrap: normal; /* Otherwise Chrome wraps lines */
    white-space: pre;
}

.wp-geshi-highlight ol {
    margin: 0 !important;
    padding: 0 !important;
    list-style-type: decimal !important;
}

.wp-geshi-highlight ol > li {
    position: relative; /* Create a positioning context */
    margin: 0 0 0 40px; /* Give each list item a left margin to make room for the numbers */
}

.wp-geshi-highlight li {
    padding-left: 2px;
    font-family: Consolas, Monaco, 'Lucida Console', monospace !important;
    font-size: 12px !important;
    line-height: 20px !important;
    list-style: decimal !important;
    }

.wp-geshi-highlight {
    padding: 7px 10px 7px 15px;
    margin: 2px 0 30px 0;
    overflow-x: auto;
    border-bottom: 1px solid #ccc;
    border-top: 1px solid #ccc;
    background-color: #fdfdfd;
    box-shadow: 0 8px 7px -10px #CCC, 0 -8px 7px -10px #CCC;
}

/* Enforce background-color in some non-official themes when using numbering */
.wp-geshi-highlight div ol li {
    background-color: #fdfdfd;
}


</style>
<style type="text/css">
/**
 * GeSHi Dynamically Generated Stylesheet
 * --------------------------------------
 * Dynamically generated stylesheet for yaml
 * CSS class: , CSS id: 
 * GeSHi (C) 2004 - 2007 Nigel McNie, 2007 - 2014 Benny Baumann
 * (http://qbnz.com/highlighter/ and http://geshi.org/)
 * --------------------------------------
 */
.yaml .de1, .yaml .de2 {}
.yaml  {font-family:monospace;}
.yaml .imp {font-weight: bold; color: red;}
.yaml li, .yaml .li1 {font-weight: normal; vertical-align:top;}
.yaml .ln {width:1px;text-align:right;margin:0;padding:0 2px;vertical-align:top;}
.yaml .li2 {font-weight: bold; vertical-align:top;}
.yaml .kw1 {font-weight: bold;}
.yaml .co0 {color: #303050;background-color: #F5F5F5}
.yaml .co1 {color: blue;}
.yaml .co2 {font-weight: bold; color: red;}
.yaml .co3 {color: green;}
.yaml .co4 {color: #007F45;}
.yaml .co5 {color: #7f7fFF;}
.yaml .co6 {color: #FF7000;}
.yaml .co7 {color: #FF45C0;}
.yaml .co8 {font-weight: bold; color: #005F5F;}
.yaml .sy1 {color: cyan;}
.yaml .sy2 {font-weight: bold; color: brown;}
.yaml .st0 {color: #CF00CF;}
.yaml .ln-xtra, .yaml li.ln-xtra, .yaml div.ln-xtra {background-color: #ffc;}
.yaml span.xtra { display:block; }
</style>
<link rel="canonical" href="https://www.cloudsavvyit.com/10673/how-to-use-docker-app-to-containerise-an-entire-application-stack/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/10673/how-to-use-docker-app-to-containerise-an-entire-application-stack/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/10673\/how-to-use-docker-app-to-containerise-an-entire-application-stack\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"How to Use Docker App to Containerise an Entire Application Stack","name":"How to Use Docker App to Containerise an Entire Application Stack","datePublished":"2021-04-15T08:00:52-04:00","dateModified":"2021-04-15T01:12:23-04:00","author":{"@type":"Person","name":"James Walker"},"description":"Docker App is an experimental Docker feature which lets you build and publish application stacks consisting of multiple containers. It aims to let you share Docker Compose stacks with the same ease of use as regular Docker containers.","image":["https:\/\/www.cloudsavvyit.com\/p\/uploads\/2021\/01\/6dc7b5a0.jpeg?height=200p&trim=2,2,2,2"]}</script>
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="How to Use Docker App to Containerise an Entire Application Stack">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/p/uploads/2021/01/6dc7b5a0.jpeg?width=600&height=340&fit=crop&trim=2,2,2,2">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="How to Use Docker App to Containerise an Entire Application Stack"/>
<meta property="og:type" content="article"/>
<meta name="twitter:description" content="Docker App is an experimental Docker feature which lets you build and publish application stacks consisting of multiple containers. It aims to let you share Docker Compose stacks with the same ease of use as regular Docker containers.">
<meta property="og:description" name="og:description" content="Docker App is an experimental Docker feature which lets you build and publish application stacks consisting of multiple containers. It aims to let you share Docker Compose stacks with the same ease of use as regular Docker containers."/>
<meta property="og:image" content="https://www.cloudsavvyit.com/p/uploads/2021/01/6dc7b5a0.jpeg"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/10673/how-to-use-docker-app-to-containerise-an-entire-application-stack/">
<meta name="description" content="Docker App is an experimental Docker feature which lets you build and publish application stacks consisting of multiple containers. It aims to let you share Docker Compose stacks with the same ease of use as regular Docker containers."/>
<title>How to Use Docker App to Containerise an Entire Application Stack &#8211; CloudSavvy IT</title>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 , .related-articles, .affiliate-disclosure, .article-share-widgets {display:none !important;}
	#page::before {
	    content: "CloudSavvy IT";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}


</style>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<script>
var tmntag = tmntag || {};
tmntag.cmd = tmntag.cmd || [];
(function() {
var tmnhead = document.createElement('script');
tmnhead.async = true;
tmnhead.type = 'text/javascript';
tmnhead.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//ads.servebom.com/tmnhead.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(tmnhead, node);
})();
tmntag.cmd.push(function() {
tmntag.placement(3999);
tmntag.start();
});
</script>
</head>
<body class="post-template-default single single-post postid-10673 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a aria-hidden="true" tabindex="-1" href="https://www.cloudsavvyit.com">
<img data-pagespeed-no-defer src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT Logo" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" role="img" aria-label="Search Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/" title="RSS Feed" aria-label="RSS Feed"><svg role="img" aria-label="RSS Feed Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;" aria-hidden="true" tabindex="-1"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="linkedin">
<a title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/company/cloudsavvy-it/">
<svg role="img" aria-label="LinkedIn Icon" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
</a>
</span>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/cloudsavvyit"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="-1">Free Newsletter</div>
<ul id="topmenu" role="menu">
<li role="menuitem" id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li role="menuitem" id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li role="menuitem" id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
<li role="menuitem" id="menu-item-7620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7620"><a href="https://www.cloudsavvyit.com/newsletter">Newsletter</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li role="menuitem" id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li role="menuitem" id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<strong class="popsearchheading" role="heading" aria-level="1">Popular Searches</strong>
<div class="menu-header-column-1-container"><ul class="menu" role="menu"><li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/" aria-label="Search for AWS">AWS</a></li>
<li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/" aria-label="Search for Microsoft">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu" data-nosnippet="data-nosnippet">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;" aria-hidden="true" tabindex="-1"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" id="header_transient_postid" value="-1">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
<div style="text-align: center;">
<img width="195" height="38" data-pagespeed-no-defer style="float: right; max-width: 300px; margin-right: 25%;" src=" data:image/gif;base64,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" alt="" role="presentation">
</div>
</div>
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<script>
			let header_transient_postid = document.getElementById('header_transient_postid');
			if (header_transient_postid) {
				header_transient_postid.value = 10673;
			}
		</script>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;min-height: 250px;margin-bottom:20px;align-items: center;display: flex;justify-content: center;" aria-hidden="true" class="adslot adslot970 ">
<div aria-hidden="true" id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1', false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>
.commercemessage {
	width:100%;
	margin:20px 0px;
	padding-left:8px;
	font-size:13px;
	color:#555;
	border-left:3px solid #888;
}
@media screen and (min-width: 1025px) {
	.commercemessage {
		width:1020px;
		line-height:15px;
	}
}
</style>
<article id="post-10673" class="post-10673 post type-post status-publish format-standard hentry category-docker tag-splashbox">
<!-- UNCACHED CONTENT -->
<header id="article-header-area" class="entry-header" aria-label="How to Use Docker App to Containerise an Entire Application Stack">
<h1 class="entry-title" style="">How to Use Docker App to Containerise an Entire Application Stack</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;" data-nosnippet="data-nosnippet">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/p/uploads/2020/12/d373f5e3.png?width=100&#038;height=100&#038;fit=crop&#038;trim=2,2,2,2" alt="" role="presentation">
<span style="display: inline-block;">
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/jameswalker/">James Walker</a></span>
<br/>
<time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2021-04-15T08:00:52-04:00">Apr 15, 2021, 8:00 am EDT</time>
| 4 min read
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="James Walker">
<meta name="twitter:label2" content="Est. Reading Time">
<meta name="twitter:data2" content="4 minutes">	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="aligncenter size-full wp-image-9034" src="https://www.cloudsavvyit.com/p/uploads/2021/01/6dc7b5a0.jpeg?width=1200&trim=1,1&bg-color=000&pad=1,1" alt="" width="1602" height="902"/></p>
<p>Docker App is an experimental Docker feature which lets you build and publish application stacks consisting of multiple containers. It aims to let you share <a href="https://www.cloudsavvyit.com/7446/what-is-docker-compose-and-how-do-you-use-it">Docker Compose stacks</a> with the same ease of use as regular Docker containers.</p>
<h2 id="why-use-docker-app">Why Use Docker App?</h2>
<p>Docker App <a href="https://docs.docker.com/app/working-with-app">brings the Docker container experience</a> to entire application stacks. Many popular software projects now have official Docker images. They might not necessarily work as-is though: WordPress, for example, needs a database connection to run.</p>
<p>Containerisation advocates the separation of each service in an app stack into its own container. A Dockerised WordPress installation should consist of a WordPress container running a web server, PHP and WordPress, and a dedicated MySQL database container.</p>
<p>Running <code>docker run -d -p 80:80 wordpress:latest</code> isn&#8217;t sufficient to get this up-and-running. You&#8217;ll have WordPress live but no database connection. You can use Docker Compose to setup a stack with a WordPress container and a MySQL container. The onus is on you to create and maintain the Compose file, even though every user will need to do something similar.</p>
<p>Docker App attempts to solve this problem. It lets you create and run &#8220;app packages&#8221; of multiple containers. These can be pushed to Docker registries in the same way as individual containers. Other users can then pull down and run your app stack without having to write their own Docker Compose file.</p>
<p>Internally Docker App implements the Cloud Native Application Bundle (<a href="https://cnab.io">CNAB</a>) specification. This is a cross-industry effort to make it simpler to define, share and install multi-container cloud native apps. It includes support for peripheral resources such as volumes and networks.</p>
<p>CNAB clients like Docker App create CNAB app bundles which can be published to <a href="https://cnab.io/registries">supporting registries</a>. A CNAB bundle is an abstraction which encapsulates multiple containers but is treated similarly to a single container when pushed to a registry.</p>
<p>Docker App is currently experimental. It&#8217;s been included with the Docker CLI since version 19.03 but may change or be removed in the future. The project has changed direction in the past and its current development status <a href="https://github.com/docker/app/issues/799">is uncertain</a>. Nonetheless, the version included with Docker today can already be used to distribute multi-container app stacks.</p>
<h2 id="creating-a-docker-app-stack">Creating a Docker App Stack</h2>
<p>You can use the Docker CLI to initialise a new app stack.</p>
<pre>docker app init --single-file example-app</pre>
<p>This will create a new file called <code>example-app.dockerapp</code> in your working directory. The <code>--single-file</code> argument instructed Docker App to merge all the project files into the one <code>example-app.dockerapp</code> file. Without this argument, you&#8217;d see three separate files: <code>docker-compose.yml</code>, <code>metadata.yml</code> and <code>parameters.yml</code>.</p>
<p>Each constituent file is represented in the merged single file as a YAML section. We&#8217;re using a single file to aid clarity in this article&#8217;s code snippets; if you&#8217;re planning a complex app stack, using multiple files will aid maintainability.</p>
<p>Here&#8217;s what each of the three sections do:</p>
<ul>
<li><strong><code>docker-compose.yml</code></strong> &#8211; This is a regular Docker Compose file defining the containers which make up your app.</li>
<li><strong><code>metadata.yml</code></strong> &#8211; This sets basic metadata about your app, such its name, version and description. You use this to describe your entire app stack, rather than any one container.</li>
<li><strong><code>parameters.yml</code></strong> &#8211; This sets up default parameters for variables used in your Docker Compose file. Parameters are defined as simple key-value pairs. Your stack will use these default parameters unless the user overrides them with custom values.</li>
</ul>
<p>The only additional configuration needed beyond a regular Docker Compose file is the metadata section. If you already have a Docker Compose file, you can use <code>docker app init</code> with the <code>--compose-file</code> flag to import it:</p>
<pre>docker app init --compose-file docker-compose.yml example-app</pre>
<p>Update the manifest section with your app&#8217;s name, version and description. You can then proceed to run and publish your app!</p>
<p>If you&#8217;ve not got a Docker Compose file ready, add some container definitions to the Compose section of the configuration now.</p>
<div class="wp-geshi-highlight-wrap5"><div class="wp-geshi-highlight-wrap4"><div class="wp-geshi-highlight-wrap3"><div class="wp-geshi-highlight-wrap2"><div class="wp-geshi-highlight-wrap"><div class="wp-geshi-highlight"><div class="yaml"><pre class="de1"><span class="co1"># Application services - equivalent to docker-compose.yml.</span>
<span class="sy1">---</span><span class="co4">
services</span>:<span class="co4">
  apache</span>:<span class="co3">
    image</span><span class="sy2">: </span>httpd:latest<span class="co4">
    ports</span><span class="sy2">:
</span>      - $<span class="br0">&#123;</span>apache_port<span class="br0">&#125;</span>:80<span class="co4">
  mysql</span>:<span class="co3">
    image</span><span class="sy2">: </span>mysql:latest<span class="co4">
    ports</span><span class="sy2">:
</span>      - $<span class="br0">&#123;</span>mysql_port<span class="br0">&#125;</span>:3306<span class="co4">
    environment</span><span class="sy2">:
</span>      - MYSQL_ROOT_PASSWORD=$<span class="br0">&#123;</span>mysql_root_password<span class="br0">&#125;</span>
<span class="sy1">---</span>
<span class="co1"># Default application parameters - equivalent to parameters.yml.</span><span class="co3">
apache_port</span><span class="sy2">: </span>80<span class="co3">
mysql_port</span><span class="sy2">: </span>3306<span class="co3">
mysql_root_password</span><span class="sy2">: </span>mysql</pre></div></div></div></div></div></div></div>
<p>This simple stack creates Apache and MySQL containers. Each container needs to be configured with the host port to bind to. The MySQL container also needs a value for the <code>MYSQL_ROOT_PASSWORD</code> variable. This is used by MySQL during first-run to set the password for the initial <code>root</code> user.</p>
<p>Default values for these variables are provided in the <code>parameters</code> section of the Docker App file. These values will be used unless you override them when spinning up your app stack.</p>
<h2 id="building-app-images">Building App Images</h2>
<p>The next step is to build your Docker App stack into a CNAB-compliant bundle.</p>
<pre>docker app build . -f example-app.dockerapp -t example-user/example-app:latest</pre>
<p>This command functions similarly to <code>docker build</code>. It&#8217;ll create an app bundle tagged as <code>example-user/example-app:latest</code>. You can now push this bundle to Docker Hub!</p>
<pre>docker app push example-user/example-app:latest</pre>
<p>You&#8217;ve successfully published your first multi-container app stack, without having to manually share a Docker Compose file.</p>
<h2 id="running-app-images">Running App Images</h2>
<p>The final piece is to run an instance of your stack:</p>
<pre>docker app run example-user/example-app:latest --name my-app</pre>
<p>Docker App will start new containers based on the definition in your app bundle. The app bundle itself will be pulled from Docker Hub if it doesn&#8217;t already exist on your machine.</p>
<p>If your Compose file included resources like volumes and networks, they&#8217;ll be created and linked to the containers. The whole operation is akin to using <code>docker-compose up</code> without having to download the <code>docker-compose.yml</code> file first.</p>
<p>The app will be launched with the default variables defined in its <code>parameters.yml</code> file. You can override any variables you need with the <code>--set</code> flag:</p>
<pre>docker app run example-user/example-app:latest --name my-app --set mysql_root_password=mysql</pre>
<p>You can change the variables of a running app using <code>docker app update</code>:</p>
<pre>docker app update my-app --set my_variable=new_value</pre>
<p>Once an app&#8217;s running, you can use <code>docker app ls</code> to inspect its details. Use <code>docker app rm my-app</code> to destroy a specific app by its name. This will remove all the resources associated with the app.</p>
<h2 id="conclusion">Conclusion</h2>
<p>Docker App is a promising approach to defining, sharing and running multi-container application stacks with the Docker CLI. The project implements the Cloud Native Application Bundle specification while providing a friendly abstracted interface to users.</p>
<p>Adoption of Docker App is likely to remain low until its status in the Docker ecosystem has been confirmed. If it graduates from its experimental position, Docker App should fill the gap between single-container registries and complex cloud native deployment solutions such as <a href="https://helm.sh">Helm</a>.</p>
</div><!-- .entry-content -->
</article><!-- #post-10673 -->
<style>
			#content ul#nextuplist {list-style-type: none;margin-left:0px;padding-left:0px;}
			#content ul#nextuplist li {margin-bottom:10px;}
			#content ul#nextuplist li a {text-decoration:none;}
		</style>
<div class="nextup">
<span id="nextuplabel" role="heading" aria-level="2">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/10626/how-to-host-multiple-websites-with-one-apache-server/">How to Host Multiple Websites With One Apache Server</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/10543/has-the-rsa-just-been-destroyed-by-a-retired-german-mathematician/">Has the RSA Just Been Destroyed by a Retired German Mathematician?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/10587/whats-driving-the-surge-in-account-take-over-attacks-in-retail/">What&#8217;s Driving the Surge in Account Take Over Attacks in Retail?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/10487/the-role-of-file-integrity-monitoring-fim-in-cybersecurity/">The Role of File Integrity Monitoring (FIM) in Cybersecurity</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/10520/how-to-run-gui-applications-in-a-docker-container/">How to Run GUI Applications in a Docker Container</a></li>
</ul>
</div>
<style>
.shortbioauthor {

	font-weight: bold;
    text-transform: uppercase;
    font-size: 20px;
    text-decoration:none;
    padding-top: 0;
    margin-top: 0;
    line-height: 20px;
}
.shortbioauthor span {
	color:#1d55a9;	
	padding-top: 0;
	margin-top: 0;
}
.shortbioauthordiv {
	border: 1px solid #eee;
	padding: 15px;
	margin-bottom: 20px;
}
.shortbioauthordiv .biotext {
	font-size: 15px;
}
.shortbioauthordiv .biomore {
	text-transform: uppercase;
	font-size: 13px;
	font-weight: bold;
	color:#1d55a9;		
}
</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/jameswalker/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/p/uploads/2020/12/d373f5e3.png?width=200&height=200&fit=crop&trim=2,2,2,2" alt="James Walker"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="shortbioauthor"><span>James Walker</span></a>
<br style="margin-top: 10px;">
<span class="biotext">James Walker is a contributor to CloudSavvy IT. He is the founder of <a href="https://www.heron-web.com" rel="noopener" target="_blank">Heron Web</a>, a UK-based digital agency providing bespoke software development services to SMEs. He has experience of managing complete end-to-end web development workflows, using technologies including Linux, GitLab, Docker and Kubernetes.
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a title="Share on Facebook" aria-label="Share on Facebook" class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/10673/how-to-use-docker-app-to-containerise-an-entire-application-stack/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a title="Share on Twitter" aria-label="Share on Twitter" class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=How+to+Use+Docker+App+to+Containerise+an+Entire+Application+Stack+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/10673/how-to-use-docker-app-to-containerise-an-entire-application-stack/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>
#content .comments p.share-heading {
	font-size: 14px;
    font-weight: bold;
    margin-top: 0;
    line-height: 36px;
    text-decoration: none;
    text-transform: uppercase;
    border: 1px solid #333333;
    background: #333333;
    border-radius: 4px;
    color: #FFF;
    padding-left: 8px;
    padding-right: 8px;
}

@media screen and (max-width: 768px) {
	#content .comments p.share-heading {
		line-height:27px;
	}

}

</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<strong class="article-footer-heading">Recently Popular</strong>
<article>
<header class="entry-header" style="min-height:100px;" aria-label="The Role of File Integrity Monitoring (FIM) in Cybersecurity" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="The Role of File Integrity Monitoring (FIM) in Cybersecurity" aria-label="The Role of File Integrity Monitoring (FIM) in Cybersecurity" href="https://www.cloudsavvyit.com/10487/the-role-of-file-integrity-monitoring-fim-in-cybersecurity/">
<img alt="The Role of File Integrity Monitoring (FIM) in Cybersecurity" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/04/b8e8632b.png?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="The Role of File Integrity Monitoring (FIM) in Cybersecurity" aria-label="The Role of File Integrity Monitoring (FIM) in Cybersecurity" href="https://www.cloudsavvyit.com/10487/the-role-of-file-integrity-monitoring-fim-in-cybersecurity/">
<span class="entry-title article-header">The Role of File Integrity Monitoring (FIM) in Cybersecurity</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anina/" class="p-author vcard author post-author"><span class="fn">Anina Ot</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-04-09T08:00:43-04:00">April 9th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="Define a Great Vim Profile Using .vimrc" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="Define a Great Vim Profile Using .vimrc" aria-label="Define a Great Vim Profile Using .vimrc" href="https://www.cloudsavvyit.com/9884/define-a-great-vim-profile-using-vimrc/">
<img alt="Define a Great Vim Profile Using .vimrc" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/02/7ae6c4da.png?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="Define a Great Vim Profile Using .vimrc" aria-label="Define a Great Vim Profile Using .vimrc" href="https://www.cloudsavvyit.com/9884/define-a-great-vim-profile-using-vimrc/">
<span class="entry-title article-header">Define a Great Vim Profile Using .vimrc</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/roel_van_de_paar/" class="p-author vcard author post-author"><span class="fn">Roel Van de Paar</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-04-06T08:00:50-04:00">April 6th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="CloudSavvy IT Is Now on Google News" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="CloudSavvy IT Is Now on Google News" aria-label="CloudSavvy IT Is Now on Google News" href="https://www.cloudsavvyit.com/10114/cloudsavvy-it-is-now-on-google-news/">
<img alt="CloudSavvy IT Is Now on Google News" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/03/90ec0ea1.png?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="CloudSavvy IT Is Now on Google News" aria-label="CloudSavvy IT Is Now on Google News" href="https://www.cloudsavvyit.com/10114/cloudsavvy-it-is-now-on-google-news/">
<span class="entry-title article-header">CloudSavvy IT Is Now on Google News</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/walterglenn/" class="p-author vcard author post-author"><span class="fn">Walter Glenn</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-03-12T06:28:32-05:00">March 12th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Use DigitalOcean Backups and Snapshots" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Use DigitalOcean Backups and Snapshots" aria-label="How to Use DigitalOcean Backups and Snapshots" href="https://www.cloudsavvyit.com/10367/how-to-use-digitalocean-backups-and-snapshots/">
<img alt="How to Use DigitalOcean Backups and Snapshots" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/01/83680385.jpeg?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="How to Use DigitalOcean Backups and Snapshots" aria-label="How to Use DigitalOcean Backups and Snapshots" href="https://www.cloudsavvyit.com/10367/how-to-use-digitalocean-backups-and-snapshots/">
<span class="entry-title article-header">How to Use DigitalOcean Backups and Snapshots</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-04-05T09:00:26-04:00">April 5th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="Has the RSA Just Been Destroyed by a Retired German Mathematician?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="Has the RSA Just Been Destroyed by a Retired German Mathematician?" aria-label="Has the RSA Just Been Destroyed by a Retired German Mathematician?" href="https://www.cloudsavvyit.com/10543/has-the-rsa-just-been-destroyed-by-a-retired-german-mathematician/">
<img alt="Has the RSA Just Been Destroyed by a Retired German Mathematician?" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/04/a2a0d88e.png?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="Has the RSA Just Been Destroyed by a Retired German Mathematician?" aria-label="Has the RSA Just Been Destroyed by a Retired German Mathematician?" href="https://www.cloudsavvyit.com/10543/has-the-rsa-just-been-destroyed-by-a-retired-german-mathematician/">
<span class="entry-title article-header">Has the RSA Just Been Destroyed by a Retired German Mathematician?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/davidmckay/" class="p-author vcard author post-author"><span class="fn">Dave McKay</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-04-13T08:00:34-04:00">April 13th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" aria-label="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" href="https://www.cloudsavvyit.com/10299/how-to-set-a-user-timezone-in-ubuntu-and-mint-using-bashrc/">
<img alt="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2017/07/add8ac45.png?width=240&height=140&fit=crop&trim=2,2,2,2" width="240" height="140"/>	</a>
<div class="article-text">
<a title="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" aria-label="How to Set a User Timezone in Ubuntu and Mint Using .bashrc" href="https://www.cloudsavvyit.com/10299/how-to-set-a-user-timezone-in-ubuntu-and-mint-using-bashrc/">
<span class="entry-title article-header">How to Set a User Timezone in Ubuntu and Mint Using .bashrc</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/roel_van_de_paar/" class="p-author vcard author post-author"><span class="fn">Roel Van de Paar</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-04-12T09:00:59-04:00">April 12th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
</div>
<script type='text/javascript'>
			var htg = -1;
			var htgm = document.cookie.match('htg=([0-9]*)');
			if (htgm && htgm.length == 2) {
				htg = htgm[1];
			}
			document.write('<img src="https://www.cloudsavvyit.com/lambda-uploads/cloudsavvy/10673/' + htg + '/logo.gif?1618499355" alt="" id="htgstats" style="display:none" />');
		</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div aria-hidden="true" id='purch_Y_R_1_1' style="min-height:620px;padding-bottom:20px; align-items: center;display: flex;justify-content: center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1', false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?p=10673&v=1618498800" defer async></script>
</div>
<div aria-hidden="true" id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1', false);});</script></div>
</aside>
<script type="text/javascript">
	document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";

	window.onload = function() {
		//document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";
	}
</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" aria-hidden="true" class="adslot adslot970 ">
<div aria-hidden="true" id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1', false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a aria-label="CloudSavvy IT" title="CloudSavvy IT" href="https://www.cloudsavvyit.com">
<img data-pagespeed-no-defer src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT Logo" class="logo">
</a>
<div class="social">
<a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1"><title>Facebook Icon</title><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" aria-hidden="true" tabindex="-1">
<title>Twitter Icon</title>
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" class="rss-link" href="https://www.linkedin.com/company/cloudsavvy-it/">
<div class="rss" style="background-color:#325f93">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><title>LinkedIn Icon</title><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
<p>LinkedIn</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}

</style>
<div class="footer-email" data-nosnippet="data-nosnippet">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" value="10673">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-footer">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<li role="menuitem"><a href="/about">About</a></li>
<li role="menuitem"><a href="/ethics">Ethics</a></li>
<li role="menuitem"><a href="/privacy-policy">Privacy</a></li>
<li role="menuitem"><a href="/terms-of-use">Terms</a></li>
<li role="menuitem"><a href="/accessibility">Accessibility</a></li>
<li role="menuitem" aria-label="Do not sell my info">
<div id="show-do-not-sell-info-container"></div>
</li>
<li role="menuitem">
<input class="darkModeToggle" id="darkModeToggle" aria-label="Toggle Dark Mode" type="checkbox" onclick="if (document.body.classList.contains('darkmode')) { document.body.classList.remove('darkmode'); document.cookie = 'enabledarkmode=no; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; } else { document.body.classList.add('darkmode'); document.cookie = 'enabledarkmode=yes; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; }"/> <label class="darkModeToggleLabel" for="darkModeToggle">Toggle Dark Mode</label>
</li>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2021 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<script>
		if (document.getElementById('moka_no_dark_mode')) {
			// Disable dark mode (and toggle!) on this page
			[].forEach.call(document.getElementsByClassName('darkModeToggle'), a => a.remove());
			[].forEach.call(document.getElementsByClassName('darkModeToggleLabel'), a => a.remove());
		} else {
			let useDarkMode = false;
			if ( document.cookie.includes('enabledarkmode=yes') ) {
				useDarkMode = true;
			} else if ( document.cookie.includes('enabledarkmode=no') ) {
				useDarkMode = false;
			} else {
				// Use system default preference
				if (window.matchMedia && window.matchMedia('(prefers-color-scheme: dark)').matches ) {
					useDarkMode = true;
				}
			}

			if (useDarkMode) {
				document.body.classList.add('darkmode');
				document.getElementById('darkModeToggle').checked = true;
			}
		}
	</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-16');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt=""/>
</div>
</noscript>
<!-- End Quantcast tag -->
<!-- Admiral -->
<script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://selfishsnake.com/v2uplt1QMJHh2ZU0CcF8XNhbb6jf2rlFeLaJqEOf96afbSAYK6PeBl6cKLbZurQeT",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){function t(){(t.q=t.q||[]).push(arguments)}t.v=1,o.admiral=o.admiral||t})(window);!(function(o,t,n,c){function e(n){(function(){try{return(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]>0}catch(o){}return!1})()&&(n=o[t].pubads())&&n.setTargeting("admiral-engaged","true")}(c=o[t]=o[t]||{}).cmd=c.cmd||[],typeof c.pubads===n?e():typeof c.cmd.unshift===n?c.cmd.unshift(e):c.cmd.push(e)})(window,"googletag","function");
var addEngageListener = function() {
    if (!window.admiral) {
        setTimeout(addEngageListener, 500);
        return;
    }
    window.admiral('addEventListener', 'engage.loaded', function() {
    	window.admiral_engaged = true;
    });
};
addEngageListener();
</script>
<!-- End Admiral --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page', false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1', false);});</script></div>
<script type="text/javascript">
let mokaFindParentAnchor = function(elem) {
    if (elem.href) return elem;
    if (elem.parentElement) return mokaFindParentAnchor(elem.parentElement);
    return null;
}
window.addEventListener("click", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null ) {
		e.preventDefault();

		window.open(trueAnchorElem.href);

		let xmlhttp = new XMLHttpRequest();
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var widgetSource = trueAnchorElem.getAttribute('data-widgetsource');
		if (widgetSource) {
			if (amzLink.indexOf('?') != -1) {
				amzLink += '&widgetsource=' + encodeURIComponent(widgetSource);
			} else {
				amzLink += '?widgetsource=' + encodeURIComponent(widgetSource);
			}
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/10673/' + htg + '/' + amzLink;
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});
window.addEventListener("contextmenu", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null) {
		// No need for preventdefault on this version - and no need to listen for finish
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var widgetSource = trueAnchorElem.getAttribute('data-widgetsource');
		if (widgetSource) {
			if (amzLink.indexOf('?') != -1) {
				amzLink += '&widgetsource=' + encodeURIComponent(widgetSource);
			} else {
				amzLink += '?widgetsource=' + encodeURIComponent(widgetSource);
			}
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/10673/' + htg + '/' + amzLink;
		let xmlhttp = new XMLHttpRequest();
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});

let handleHtgHash = function() {
	if (document.location.hash.indexOf('#htg=') != -1) {
		let htgid = document.location.hash.match(/htg=([0-9]*)/);
		let uid = 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, (c) => {
			var r = Math.random() * 16 | 0, v = c == 'x' ? r : (r & 0x3 | 0x8);
			return v.toString(16);
		});
		if (htgid.length == 2) {
			document.cookie = 'htg=' + htgid[1] + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htgreader=' + uid + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htg_newsletter_subform_hide=1; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
		}

		history.pushState('', document.title, window.location.pathname);
	}
}();
</script>
<script>
	// Load all lazy-loaded images before someone prints:
	let loadAllLazy = () => {
		var imgs = document.querySelectorAll('[data-pagespeed-lazy-src]');
		imgs.forEach(e => e.src = e.attributes['data-pagespeed-lazy-src'].value);
	}
	// IE and FireFox:
	window.onbeforeprint = loadAllLazy;
	// Chrome and Safari:
	let mediaQueryList = window.matchMedia('print');
	mediaQueryList.addListener((mql) => {
    	if (mql.matches) loadAllLazy();
	});
</script>
<script>
	(function() {
		if (document.referrer) {
			var x = document.getElementsByName('moka-pagerefer');
			for (var i = 0; i < x.length; i++) {
				x[i].value = document.referrer;
			}
		}
	})();

	function fb_t_convert() {
		var url = 'https://www.howtogeek.com/public/trackBBClick.php?s=cloudsavvy';

		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			url += '&htgm=' + htgm[1];
		}
		var fbpm = document.cookie.match('_fbp=([0-9a-zA-Z\.]*)');
		if (fbpm && fbpm.length == 2) {
			url += '&fbp=' + fbpm[1];
		}
		var fbcm = document.cookie.match('_fbc=([0-9a-zA-Z\.]*)');
		if (fbcm && fbcm.length == 2) {
			url += '&fbc=' + fbcm[1];
		}

		url += '&r=' + Date.now();

		var xhr = new XMLHttpRequest();
		xhr.open('GET', url);
		xhr.send()
	}
</script>
</body>
</html>