<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});document.addEventListener("DOMContentLoaded",function(){if(document.cookie.includes('enabledarkmode')){document.querySelector('body').classList.add("darkmode");}});</script>
<script>/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-57x57.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.X4qjwvEy-w.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-60x60.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ZsgiriYp6p.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-72x72.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.2c-VliVhHB.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-76x76.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.-W23JYe9bs.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-114x114.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.YiS-24fen9.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-120x120.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.XGRWxmU8nr.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-144x144.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.Y7cnPtTr9u.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-152x152.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ycAcLBARUK.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-180x180.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.YmoH7R2Hh3.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xandroid-icon-192x192.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.VlQU51G5bV.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-32x32.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.vZfVuJKvuP.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-96x96.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.kV3Wz5oed-.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-16x16.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.mumKW6Z4Mp.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<title>How To Manage Different Versions of Lambda Functions &#8211; CloudSavvy IT</title>
<link rel="canonical" href="https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/3359\/how-to-manage-different-versions-of-lambda-functions\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"How To Manage Different Versions of Lambda Functions","name":"How To Manage Different Versions of Lambda Functions","datePublished":"2020-05-15T10:00:16-04:00","dateModified":"2020-05-15T09:26:53-04:00","author":{"@type":"Person","name":"Anthony Heddings"},"description":"Lambda functions are a very useful entry to AWS&#8217;s compute services. Since they&#8217;re basically just a function in the cloud, tracking different versions and rolling out updates is crucial to working with them effectively.","image":["https:\/\/www.cloudsavvyit.com\/thumbcache\/2\/200\/555659f34d32d8a9d63e2acb77562823\/p\/uploads\/2019\/06\/58095fd3.png"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="How To Manage Different Versions of Lambda Functions">
<meta name="twitter:description" content="Lambda functions are a very useful entry to AWS&#8217;s compute services. Since they&#8217;re basically just a function in the cloud, tracking different versions and rolling out updates is crucial to working with them effectively.">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/thumbcache/600/340/812634dfa49b31f652b1a75a9bca43c1/p/uploads/2019/06/58095fd3.png">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="How To Manage Different Versions of Lambda Functions"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="Lambda functions are a very useful entry to AWS&#8217;s compute services. Since they&#8217;re basically just a function in the cloud, tracking different versions and rolling out updates is crucial to working with them effectively."/>
<meta property="og:image" content="https://www.cloudsavvyit.com/thumbcache/648/248/4ff041a2fbdf37824fd480300ae4916f/p/uploads/2019/06/58095fd3.png"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/">
<meta name="description" content="Lambda functions are a very useful entry to AWS&#8217;s compute services. Since they&#8217;re basically just a function in the cloud, tracking different versions and rolling out updates is crucial to working with them effectively."/>
<style>@media print{#masthead,.full-screen-menu,.adslot,.site-footer,#secondary,#purch_N_C_0_1,.social-media-buttons,.article-bottom,.jw-loaded,#purch_N_C_0_1,.related-articles,.affiliate-disclosure,.article-share-widgets{display:none!important}#page::before{content:"CloudSavvy IT";font-size:24px;font-weight:bold;padding-left:20px;width:700px;border-bottom:1px solid #000;display:block;margin:10px auto}}</style>
<script>var tmntag=tmntag||{};tmntag.cmd=tmntag.cmd||[];(function(){var tmnhead=document.createElement('script');tmnhead.async=true;tmnhead.type='text/javascript';tmnhead.src=('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(tmnhead,node);})();tmntag.cmd.push(function(){tmntag.placement(4000);tmntag.start();});</script>
</head>
<body class="post-template-default single single-post postid-3359 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a href="https://www.cloudsavvyit.com">
<img src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/xcsit_dark_t.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.pNfZCdDxNv.png" alt="CloudSavvy IT" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button">
<span class="hamburger-box">
<span class="hamburger-inner"></span>
</span>
</button>
<svg class="search" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="twitter"><a href="https://twitter.com/cloudsavvyit"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a href="https://www.facebook.com/cloudsavvyit/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button">Subscribe</div>
<ul id="topmenu">
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul id="menu-header-column-1" class="menu"><li id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul id="menu-header-column-2" class="menu"><li id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul id="menu-header-column-3" class="menu"><li id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul id="menu-header-column-4" class="menu"><li id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="">
<input type="submit" value="Go">
</form>
<span class="popsearchheading">Popular Searches</span>
<div class="menu-header-column-1-container"><ul id="menu-header-column-5" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input type="hidden" name="list" value="cloudsavvy">
<input type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input type="text" name="email" id="ftemtxt" placeholder="Your email">
<input type="submit" id="ftemsub" value="Go">
</form>
</div>
</div>
</div>
</div>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" class="adslot adslot970 ">
<div id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1',false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>.commercemessage{width:100%;margin:20px 0;padding-left:8px;font-size:13px;color:#555;border-left:3px solid #888}@media screen and (min-width:1025px){.commercemessage{width:1020px;line-height:15px}}</style>
<article id="post-3359" class="post-3359 post type-post status-publish format-standard hentry category-aws category-cloud">
<header id="article-header-area" class="entry-header">
<h1 class="entry-title" style="">How To Manage Different Versions of Lambda Functions</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/2c5f75e27762ca292f9660b5e0d85ea7/p/uploads/2019/11/36x36xecebbecf.jpg.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.LnD4l2tAPW.jpg" alt="">
<span>
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/anthonyheddings/">Anthony Heddings</a></span>
<br/>
<a href="https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/" rel="bookmark"><time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2020-05-15T10:00:16-04:00">May 15, 2020, 10:00am EDT </time><time class="updated" datetime="2020-05-15T09:26:53-04:00">May 15, 2020, 9:26am EDT </time></a>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="alignnone size-full wp-image-516" src="https://www.cloudsavvyit.com/thumbcache/0/0/f2cbafc46076ecfc332b31b9185deb13/p/uploads/2019/06/x58095fd3.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.JGe3Vkwewr.png" alt="lambda logo" width="700" height="300"/></p>
<p>Lambda functions are a very useful entry to AWS&#8217;s compute services. Since they&#8217;re basically just a function in the cloud, tracking different versions and rolling out updates is crucial to working with them effectively.</p>
<h2>$LATEST Tracks The Most Recent Updates</h2>
<p>Anytime you make a change to a Lambda function, changes are automatically reflected in a version called $LATEST. This tracks the most recent updates, and is the default version for most Lambda functions. Changes from the Lambda edit page, Cloud9 IDE, and zip uploading from the CLI all update this version.</p>
<p>Because of this, the $LATEST version should not be used in production, as any updates to the function to test new features will affect your production traffic. Plus, there&#8217;s no easy way to roll out updates over time with CodeDeploy if you use $LATEST.</p>
<p>Instead, we recommend creating new versions for each release, and a &#8220;production&#8221; alias that points to it. $LATEST can be used for development, with its own alias pointing to it as well.</p>
<h2>Adding a New Version (And Shifting Traffic To It)</h2>
<p>Working with versions is pretty easy. From the <a href="https://console.aws.amazon.com/lambda/home?tag=reviewgeek-20">Lambda Management Console</a>, select your function, and click on the &#8220;Version:&#8221; dropdown. This will allow you to switch between versions, and view the versions currently in use.</p>
<p><img class="alignnone wp-image-3360 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/5b2b74969c4567d0f6f16985623cff93/p/uploads/2019/12/x5c3073e5.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.C1mDkEv9ET.jpg" alt="Lambda versions menu" width="700" height="328"/></p>
<p>To publish a new version, you&#8217;ll need to switch to the $LATEST version, and click &#8220;Publish new version&#8221; from the &#8220;Actions&#8221; dropdown.</p>
<p><img class=" alignnone wp-image-3361 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/e9124cbcf6d01658ab5a29e34e26b80b/p/uploads/2019/12/x7503b392.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.t6I0OjW-BW.jpg" alt="lambda new version" width="700" height="216"/></p>
<p>New versions are rather archaically denoted by an incrementing integer, with no way to use the standard major.minor.patch format used for most software releases. If you really need this format, we recommend you use CodePipeline with SAM deployments, and track your Lambda versions on Git.</p>
<p>This new version can be used in other services, like API Gateway. However, you don&#8217;t want to have to update every service that uses your Lambda function every time the function itself is updated. Instead, you should create an Alias, which points to a particular version number, and can be set as the endpoint for API Gateway. This way, whenever you publish a new version, you&#8217;ll simply need to update the alias to switch everything over.</p>
<p>You can create aliases from the same &#8220;Actions&#8221; menu. Give it a name, such as &#8220;Production,&#8221; and select a version to point to.</p>
<p><img class="alignnone size-full wp-image-3362" src="https://www.cloudsavvyit.com/thumbcache/0/0/7ba050be9cf95052a2d97a2fb333a5d6/p/uploads/2019/12/x52f3c496.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.Mqy9smqEkV.jpg" alt="lambda alias" width="700" height="388"/></p>
<p>Aliases can also gradually shift traffic over to a new version. While you can manually set this up, it&#8217;s mostly used for CodeDeploy deployments, where new versions of your functions can be deployed gradually, e.g., 10% every five minutes or so. This way, you can catch errors early and rollback releases before they affect everybody.</p>
<h2>SAM Deployments Automatically Add New Versions</h2>
<p>Creating versions manually is useful, but if you&#8217;re managing a lot of functions, you&#8217;ll probably be using SAM deployments instead. Lambda functions deployed using SAM templates will automatically add a new version (and update $LATEST).</p>
<p>Combined with Git for version control, and AWS&#8217;s CodePipeline CI/CD service, this makes version management for Lambda functions much easier. Whenever a change is pushed to the release branch in your source control, CodePipeline will trigger automatically and update your functions. If you&#8217;re working with a language that needs compiling (or transpiling in the case of TypeScript), you can also send your function code to CodeBuild to handle that stage as well.</p>
<p>SAM deployment is an extension of CloudFormation, so any deployments made using SAM will create a new CloudFormation stack. Whenever updates are pushed, CloudFormation recognizes that it&#8217;s a stack update, rather than a new stack, and will replace the current function version with the updated one.</p>
</div><!-- .entry-content -->
</article><!-- #post-3359 -->
<style>#content ul#nextuplist{list-style-type:none;margin-left:0;padding-left:0}#content ul#nextuplist li{margin-bottom:10px}#content ul#nextuplist li a{text-decoration:none}</style>
<div class="nextup">
<span id="nextuplabel" style="font-weight: bold;
					    font-size: 22px;
					    color: #000;
					    margin-bottom: 10px;
					    display: block;">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/2817/should-you-use-a-git-alternative/">Should You Use a Git Alternative?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/4796/nvidias-new-ampere-gpu-is-a-game-changer-for-artificial-intelligence/">NVIDIA&#8217;s New Ampere GPU is a Game Changer for Artificial Intelligence</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/363/how-to-lock-down-your-ssh-server/">How to Lock Down Your SSH Server</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/2428/the-best-alternatives-to-github/">The Best Alternatives to Github</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/255/need-analytics-for-your-web-site-here-are-four-tools-you-can-use/">Need Analytics for Your Web Site? Here Are Four Tools You Can Use</a></li>
</ul>
</div>
<style>.shortbioauthor{font-weight:bold;text-transform:uppercase;font-size:20px;text-decoration:none;padding-top:0;margin-top:0;line-height:20px}.shortbioauthor span{color:#1d55a9;padding-top:0;margin-top:0}.shortbioauthordiv{border:1px solid #eee;padding:15px;margin-bottom:20px}.shortbioauthordiv .biotext{font-size:15px}.shortbioauthordiv .biomore{text-transform:uppercase;font-size:13px;font-weight:bold;color:#1d55a9}</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/b61217adbd4c46bbe0a1cdb699fa5a4f/p/uploads/2019/11/100xNxecebbecf.jpg.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.RpN26oxPKY.jpg" alt="Anthony Heddings"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="shortbioauthor"><span>Anthony Heddings</span></a>
<br style="margin-top: 10px;">
<span class="biotext">Anthony Heddings is the resident cloud engineer for LifeSavvy Media, a technical writer, programmer, and an expert at Amazon's AWS platform. He's written hundreds of articles for How-To Geek and CloudSavvy IT that have been read millions of times.
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=How+To+Manage+Different+Versions+of+Lambda+Functions+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/3359/how-to-manage-different-versions-of-lambda-functions/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>#content .comments p.share-heading{font-size:14px;font-weight:bold;margin-top:0;line-height:36px;text-decoration:none;text-transform:uppercase;border:1px solid #333;background:#333;border-radius:4px;color:#fff;padding-left:8px;padding-right:8px}@media screen and (max-width:768px){#content .comments p.share-heading{line-height:27px}}</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<span class="article-footer-heading">Recently Popular</span>
<article id="post-2817">
<a href="https://www.cloudsavvyit.com/2817/should-you-use-a-git-alternative/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/8fb1120b45d43d5ca36c08ce7739c71d/p/uploads/2019/10/xe713ed70-1.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.FMDdGryvOU.png"/>	<div class="article-text">
<span class="entry-title article-header">Should You Use a Git Alternative?</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-05-15T09:24:41-04:00">May 15th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-640">
<a href="https://www.cloudsavvyit.com/640/how-to-extract-and-sort-columns-out-of-log-files-on-linux/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/2976939aa95c8fae0bf321f4313c28a6/p/uploads/2019/06/x0d5f8f09-1.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.q5QoKmLDsR.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How to Extract and Sort Columns Out of Log Files on Linux</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-05-12T10:00:31-04:00">May 12th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-1121">
<a href="https://www.cloudsavvyit.com/1121/what-is-es6-javascript-and-how-is-it-different/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/cabe5a0dbba3662c1bc948713e44d066/p/uploads/2019/07/x9608c9ff.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.khEHg1oZY5.png"/>	<div class="article-text">
<span class="entry-title article-header">What Is ES6 JavaScript, and How Is It Different?</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-05-08T11:00:55-04:00">May 8th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-4796">
<a href="https://www.cloudsavvyit.com/4796/nvidias-new-ampere-gpu-is-a-game-changer-for-artificial-intelligence/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/a4535c228acbda0b1cf2520c01051da6/p/uploads/2020/05/x6db20e65.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.q5pPBpyozw.jpg"/>	<div class="article-text">
<span class="entry-title article-header">NVIDIA&#8217;s New Ampere GPU is a Game Changer for Artificial Intelligence</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-05-14T15:32:18-04:00">May 14th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-2599">
<a href="https://www.cloudsavvyit.com/2599/a-beginners-guide-to-awss-machine-learning-services/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/88efed571ca3d8e618ce6a93e1a611fa/p/uploads/2019/11/x441e5a76-e1583338193943.jpg.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.-D-M-fdg5V.jpg"/>	<div class="article-text">
<span class="entry-title article-header">A Beginner&#8217;s Guide to AWS&#8217;s Machine Learning Services</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-03-04T08:00:36-05:00">March 4th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-552">
<a href="https://www.cloudsavvyit.com/552/how-to-make-sure-your-ubuntu-servers-are-always-patched/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/e2bc6eff3d05886ba7aaa129cea52083/p/uploads/2020/05/x59ea38f7.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.hBQ2vPXw6D.png"/>	<div class="article-text">
<span class="entry-title article-header">How to Make Sure Your Ubuntu Servers Are Always Patched</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-05-11T11:00:00-04:00">May 11th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	</div>
<script type='text/javascript'>document.write('<img src="/p/uploads/px/3359/logo.gif?1589553046" alt="" id="htgstats" style="display:none" />');</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1',false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?v=1589551200" defer async></script>
</div>
<div id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1',false);});</script></div>
</aside>
<script type="text/javascript">document.getElementById("secondary").style.paddingTop=(document.getElementById("article-content-area").getBoundingClientRect().top-document.getElementById("main").getBoundingClientRect().top+15)+"px";window.onload=function(){}</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" class="adslot adslot970 ">
<div id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1',false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/xcsit_dark_t.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.pNfZCdDxNv.png" alt="CloudSavvy IT" class="logo">
</a>
<div class="social">
<a href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%"><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/">
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
</div>
</div>
<style>.footer-email{display:inline-block;float:left;width:33%}#footer-email-text{margin-bottom:5px;font-size:16px;font-family:"Open Sans",sans-serif;margin-top:0}.footer-email form{margin-bottom:10px}.footer-email #ftemtxt{border-radius:0;font-size:16px;padding:8px;height:40px;margin-right:0;border:0;width:250px}.footer-email #ftemsub{border:0;border-radius:0;font-size:14px;padding:8px;height:40px;margin-left:0;background:#f79826;color:#000;font-weight:bold}@media screen and (max-width:768px){.footer-email{display:block;text-align:center;width:100%;border-top:1px solid #999;margin-top:20px;padding-top:15px}}</style>
<div class="footer-email">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input type="hidden" name="list" value="cloudsavvy">
<input type="hidden" name="tr" value="cloudsavvy-footer">
<input type="text" name="email" id="ftemtxt" placeholder="Enter Your Email">
<input type="submit" id="ftemsub" value="Sign Up">
</form>
</div>
<div class="pages">
<ul>
<a href="/about"><li>About</li></a>
<a href="/ethics"><li>Ethics</li></a>
<a href="/privacy-policy"><li>Privacy</li></a>
<a href="/terms-of-use"><li>Terms</li></a>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2020 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-1113647-16');</script>
<!-- Quantcast Tag -->
<script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt);})();_qevents.push({qacct:"p-dPPj_fTCprdm0"});</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page',false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1',false);});</script></div>
<div id="amzn-assoc-ad-26d15b29-c719-4695-a978-d712e16a3766"></div><script async src="https://z-na.associates-amazon.com/onetag/v2?MarketPlace=US&instanceId=26d15b29-c719-4695-a978-d712e16a3766"></script>
</body>
</html>
