<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>
		document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});		document.addEventListener("DOMContentLoaded", function(){
			if(document.cookie.includes('enabledarkmode')){
				document.querySelector('body').classList.add("darkmode");
			}
		});			
	</script>
<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);	</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-16x16.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<link rel="canonical" href="https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/436\/how-to-lock-down-your-aws-resources\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"How to Lock Down Your AWS Resources","name":"How to Lock Down Your AWS Resources","datePublished":"2020-10-07T10:00:11-04:00","dateModified":"2020-10-06T13:25:56-04:00","author":{"@type":"Person","name":"Anthony Heddings"},"description":"AWS is a very secure ecosystem, but they can&#8217;t guarantee that what you do\u00a0in the cloud is going to be secure. That responsibility is left up to you, although AWS will try to nudge you in the right direction.","image":["https:\/\/www.cloudsavvyit.com\/thumbcache\/2\/200\/51ee7f42b4ade130be697680de2d3708\/p\/uploads\/2019\/06\/1037b3fa.png"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="How to Lock Down Your AWS Resources">
<meta name="twitter:description" content="AWS is a very secure ecosystem, but they can&#8217;t guarantee that what you do in the cloud is going to be secure. That responsibility is left up to you, although AWS will try to nudge you in the right direction.">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/thumbcache/600/340/a8db20f3f70c2fa0395c46c0e2adfafb/p/uploads/2019/06/1037b3fa.png">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="How to Lock Down Your AWS Resources"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="AWS is a very secure ecosystem, but they can&#8217;t guarantee that what you do in the cloud is going to be secure. That responsibility is left up to you, although AWS will try to nudge you in the right direction."/>
<meta property="og:image" content="https://www.cloudsavvyit.com/p/uploads/2019/06/1037b3fa.png"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/">
<meta name="description" content="AWS is a very secure ecosystem, but they can&#8217;t guarantee that what you do in the cloud is going to be secure. That responsibility is left up to you, although AWS will try to nudge you in the right direction."/>
<title>How to Lock Down Your AWS Resources &#8211; CloudSavvy IT</title>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 , .related-articles, .affiliate-disclosure, .article-share-widgets {display:none !important;}
	#page::before {
	    content: "CloudSavvy IT";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}


</style>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<script>
var tmntag = tmntag || {};
tmntag.cmd = tmntag.cmd || [];
(function() {
var tmnhead = document.createElement('script');
tmnhead.async = true;
tmnhead.type = 'text/javascript';
tmnhead.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//ads.servebom.com/tmnhead.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(tmnhead, node);
})();
tmntag.cmd.push(function() {
tmntag.placement(4000);
tmntag.start();
});
</script>
</head>
<body class="post-template-default single single-post postid-436 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a aria-hidden="true" tabindex="-1" href="https://www.cloudsavvyit.com">
<img aria-hidden="true" tabindex="-1" role="presentation" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/" title="RSS Feed" aria-label="RSS Feed"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;" aria-hidden="true" tabindex="-1"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="linkedin">
<a title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/company/cloudsavvy-it/">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
</a>
</span>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/cloudsavvyit"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="0">Subscribe</div>
<ul id="topmenu" role="menu">
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul id="menu-header-column-1" class="menu"><li id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul id="menu-header-column-2" class="menu"><li id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul id="menu-header-column-3" class="menu"><li id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul id="menu-header-column-4" class="menu"><li id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<strong class="popsearchheading" role="heading">Popular Searches</strong>
<div class="menu-header-column-1-container"><ul id="menu-header-column-5" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;" aria-hidden="true" tabindex="-1"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
<div style="text-align: center;">
<img style="max-height: 38px; float: right; max-width: 300px; margin-right: 25%;" src=" data:image/gif;base64,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" alt="" role="presentation">
</div>
</div>
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<div id="content" class="site-content" role="main">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" class="adslot adslot970 ">
<div id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1', false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>
.commercemessage {
	width:100%;
	margin:20px 0px;
	padding-left:8px;
	font-size:13px;
	color:#555;
	border-left:3px solid #888;
}
@media screen and (min-width: 1025px) {
	.commercemessage {
		width:1020px;
		line-height:15px;
	}
}
</style>
<article id="post-436" class="post-436 post type-post status-publish format-standard hentry category-aws category-cloud category-uncategorized">
<header id="article-header-area" class="entry-header" aria-label="How to Lock Down Your AWS Resources" role="heading">
<h1 class="entry-title" style="">How to Lock Down Your AWS Resources</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/2c5f75e27762ca292f9660b5e0d85ea7/p/uploads/2019/11/ecebbecf.jpg" alt="" role="presentation">
<span>
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/anthonyheddings/">Anthony Heddings</a></span>
<br/>
<a href="https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/" rel="bookmark"><time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2020-10-07T10:00:11-04:00">October 7, 2020, 10:00am EDT </time><time class="updated" datetime="2020-10-06T13:25:56-04:00">October 6, 2020, 1:25pm EDT </time></a>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="alignnone size-full wp-image-458 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/4288c9530b45501bba1164fdd520710b/p/uploads/2019/06/1037b3fa.png" alt="" width="700" height="300"/></p>
<p>AWS is a very secure ecosystem, but they can&#8217;t guarantee that what you do <em>in</em> the cloud is going to be secure. That responsibility is left up to you, although AWS will try to nudge you in the right direction.</p>
<p>This guide covers what you should do from the AWS Console to make your network and account more secure. In addition to everything here, you&#8217;ll need to make sure your own applications running on your EC2 servers (or otherwise) are themselves secure. For example, <a href="https://www.cloudsavvyit.com/?p=63">enabling HTTPS</a> on a web server, or keeping your dependencies and programs up to date.</p>
<h2>Use Two Factor Authentication For Your AWS Account</h2>
<p>Your main AWS account controls all your AWS resources; if someone were to gain access to it, they&#8217;d have complete control over your resources, and could <a href="https://www.infoworld.com/article/2608076/murder-in-the-amazon-cloud.html?tag=reviewgeek-20">delete everything</a>. You&#8217;ll want to make sure your login method isn&#8217;t just a simple password that could be stolen.</p>
<p>AWS offers a few <a href="https://aws.amazon.com/iam/details/mfa/?tag=reviewgeek-20">multi-factor authentication</a> methods. The easiest to use is Virtual MFA device, which uses apps like Google Authenticator and Authy to turn your phone into a virtual key fob. AWS also supports hardware keys from YubiKEy and Gemalto, but those cost money. Alternatively, you can use SMS, but only for administrative users you add, not your root account.</p>
<p>Click on your account name in the top menu bar, and select &#8220;My Security Credentials.&#8221;</p>
<p><img class="alignnone size-full wp-image-437 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/b038e9d6d71ed7ff77f7cd432649fb11/p/uploads/2019/06/ac37771a.png" alt="" width="700" height="300"/></p>
<p>Under &#8220;Multi-factor Authentication,&#8221; click &#8220;Activate MFA.&#8221;</p>
<p><img class="alignnone size-full wp-image-438 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/37a708832d6a76b8c140abd97b9f7b44/p/uploads/2019/06/277b1aca.png" alt="" width="700" height="300"/></p>
<p>Select &#8220;Virtual MFA Device,&#8221; and open your authenticator app on your phone.</p>
<p><img class="alignnone size-full wp-image-439 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/f2ac691335150aba51dc231f9bafc14b/p/uploads/2019/06/cb42aca9.png" alt="" width="700" height="300"/></p>
<p>AWS will show you a QR code that you should scan with your authenticator app to link the two together. Then you can begin entering codes; AWS will ask for two consecutive codes, so you&#8217;ll have to wait 30 seconds between them. Click &#8220;Assign MFA&#8221; when you&#8217;re done.</p>
<p><img class="alignnone size-full wp-image-440 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/208bd16a918cf4b527839e6ebf15879f/p/uploads/2019/06/1a02c53b.png" alt="" width="700" height="300"/></p>
<p>Now when you sign out, you&#8217;ll be asked for a code from your phone when you log back in.</p>
<p>If you&#8217;re setting up a physical key fob, you&#8217;ll just have to plug it in to link it, and then plug it in every time you want to sign in.</p>
<h2>Close Your Firewalls</h2>
<p>Whenever you create a new EC2 instance, you&#8217;ll be asked to choose a security group or make a new one. This security group is a firewall, and defines which ports will be open. By default, AWS opens port 22 (for SSH) for all IPs coming in, and allows all traffic going out.</p>
<p>This means anyone can attempt to authenticate over SSH, which isn&#8217;t a huge issue (since AWS uses SSH keys by default), but it&#8217;s good practice to limit most traffic to your IP unless it has a reason to be open to the world.</p>
<p>Click on &#8220;Security Groups&#8221; in the sidebar of the EC2 Management Console, select the group your instance uses, select &#8220;Inbound,&#8221; and click &#8220;Edit.&#8221; Alternatively, you can access this security group from the Instances panel by clicking on it under the &#8220;Security groups&#8221; property.</p>
<p><img class="alignnone size-full wp-image-443 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/01c22e6faadbca9b779eaa3b79d5cfba/p/uploads/2019/06/e3372587-2.png" alt="" width="700" height="300"/></p>
<p>From here, you can edit the rules for this security group. Outbound is usually fine to leave open, but inbound should be left as closed as possible. Click on the SSH rule and switch the source from &#8220;Anywhere&#8221; to &#8220;My IP,&#8221; which should close it off.</p>
<p><img class="alignnone size-full wp-image-445 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/bddd814b9a4840e8248a2aaf9d0adb30/p/uploads/2019/06/1ee4e619.png" alt="" width="700" height="300"/></p>
<p>You don&#8217;t have to worry about your IP changing and locking you out, since you can always reset it from the AWS console.</p>
<p>If you have multiple instances talking to each other, such as a database server that connects to an API server, you should secure the connection between them by only allowing secured traffic between the two instances. Nobody else should be able to talk to the database except the API server, with the exception of your IP address for management purposes.</p>
<p>You don&#8217;t have to specify individual IP addresses manually, since AWS will let you allow traffic to all devices assigned a specific security group. If you have multiple database servers, you could give them all the &#8220;database&#8221; security group, and allow your API server to talk to anything with the that security group. You can also allow everything in a specific <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.aws.amazon.com%2Fvpc%2Flatest%2Fuserguide%2FVPC_Subnets.html&key=204a528a336ede4177fff0d84a044482>subnet</a>, which requires you to use <a href="https://aws.amazon.com/vpc/?tag=reviewgeek-20">AWS&#8217;s VPC</a>.</p>
<h2>Set Up IAM Users</h2>
<p>AWS Identity and Access Management (IAM) users are a way to allow access to your account without giving out full permissions. If you have multiple people accessing your AWS resources, you should give them access through an <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.aws.amazon.com%2FIAM%2Flatest%2FUserGuide%2Fid_users.html&key=204a528a336ede4177fff0d84a044482>IAM user</a>. You should never give out access to your root account.</p>
<p>IAM users aren&#8217;t just for other people though; if you have code that needs to access your AWS account, you should allow access through an IAM user. Some AWS services will make use of IAM users to act on resources in your account.</p>
<p>AWS also recommends using an IAM user with administrator permission for all of your normal tasks. This way, you can lock away your root account credentials and only use it when it&#8217;s <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.aws.amazon.com%2Fgeneral%2Flatest%2Fgr%2Faws_tasks-that-require-root.html&key=204a528a336ede4177fff0d84a044482>absolutely necessary</a>, mostly for account maintenance.</p>
<p>IAM users can be assigned very specific permissions, so you can be sure that in the event one of them is compromised, it won&#8217;t affect your entire infrastructure. You can also assign these permissions to role groups, and assign roles to users.</p>
<p><img class="alignnone size-full wp-image-451 imgchk9" src="https://www.cloudsavvyit.com/thumbcache/0/0/0b12e795372103ece3a483677140f8a5/p/uploads/2019/06/277b1aca-1.png" alt="" width="700" height="300"/></p>
<p>You can create new IAM users through the <a href="https://console.aws.amazon.com/iam/home#/home?tag=reviewgeek-20">IAM Management Console</a>. They&#8217;ll be given a randomly generated password, which they&#8217;ll be forced to change on first login. You should apply an <a href="https://console.aws.amazon.com/iam/home#/account_settings?tag=reviewgeek-20">IAM Password Policy</a> to make sure these passwords are secure.</p>
<h2>Perform Regular Security Audits</h2>
<p>You should periodically review your security to make sure there&#8217;s nothing you missed. AWS provides a <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.aws.amazon.com%2Fgeneral%2Flatest%2Fgr%2Faws-security-audit-guide.html&key=204a528a336ede4177fff0d84a044482>very thorough checklist</a> for this exact purpose.</p>
<p>This checklist has you delete old resources that are not in use anymore and review your security policies for different services. The main sources of insecurity are changes in how you use AWS, like if you&#8217;ve started using a new service, stopped using an old one, or have had people leave. In each case, you should review your access policies.</p>
<p>If you&#8217;re not using AWS for an organizational account, it&#8217;s probably not necessary to go down this entire checklist, but you should still make a good habit of looking over your security policies every once in a while.</p>
</div><!-- .entry-content -->
</article><!-- #post-436 -->
<style>
			#content ul#nextuplist {list-style-type: none;margin-left:0px;padding-left:0px;}
			#content ul#nextuplist li {margin-bottom:10px;}
			#content ul#nextuplist li a {text-decoration:none;}
		</style>
<div class="nextup">
<span id="nextuplabel" style="font-weight: bold; font-size: 22px; color: #000; margin-bottom: 10px; display: block;" role="heading">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/400/what-is-a-log-management-tool-and-should-you-use-one/">What is a Log Management Tool, and Should You Use One?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/784/a-cdn-can-speed-up-your-website-heres-what-you-need-to-know/">A CDN Can Speed Up Your Website. Here’s What You Need to Know!</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/852/what-is-git-rebase-and-how-is-it-different-than-merging/">What is Git Rebase and How Is it Different than Merging?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/7132/how-to-protect-your-organization-against-password-dictionary-attacks/">How to Protect Your Organization Against Password Dictionary Attacks</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/6871/how-to-get-started-with-githubs-new-docker-container-registry/">How to Get Started with Github&#8217;s New Docker Container Registry</a></li>
</ul>
</div>
<style>
.shortbioauthor {

	font-weight: bold;
    text-transform: uppercase;
    font-size: 20px;
    text-decoration:none;
    padding-top: 0;
    margin-top: 0;
    line-height: 20px;
}
.shortbioauthor span {
	color:#1d55a9;	
	padding-top: 0;
	margin-top: 0;
}
.shortbioauthordiv {
	border: 1px solid #eee;
	padding: 15px;
	margin-bottom: 20px;
}
.shortbioauthordiv .biotext {
	font-size: 15px;
}
.shortbioauthordiv .biomore {
	text-transform: uppercase;
	font-size: 13px;
	font-weight: bold;
	color:#1d55a9;		
}
</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/b61217adbd4c46bbe0a1cdb699fa5a4f/p/uploads/2019/11/ecebbecf.jpg" alt="Anthony Heddings"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="shortbioauthor"><span>Anthony Heddings</span></a>
<br style="margin-top: 10px;">
<span class="biotext">Anthony Heddings is the resident cloud engineer for LifeSavvy Media, a technical writer, programmer, and an expert at Amazon's AWS platform. He's written hundreds of articles for How-To Geek and CloudSavvy IT that have been read millions of times.
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=How+to+Lock+Down+Your+AWS+Resources+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>
#content .comments p.share-heading {
	font-size: 14px;
    font-weight: bold;
    margin-top: 0;
    line-height: 36px;
    text-decoration: none;
    text-transform: uppercase;
    border: 1px solid #333333;
    background: #333333;
    border-radius: 4px;
    color: #FFF;
    padding-left: 8px;
    padding-right: 8px;
}

@media screen and (max-width: 768px) {
	#content .comments p.share-heading {
		line-height:27px;
	}

}

</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<span class="article-footer-heading">Recently Popular</span>
<article id="post-436">
<a href="https://www.cloudsavvyit.com/436/how-to-lock-down-your-aws-resources/">
<header class="entry-header" style="min-height:100px;" aria-label="How to Lock Down Your AWS Resources" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/606c994ffc1f0e95b7d4579585633118/p/uploads/2019/06/1037b3fa.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">How to Lock Down Your AWS Resources</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-07T10:00:11-04:00">October 7th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-4922">
<a href="https://www.cloudsavvyit.com/4922/how-to-add-new-users-to-your-google-cloud-platform-projects/">
<header class="entry-header" style="min-height:100px;" aria-label="How to Add New Users to Your Google Cloud Platform Projects" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/edf1dac298e982b37f3af9a023847259/p/uploads/2020/04/469724f6.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">How to Add New Users to Your Google Cloud Platform Projects</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-06T09:00:27-04:00">October 6th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-4898">
<a href="https://www.cloudsavvyit.com/4898/a-beginners-guide-to-google-cloud-platform-gcp/">
<header class="entry-header" style="min-height:100px;" aria-label="A Beginner&#8217;s Guide to Google Cloud Platform (GCP)" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/edf1dac298e982b37f3af9a023847259/p/uploads/2020/04/469724f6.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">A Beginner&#8217;s Guide to Google Cloud Platform (GCP)</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-02T11:00:55-04:00">October 2nd</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-692">
<a href="https://www.cloudsavvyit.com/692/what-are-file-permissions-in-linux-and-how-do-i-make-sure-mine-are-secure/">
<header class="entry-header" style="min-height:100px;" aria-label="What Are File Permissions in Linux, and How Do I Make Sure Mine Are Secure?" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/bbd218d17caec26456bd4b2b8a8bbbd9/p/uploads/2019/06/d0f34641-1.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">What Are File Permissions in Linux, and How Do I Make Sure Mine Are Secure?</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-06T11:00:00-04:00">October 6th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-3970">
<a href="https://www.cloudsavvyit.com/3970/5-ways-to-secure-protect-sensitive-data-on-your-server/">
<header class="entry-header" style="min-height:100px;" aria-label="5 Ways to Secure &#038; Protect Sensitive Data on Your Server" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/756009b431ab89bde086cec2208a1651/p/uploads/2020/04/101424eb.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">5 Ways to Secure &#038; Protect Sensitive Data on Your Server</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/mikesherman/" class="p-author vcard author post-author"><span class="fn">Mike Sherman</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-07T09:00:31-04:00">October 7th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-400">
<a href="https://www.cloudsavvyit.com/400/what-is-a-log-management-tool-and-should-you-use-one/">
<header class="entry-header" style="min-height:100px;" aria-label="What is a Log Management Tool, and Should You Use One?" role="heading">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/768045dc94c1c6dae02bb6bc3655398e/p/uploads/2019/06/403dfd6c.png" alt="" role="presentation">	<div class="article-text">
<span class="entry-title article-header">What is a Log Management Tool, and Should You Use One?</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-10-07T08:00:59-04:00">October 7th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	</div>
<script type='text/javascript'>document.write('<img src="/p/uploads/px/436/logo.gif?1602088209" alt="" id="htgstats" style="display:none" />');</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1', false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?v=1602086400" defer async></script>
</div>
<div id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1', false);});</script></div>
</aside>
<script type="text/javascript">
	document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";

	window.onload = function() {
		//document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";
	}
</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" class="adslot adslot970 ">
<div id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1', false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo" alt="" role="presentation">
</a>
<div class="social">
<a title="Facebook" href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1"><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/" aria-hidden="true" tabindex="-1">
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" class="rss-link" href="https://www.linkedin.com/company/cloudsavvy-it/">
<div class="rss" style="background-color:#325f93">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
<p>LinkedIn</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}

</style>
<div class="footer-email">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-footer">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<a href="/about"><li role="menuitem">About</li></a>
<a href="/ethics"><li role="menuitem">Ethics</li></a>
<a href="/privacy-policy"><li role="menuitem">Privacy</li></a>
<a href="/terms-of-use"><li role="menuitem">Terms</li></a>
<li><div id="show-do-not-sell-info-container"/></li>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2020 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-16');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page', false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1', false);});</script></div>
<script type="text/javascript">
let mokaFindParentAnchor = function(elem) {
    if (elem.href) return elem;
    if (elem.parentElement) return mokaFindParentAnchor(elem.parentElement);
    return null;
}
window.addEventListener("click", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null ) {
		e.preventDefault();

		let xmlhttp = new XMLHttpRequest();
	    xmlhttp.onreadystatechange = function() {
	        if (xmlhttp.readyState == XMLHttpRequest.DONE) {
	        	self.location = trueAnchorElem.href;
	        }
	    };

		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var trackDest = 'https://2htg.com/a/cloudsavvy/436/-1/' + amzLink;
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
		
		document.body.style.cursor = 'wait';
	}
});
window.addEventListener("contextmenu", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null) {
		// No need for preventdefault on this version - and no need to listen for finish
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var trackDest = 'https://2htg.com/a/cloudsavvy/436/-1/' + amzLink;
		let xmlhttp = new XMLHttpRequest();
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});
</script>
<div id="amzn-assoc-ad-26d15b29-c719-4695-a978-d712e16a3766"></div><script async src="https://z-na.associates-amazon.com/onetag/v2?MarketPlace=US&instanceId=26d15b29-c719-4695-a978-d712e16a3766"></script>
</body>
</html>
