<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});document.addEventListener("DOMContentLoaded",function(){if(document.cookie.includes('enabledarkmode')){document.querySelector('body').classList.add("darkmode");}});</script>
<script>/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-57x57.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.X4qjwvEy-w.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-60x60.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ZsgiriYp6p.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-72x72.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.2c-VliVhHB.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-76x76.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.-W23JYe9bs.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-114x114.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.YiS-24fen9.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-120x120.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.XGRWxmU8nr.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-144x144.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.Y7cnPtTr9u.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-152x152.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ycAcLBARUK.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xapple-icon-180x180.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.YmoH7R2Hh3.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xandroid-icon-192x192.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.VlQU51G5bV.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-32x32.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.vZfVuJKvuP.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-96x96.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.kV3Wz5oed-.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/xfavicon-16x16.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.mumKW6Z4Mp.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<link rel="canonical" href="https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/4900\/exploring-and-using-the-graph-api-for-azuread\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"Exploring and Using the Graph API for AzureAD","name":"Exploring and Using the Graph API for AzureAD","datePublished":"2020-06-05T09:00:24-04:00","dateModified":"2020-06-04T12:19:27-04:00","author":{"@type":"Person","name":"Adam Bertram"},"description":"The Microsoft GraphAPI is a powerful tool to have. Not only can we use it to create tooling to automate our workloads&#8212;we can also access new functions earlier.","image":["https:\/\/www.cloudsavvyit.com\/thumbcache\/2\/200\/a19ac50166806c7051032befbd7fd6d3\/p\/uploads\/2020\/04\/30fdf294.png"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="Exploring and Using the Graph API for AzureAD">
<meta name="twitter:description" content="The Microsoft GraphAPI is a powerful tool to have. Not only can we use it to create tooling to automate our workloads&#8212;we can also access new functions earlier.">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/thumbcache/600/340/f44674dbf198716950c0711c9f5c250b/p/uploads/2020/04/30fdf294.png">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="Exploring and Using the Graph API for AzureAD"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="The Microsoft GraphAPI is a powerful tool to have. Not only can we use it to create tooling to automate our workloads&#8212;we can also access new functions earlier."/>
<meta property="og:image" content="https://www.cloudsavvyit.com/thumbcache/648/248/78338dad13d5f1570c2d63d235f85c56/p/uploads/2020/04/30fdf294.png"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/">
<meta name="description" content="The Microsoft GraphAPI is a powerful tool to have. Not only can we use it to create tooling to automate our workloads&#8212;we can also access new functions earlier."/>
<title>Exploring and Using the Graph API for AzureAD &#8211; CloudSavvy IT</title>
<style>@media print{#masthead,.full-screen-menu,.adslot,.site-footer,#secondary,#purch_N_C_0_1,.social-media-buttons,.article-bottom,.jw-loaded,#purch_N_C_0_1,.related-articles,.affiliate-disclosure,.article-share-widgets{display:none!important}#page::before{content:"CloudSavvy IT";font-size:24px;font-weight:bold;padding-left:20px;width:700px;border-bottom:1px solid #000;display:block;margin:10px auto}}</style>
<script>var tmntag=tmntag||{};tmntag.cmd=tmntag.cmd||[];(function(){var tmnhead=document.createElement('script');tmnhead.async=true;tmnhead.type='text/javascript';tmnhead.src=('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(tmnhead,node);})();tmntag.cmd.push(function(){tmntag.placement(4000);tmntag.start();});</script>
</head>
<body class="post-template-default single single-post postid-4900 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a href="https://www.cloudsavvyit.com">
<img src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/xcsit_dark_t.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.pNfZCdDxNv.png" alt="CloudSavvy IT" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button">
<span class="hamburger-box">
<span class="hamburger-inner"></span>
</span>
</button>
<svg class="search" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="twitter"><a href="https://twitter.com/cloudsavvyit"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a href="https://www.facebook.com/cloudsavvyit/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button">Subscribe</div>
<ul id="topmenu">
<li id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul id="menu-header-column-1" class="menu"><li id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul id="menu-header-column-2" class="menu"><li id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul id="menu-header-column-3" class="menu"><li id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul id="menu-header-column-4" class="menu"><li id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="">
<input type="submit" value="Go">
</form>
<span class="popsearchheading">Popular Searches</span>
<div class="menu-header-column-1-container"><ul id="menu-header-column-5" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input type="hidden" name="list" value="cloudsavvy">
<input type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input type="text" name="email" id="ftemtxt" placeholder="Your email">
<input type="submit" id="ftemsub" value="Go">
</form>
</div>
</div>
</div>
</div>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" class="adslot adslot970 ">
<div id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1',false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>.commercemessage{width:100%;margin:20px 0;padding-left:8px;font-size:13px;color:#555;border-left:3px solid #888}@media screen and (min-width:1025px){.commercemessage{width:1020px;line-height:15px}}</style>
<article id="post-4900" class="post-4900 post type-post status-publish format-standard hentry category-cloud category-microsoft category-microsoft-azure">
<header id="article-header-area" class="entry-header">
<h1 class="entry-title" style="">Exploring and Using the Graph API for AzureAD</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/d592cd407deff975518e52a4b678d879/p/uploads/2020/03/36x36x50ec1fe8.jpg.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ICZwnNRxPt.jpg" alt="">
<span>
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/adambertram/">Adam Bertram</a></span>
<span style="margin-left:12px;">
<svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;height: 12px;width: 12px;display: inline-block;position: relative;top: 2px;"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"></path></svg>
<span class="author-twitter"><a href="https://twitter.com/@adbertram">@adbertram</a></span></span>
<br/>
<a href="https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/" rel="bookmark"><time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2020-06-05T09:00:24-04:00">June 5, 2020, 9:00am EDT </time><time class="updated" datetime="2020-06-04T12:19:27-04:00">June 4, 2020, 12:19pm EDT </time></a>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="alignnone size-full wp-image-4724" src="https://www.cloudsavvyit.com/thumbcache/0/0/dd73232a7248fcf591e921f5e52164df/p/uploads/2020/04/x30fdf294.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.p9Q8vEsA0Q.jpg" alt="azure logo" width="1400" height="600"/></p>
<p>The Microsoft GraphAPI is a powerful tool to have. Not only can we use it to create tooling to automate our workloads&#8212;we can also access new functions earlier.</p>
<p>In this article, we&#8217;ll learn how to explore and use the Microsoft GraphAPI for Azure AD.</p>
<h2>Prerequisites</h2>
<p>You must meet a few prerequisites before we can begin. Before you begin with the steps outlined in this article, be sure you meet or have the following:</p>
<ul>
<li>An <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fazure%2Factive-directory%2Fdevelop%2Fquickstart-register-app&key=204a528a336ede4177fff0d84a044482>App Registration</a> in AzureAD with the following GraphAPI permissions:
<ul>
<li>Directory.Read.All</li>
<li>Directory.ReadWrite.All</li>
</ul>
</li>
<li>Application Id (client-id) and client-secret for above App Registration</li>
<li>Your Tenant name</li>
<li>A computer running PowerShell version 5.1 or above</li>
</ul>
<p>With that out of the way&#8212;let&#8217;s learn how to explore the GraphAPI.</p>
<h2>Read the Documentation</h2>
<p>The Microsoft GraphAPI is well-documented, and the best place to begin when finding out how to use a new function is to start in the <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fresources%2Fazure-ad-overview%3Fview%3Dgraph-rest-1.0&key=204a528a336ede4177fff0d84a044482>reference documentation</a> of the Microsoft Graph API.</p>
<p>This specifies how to use a specific function and what permissions you need to use it. There are currently two versions of the GraphAPI: v1.0 and the beta API. They may look identical at first, but the beta API contains a lot of new functions that are not yet released. Also be aware that functions in the beta API are subject to change at any time.</p>
<h3>Permissions</h3>
<p>Permissions are an important part of exploring and using the Graph API permissions&#8212;luckily all the permissions that you need to perform a certain action are specified in the <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fdirectoryobject-get%3Fview%3Dgraph-rest-1.0%26amp%3Btabs%3Dhttp&key=204a528a336ede4177fff0d84a044482>reference documentation</a> of that function.</p>
<p>The following screenshot shows the permission needed to use the <code>getDirectoryObject</code> function. And because you will access it as an application, you need the <em>Directory.ReadAll</em> permission.</p>
<p><img class="imgchk9 alignnone wp-image-4901 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/7c51ebfa86cf51728b9655a084676f30/p/uploads/2020/05/x2fd5d90a.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.Fs1M0BUj_d.png" alt="You need the Directory.ReadAll permission to use the getDirectoryObject function." width="1100" height="307"/></p>
<p>Now that you have the basics, let&#8217;s get started by requesting an access token&#8212;a temporary secret that we will use to access the Microsoft Graph API.</p>
<h2>Requesting an Access Token</h2>
<p>The access token is a secret that you can request with our client-id and client-secret. It is this token that you must in the requests towards the GraphAPI.</p>
<p>To request an access token, you need to authorize yourself against the tenant&#8217;s oauth2 endpoint by posting your Application Id and Application Secret.</p>
<p>Edit the following script, replacing AppId, AppSecret, and Tenant name, and run it in PowerShell to request an access token:</p>
<pre><code class="language-powershell">
Add-Type -AssemblyName System.Web

$AppId = 'CHANGEME'
$AppSecret = 'CHANGEME'
$Scope = "https://graph.microsoft.com/.default"
$TenantName = "CHANGEME.onmicrosoft.com"

$Url = "https://login.microsoftonline.com/$TenantName/oauth2/v2.0/token"

$Body = @{
  client_id = $AppId
	client_secret = $AppSecret
	scope = $Scope
	grant_type = 'client_credentials'
}

$PostSplat = @{
    ContentType = 'application/x-www-form-urlencoded'
    Method = 'POST'
    Body = $Body
    Uri = $Url
}

# Request the token!
$Request = Invoke-RestMethod @PostSplat
</code></pre>
<p>Now if you take a look at the <code>$Request</code> variable, you can see that it contains our access token, as well as type and expiration time.</p>
<pre><code class="language-powershell">PS51&gt; $Request

token_type expires_in ext_expires_in access_token                                                                                                      
---------- ---------- -------------- ------------                                                                                                      
Bearer           3599           3599 eyJ...............
</code></pre>
<p>The <em>expires_in</em> is in seconds, which means that you have to request a new token within an hour or it will stop working.</p>
<p>Let us save the access token in a variable for future use and then start making requests towards the GraphApi:</p>
<pre><code class="language-powershell">PS51&gt; $AccessToken = $Request.access_token
</code></pre>
<h2>Your First GraphAPI Request</h2>
<p>It is time for your first graph request! The simplest requests to start with are the requests that utilizes HTTP GET. The GET commands are only for fetching information, so you don&#8217;t need to worry about messing anything up.</p>
<p>We will start out with a simple request listing the domains tied to our tenant. And remember&#8212;read the documentation. All information on how to use the GraphAPI functions is in the <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fdomain-list%3Fview%3Dgraph-rest-1.0%26amp%3Btabs%3Dhttp&key=204a528a336ede4177fff0d84a044482>documentation</a>.</p>
<p>You might have noticed in the documentation for the <em>List Domains</em> command that you can call it by using HTTP GET&#8212;the default method when using <code>Invoke-RestMethod</code>:</p>
<p><img class="imgchk9 alignnone wp-image-4902 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/5ff3ef9818c4fb4781ef0cae487af59a/p/uploads/2020/05/x47aff47e.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.euVixTzC5n.png" alt="You can call a List Domains command using HTTP GET." width="1069" height="570"/></p>
<p>With this information, you can start constructing the request. For that, we need to create an <em>Authorization Header</em> that contains &#8220;Bearer &lt;token&gt;&#8221; and use that to make a GET request towards the URL in the picture above:</p>
<pre><code class="language-powershell">$Headers = @{
    Authorization = "Bearer $AccessToken"
}

$Uri = "https://graph.microsoft.com/v1.0/domains"

$Result = Invoke-RestMethod -Headers $Headers -Uri $Uri
</code></pre>
<p>You now have the list of domains in the <code>$Result</code> variable, but trying to output the value of the <code>$Result</code> variable will result in this:</p>
<pre><code class="language-powershell">PS51&gt; $Result

@odata.context                                     value                                                                                               
--------------                                     -----                                                                                               
&lt;https://graph.microsoft.com/v1.0/$metadata#domains&gt; {@{authenticationType=Managed; availabilityStatus=; id=contoso.com; isAdminManaged=True; isD..
</code></pre>
<p>The result of the query is usually in the <em>value</em> property of the result. You can get the whole result by just outputting that property instead:</p>
<pre><code class="language-powershell">PS51&gt; $Result.value

authenticationType               : Managed
availabilityStatus               : 
id                               : contoso.com
isAdminManaged                   : True
isDefault                        : True
isInitial                        : False
isRoot                           : True
isVerified                       : True
supportedServices                : {Email, Intune}
state                            : 
passwordValidityPeriodInDays     : 2147483647
passwordNotificationWindowInDays : 14

authenticationType               : Managed
availabilityStatus               : 
id                               : contoso.onmicrosoft.com
isAdminManaged                   : True
isDefault                        : False
isInitial                        : True
isRoot                           : True
isVerified                       : True
supportedServices                : {Email, OfficeCommunicationsOnline}
state                            : 
passwordValidityPeriodInDays     : 2147483647
passwordNotificationWindowInDays : 14
</code></pre>
<p>Now that you&#8217;ve learned the basics of getting information with the GraphAPI, it&#8217;s time to learn how to use filters.</p>
<h2>Using Filters</h2>
<p>It is great to be able to fetch all data that are available. And while it may work, it is awfully ineffective. A good practice is to only request the data that you need. To achieve this in the GraphAPI, we can use filters.</p>
<p>A good candidate for trying out filters is by fetching <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fuser-list%3Fview%3Dgraph-rest-1.0%26amp%3Btabs%3Dhttp&key=204a528a336ede4177fff0d84a044482>users</a>. They have a lot of common attribute names to on-prem Active Directory, and you usually have at least a few of them.</p>
<p>The URI for fetching all users is *<a href=http://redirect.viglink.com?u=https%3A%2F%2Fgraph.microsoft.com%2Fv1.0%2Fusers%2A&key=204a528a336ede4177fff0d84a044482>https://graph.microsoft.com/v1.0/users*</a>, but we want to filter this request. You can do that by adding the <em>$filter=&lt;filter&gt;</em> parameter to the URI.</p>
<p>A filter (usually) consists of property operator and a value like this:</p>
<pre><code>property operator 'value'
</code></pre>
<p>If you now want to fetch all users with the <em>givenName</em> &#8220;John,&#8221; the following URI should be used:</p>
<pre><code>https://graph.microsoft.com/v1.0/users?$filter=givenName eq 'John'
</code></pre>
<p>So, if you want to use PowerShell to make this request, the code should look something like this:</p>
<pre><code class="language-powershell">$Uri = "https://graph.microsoft.com/v1.0/users?`$filter=givenName eq 'John'"
$Result = Invoke-RestMethod -Headers $Headers -Uri $Uri

</code></pre>
<p>Notice the backtick before <code>$filter</code>&#8212;that&#8217;s to escape the dollar sign&#8212;else PowerShell would&#8217;ve interpreted it as a variable.</p>
<p>Take a look at the value property,  and you will see all users with a givenName of &#8220;John&#8221; in Azure Active Directory:</p>
<pre><code class="language-powershell">PS51&gt; $Result.value

businessPhones    : {5554012}
displayName       : John Doe
givenName         : John
jobTitle          : 
mail              : jdoe@contoso.com
mobilePhone       : 
officeLocation    : 
preferredLanguage : en
surname           : Doe
userPrincipalName : jdoe@contoso.com
id                : 7fd22087-ec0a-47a1-91fb-0a7d8e6f0c
</code></pre>
<p>&#8216;EQ&#8217; is not the only operator, you have not (ne), match, contains, less/greater than (lt/gt), and a whole lot more. While out of the scope of this article, more information about operators is available in the <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fquery-parameters&key=204a528a336ede4177fff0d84a044482>documentation</a>. Also more extensive documentation about the different filter properties is available in the property <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fresources%2Fuser%3Fview%3Dgraph-rest-1.0&key=204a528a336ede4177fff0d84a044482>documentation</a> about each object type.</p>
<h2>Creating a User</h2>
<p>Now that you got the basics, let&#8217;s perform a write operation and create a user. For that, you need to know how to construct the data and where to POST it. You can see an example on how to perform that by going to the Microsoft Graph API documentation and looking at <a href=http://redirect.viglink.com?u=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fgraph%2Fapi%2Fuser-post-users%3Fview%3Dgraph-rest-1.0%26amp%3Btabs%3Dhttp&key=204a528a336ede4177fff0d84a044482>&#8220;Create User&#8221;</a>:</p>
<p><img class="imgchk9 alignnone wp-image-4903 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/4b41e28050b2ab15f80290ef3c27bff1/p/uploads/2020/05/xc5511bf0.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.jeazS3QVeN.png" alt="Perform a write operation and create a user." width="1049" height="432"/></p>
<p>You can see that you need to send the data as a POST request, and that the content type should be of <em>application/json.</em> You can also see a JSON representation of the data&#8212;the goal here is to create a PowerShell object that creates that JSON when <code>ConvertTo-Json</code> is used on it.</p>
<p>Let&#8217;s have a go at it:</p>
<pre><code class="language-powershell">$Body = [PSCustomObject]@{
    accountEnabled = $True
    displayName = "Jane Doe"
    mailNickname = "janedoe"
    userPrincipalName = "jane.doe@automativity.com"
    passwordProfile = @{
        forceChangePasswordNextSignIn = $True
        password = "Hunter221!"
    }
}
</code></pre>
<p>Running <code>$Body | ConvertTo-Json</code> will result in a similar JSON as the one displayed in the documentation. What&#8217;s left now is to convert it to JSON and POST it to the GraphAPI URI with the right content-type:</p>
<pre><code class="language-powershell">$Body = [PSCustomObject]@{
    accountEnabled = $True
    displayName = "Jane Doe"
    mailNickname = "janedoe"
    userPrincipalName = "jane.doe@contoso.com"
    passwordProfile = @{
        forceChangePasswordNextSignIn = $True
        password = "Hunter221!"
    }
}

$BodyJson = $Body | ConvertTo-Json
$Uri = "https://graph.microsoft.com/v1.0/users"

Invoke-RestMethod -Uri $Uri -Headers $Headers -Method POST -ContentType application/json -Body $BodyJson
</code></pre>
<p>If you now go to our Azure Active Directory Console and have a look, you will find the newly created user:</p>
<p><img class="imgchk9 alignnone wp-image-4904 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/f7c141f8ae1e9eaa3903cdaf7d306171/p/uploads/2020/05/x7d371b23.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.7wwVutPlh0.png" alt="The newly created user in the Azure Active Directory Console." width="961" height="163"/></p>
<p>You have now created your first user using GraphAPI!</p>
<h2>Conclusion</h2>
<p>The Microsoft GraphAPI is a powerful tool and will enable you to automate your environment even further. And not just when it comes to Azure Active Directory&#8212;but also for the majority of SaaS services that Microsoft offers.</p>
<p>Also considering the &#8220;serverless&#8221; movement using Azure Functions or AWS Lambda in an event, it&#8217;s possible to create minimalistic and event-driven functions to automate as much as possible in your environment. All without the need to include large libraries into your functions.</p>
</div><!-- .entry-content -->
</article><!-- #post-4900 -->
<style>#content ul#nextuplist{list-style-type:none;margin-left:0;padding-left:0}#content ul#nextuplist li{margin-bottom:10px}#content ul#nextuplist li a{text-decoration:none}</style>
<div class="nextup">
<span id="nextuplabel" style="font-weight: bold;
					    font-size: 22px;
					    color: #000;
					    margin-bottom: 10px;
					    display: block;">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/3270/how-to-use-aws-vpn-to-lock-down-access-to-your-servers/">How to Use AWS VPN to Lock Down Access to Your Servers</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/3103/how-to-roll-your-own-dynamic-dns-with-aws-route-53/">How to Roll Your Own Dynamic DNS with AWS Route 53</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/2097/how-much-performance-does-your-cloud-server-really-need/">How Much Performance Does Your Cloud Server Really Need?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/3864/should-you-care-about-ipv6-connectivity-for-your-web-server/">Should You Care About IPv6 Connectivity For Your Web Server?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/2817/should-you-use-a-git-alternative/">Should You Use a Git Alternative?</a></li>
</ul>
</div>
<style>.shortbioauthor{font-weight:bold;text-transform:uppercase;font-size:20px;text-decoration:none;padding-top:0;margin-top:0;line-height:20px}.shortbioauthor span{color:#1d55a9;padding-top:0;margin-top:0}.shortbioauthordiv{border:1px solid #eee;padding:15px;margin-bottom:20px}.shortbioauthordiv .biotext{font-size:15px}.shortbioauthordiv .biomore{text-transform:uppercase;font-size:13px;font-weight:bold;color:#1d55a9}</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/adambertram/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/d95faed0363d39493a6b813ebe328651/p/uploads/2020/03/100xNx50ec1fe8.jpg.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.0PLIQLTOy6.jpg" alt="Adam Bertram"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/adambertram/" class="shortbioauthor"><span>Adam Bertram</span></a>
<br style="margin-top: 10px;">
<span class="biotext">Adam Bertram is a 20+ year veteran of IT and an experienced online business professional. He’s a consultant, Microsoft MVP, blogger, trainer, published author and content marketer for multiple technology companies. Catch up on Adam’s articles at <a href="http://adamtheautomator.com/"><u>adamtheautomator.com</u></a>, connect on <a href="https://www.linkedin.com/in/adbertram"><u>LinkedIn</u></a>, or follow him on Twitter at <a href="https://twitter.com/adbertram"><u>@adbertram</u></a><u>.</u>
<a href="https://www.cloudsavvyit.com/author/adambertram/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=Exploring+and+Using+the+Graph+API+for+AzureAD+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/4900/exploring-and-using-the-graph-api-for-azuread/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>#content .comments p.share-heading{font-size:14px;font-weight:bold;margin-top:0;line-height:36px;text-decoration:none;text-transform:uppercase;border:1px solid #333;background:#333;border-radius:4px;color:#fff;padding-left:8px;padding-right:8px}@media screen and (max-width:768px){#content .comments p.share-heading{line-height:27px}}</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<span class="article-footer-heading">Recently Popular</span>
<article id="post-3163">
<a href="https://www.cloudsavvyit.com/3163/how-to-use-awss-api-gateway-as-a-frontend-for-lambda-functions/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/cc14b1944c338b2113ae099d10d547ff/p/uploads/2019/12/xcac0324d.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.DUA8Ko0RBb.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How to Use AWS&#8217;s API Gateway as a Frontend for Lambda Functions</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-03T10:00:52-04:00">June 3rd</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-3103">
<a href="https://www.cloudsavvyit.com/3103/how-to-roll-your-own-dynamic-dns-with-aws-route-53/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/4103e3b744a40aeba5f967ce6d68061c/p/uploads/2019/09/x7744a78e.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.k6POnjGlk5.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How to Roll Your Own Dynamic DNS with AWS Route 53</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-04T10:00:13-04:00">June 4th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-3135">
<a href="https://www.cloudsavvyit.com/3135/how-to-transfer-a-domain-name-to-aws-route-53/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/4103e3b744a40aeba5f967ce6d68061c/p/uploads/2019/09/x7744a78e.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.k6POnjGlk5.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How to Transfer a Domain Name to AWS Route 53</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-01T10:00:22-04:00">June 1st</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-921">
<a href="https://www.cloudsavvyit.com/921/how-do-you-actually-use-regex/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/1eb4a62e4b1e86e6b328e78393764e2d/p/uploads/2019/06/xb0582a06.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.PHGh5pNWdF.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How Do You Actually Use Regex?</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-03-11T09:00:00-04:00">March 11th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-3270">
<a href="https://www.cloudsavvyit.com/3270/how-to-use-aws-vpn-to-lock-down-access-to-your-servers/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/f1d2f2866e8547e0a1820cbc7d208b9f/p/uploads/2019/12/xbf13de03.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.ESJoYBjHsM.png"/>	<div class="article-text">
<span class="entry-title article-header">How to Use AWS VPN to Lock Down Access to Your Servers</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-05T10:00:28-04:00">June 5th</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	<article id="post-3194">
<a href="https://www.cloudsavvyit.com/3194/how-to-set-up-a-custom-domain-for-awss-api-gateway/">
<header class="entry-header" style="min-height:100px;">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/0777ddd05a5c6a7961d372e622d3ea80/p/uploads/2019/09/x821c14ca.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.DYbFYewhoL.jpg"/>	<div class="article-text">
<span class="entry-title article-header">How to Set Up a Custom Domain for AWS&#8217;s API Gateway</span>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-02T10:00:56-04:00">June 2nd</time></div>
</div>
</header><!-- .entry-header -->
</a>
<div style="clear:both;"></div>
</article><!-- #post-## -->	</div>
<script type='text/javascript'>document.write('<img src="/p/uploads/px/4900/logo.gif?1591372249" alt="" id="htgstats" style="display:none" />');</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1',false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?v=1591369200" defer async></script>
</div>
<div id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1',false);});</script></div>
</aside>
<script type="text/javascript">document.getElementById("secondary").style.paddingTop=(document.getElementById("article-content-area").getBoundingClientRect().top-document.getElementById("main").getBoundingClientRect().top+15)+"px";window.onload=function(){}</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" class="adslot adslot970 ">
<div id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1',false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/xcsit_dark_t.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.pNfZCdDxNv.png" alt="CloudSavvy IT" class="logo">
</a>
<div class="social">
<a href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%"><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/">
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
</div>
</div>
<style>.footer-email{display:inline-block;float:left;width:33%}#footer-email-text{margin-bottom:5px;font-size:16px;font-family:"Open Sans",sans-serif;margin-top:0}.footer-email form{margin-bottom:10px}.footer-email #ftemtxt{border-radius:0;font-size:16px;padding:8px;height:40px;margin-right:0;border:0;width:250px}.footer-email #ftemsub{border:0;border-radius:0;font-size:14px;padding:8px;height:40px;margin-left:0;background:#f79826;color:#000;font-weight:bold}@media screen and (max-width:768px){.footer-email{display:block;text-align:center;width:100%;border-top:1px solid #999;margin-top:20px;padding-top:15px}}</style>
<div class="footer-email">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input type="hidden" name="list" value="cloudsavvy">
<input type="hidden" name="tr" value="cloudsavvy-footer">
<input type="text" name="email" id="ftemtxt" placeholder="Enter Your Email">
<input type="submit" id="ftemsub" value="Sign Up">
</form>
</div>
<div class="pages">
<ul>
<a href="/about"><li>About</li></a>
<a href="/ethics"><li>Ethics</li></a>
<a href="/privacy-policy"><li>Privacy</li></a>
<a href="/terms-of-use"><li>Terms</li></a>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2020 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-1113647-16');</script>
<!-- Quantcast Tag -->
<script type="text/javascript">var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt);})();_qevents.push({qacct:"p-dPPj_fTCprdm0"});</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page',false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1',false);});</script></div>
</body>
</html>
