<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>
		document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});	</script>
<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);	</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-16x16.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<link rel="canonical" href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/8669\/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?","name":"What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?","datePublished":"2020-12-23T08:00:19-05:00","dateModified":"2020-12-23T04:47:43-05:00","author":{"@type":"Person","name":"Anthony Heddings"},"description":"Everyone is going ARM these days&#8212;Amazon and Apple are both shipping in-house CPUs with crazy performance increases, with Microsoft rumored to be developing their own. ARM has historically been used for low power mobile chips, so why exactly is ARM crushing x86 on the desktop and server space?","image":["https:\/\/www.cloudsavvyit.com\/thumbcache\/2\/200\/c0032eaaa45ac7d1c5c432255ac036eb\/p\/uploads\/2020\/12\/81524717.png"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?">
<meta name="twitter:description" content="Everyone is going ARM these days&#8212;Amazon and Apple are both shipping in-house CPUs with crazy performance increases, with Microsoft rumored to be developing their own. ARM has historically been used for low power mobile chips, so why exactly is ARM crushing x86 on the desktop and server space?">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/thumbcache/600/340/76853b7a66cc7d746d244b40b9f0dc23/p/uploads/2020/12/81524717.png">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="Everyone is going ARM these days&#8212;Amazon and Apple are both shipping in-house CPUs with crazy performance increases, with Microsoft rumored to be developing their own. ARM has historically been used for low power mobile chips, so why exactly is ARM crushing x86 on the desktop and server space?"/>
<meta property="og:image" content="https://www.cloudsavvyit.com/p/uploads/2020/12/81524717.png"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/">
<meta name="description" content="Everyone is going ARM these days&#8212;Amazon and Apple are both shipping in-house CPUs with crazy performance increases, with Microsoft rumored to be developing their own. ARM has historically been used for low power mobile chips, so why exactly is ARM crushing x86 on the desktop and server space?"/>
<title>What Are ARM CPUs, and Are They Going To Replace x86 (Intel)? &#8211; CloudSavvy IT</title>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 , .related-articles, .affiliate-disclosure, .article-share-widgets {display:none !important;}
	#page::before {
	    content: "CloudSavvy IT";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}


</style>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<script>
var tmntag = tmntag || {};
tmntag.cmd = tmntag.cmd || [];
(function() {
var tmnhead = document.createElement('script');
tmnhead.async = true;
tmnhead.type = 'text/javascript';
tmnhead.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//ads.servebom.com/tmnhead.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(tmnhead, node);
})();
tmntag.cmd.push(function() {
tmntag.placement(3999);
tmntag.start();
});
</script>
</head>
<body class="post-template-default single single-post postid-8669 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a aria-hidden="true" tabindex="-1" focusable="false" href="https://www.cloudsavvyit.com">
<img aria-hidden="true" tabindex="-1" focusable="false" role="presentation" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/" title="RSS Feed" aria-label="RSS Feed"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="linkedin">
<a title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/company/cloudsavvy-it/">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1" focusable="false"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
</a>
</span>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/cloudsavvyit"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="-1">Subscribe</div>
<ul id="topmenu" role="menu">
<li role="menuitem" id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li role="menuitem" id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul id="menu-header-column-1" class="menu"><li role="menuitem" id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul id="menu-header-column-2" class="menu"><li role="menuitem" id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul id="menu-header-column-3" class="menu"><li role="menuitem" id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li role="menuitem" id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
<li role="menuitem" id="menu-item-7620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7620"><a href="https://www.cloudsavvyit.com/newsletter">Newsletter</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul id="menu-header-column-4" class="menu"><li role="menuitem" id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li role="menuitem" id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li role="menuitem" id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<strong class="popsearchheading" role="heading" aria-level="1">Popular Searches</strong>
<div class="menu-header-column-1-container"><ul id="menu-header-column-5" class="menu"><li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="postid" id="header_transient_postid" value="-1">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
<div style="text-align: center;">
<img style="max-height: 38px; float: right; max-width: 300px; margin-right: 25%;" src=" data:image/gif;base64,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" alt="" role="presentation">
</div>
</div>
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<script>
			let header_transient_postid = document.getElementById('header_transient_postid');
			if (header_transient_postid) {
				header_transient_postid.value = 8669;
			}
		</script>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" class="adslot adslot970 ">
<div id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1', false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>
.commercemessage {
	width:100%;
	margin:20px 0px;
	padding-left:8px;
	font-size:13px;
	color:#555;
	border-left:3px solid #888;
}
@media screen and (min-width: 1025px) {
	.commercemessage {
		width:1020px;
		line-height:15px;
	}
}
</style>
<article id="post-8669" class="post-8669 post type-post status-publish format-standard hentry category-uncategorized tag-splashbox">
<header id="article-header-area" class="entry-header" aria-label="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" role="heading" aria-level="2">
<h1 class="entry-title" style="">What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/2c5f75e27762ca292f9660b5e0d85ea7/p/uploads/2019/11/ecebbecf.jpg" alt="" role="presentation">
<span>
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/anthonyheddings/">Anthony Heddings</a></span>
<br/>
<a aria-label="&lt;time style=&quot;font-size:12px;text-transform:uppercase;color:#666;&quot; class=&quot;entry-date published&quot; datetime=&quot;2020-12-23T08:00:19-05:00&quot;&gt;December 23, 2020, 8:00am EDT &lt;/time&gt;&lt;time class=&quot;updated&quot; datetime=&quot;2020-12-23T04:47:43-05:00&quot;&gt;December 23, 2020, 4:47am EDT &lt;/time&gt;" href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/" rel="bookmark"><time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2020-12-23T08:00:19-05:00">December 23, 2020, 8:00am EDT </time><time class="updated" datetime="2020-12-23T04:47:43-05:00">December 23, 2020, 4:47am EDT </time></a>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<figure id="attachment_8687" style="width: 700px" class="wp-caption alignnone"><img class="wp-image-8687 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/9682b124dfee6f4777560d092ec770b7/p/uploads/2020/12/81524717.png" alt="" width="700" height="300" data-crediturl="https://www.shutterstock.com/image-photo/modern-high-tech-authentic-robot-arm-1501235957" data-credittext="Shutterstock/Gorodenkoff"/><figcaption class="wp-caption-text"><span class="imagecredit"><a href="https://www.shutterstock.com/image-photo/modern-high-tech-authentic-robot-arm-1501235957">Shutterstock/Gorodenkoff</a></span></figcaption></figure>
<p>Everyone is going ARM these days&#8212;Amazon and Apple are both shipping in-house CPUs with crazy performance increases, with Microsoft rumored to be developing their own. ARM has historically been used for low power mobile chips, so why exactly is ARM crushing x86 on the desktop and server space?</p>
<h2 role="heading" aria-level="2">Everyone Is Going ARM These Days</h2>
<p>The processor world is a complex industry, and only a few designs from a few companies are able to compete on the high end of performance. Usually, Intel or AMD holds the crown of performance, with both of them manufacturing x86 CPUs. But recently, CPUs from Apple and Amazon based on ARM have been giving Intel (and the x86 architecture) a run for their money.</p>
<p>Amazon has their Graviton2 CPU, which isn&#8217;t faster than Intel&#8217;s server counterparts, but is more cost effective and uses less power. With how much of an improvement it was over Graviton1, their next iteration will likely be fierce competition in the server space.</p>
<p>Apple hit it out of the park with their first non-mobile CPU, the Apple Silicon M1 processor, which runs faster than desktop Intel CPUs and nearly as fast as AMD&#8217;s Ryzen 5000 series, the current performance crown. It&#8217;s custom silicon which makes Apple Macbooks the current fastest laptops in the world, much to the chagrin of PC enthusiasts (myself included).</p>
<p><img class="alignnone size-full wp-image-8689" src="https://www.cloudsavvyit.com/thumbcache/0/0/e1c867dd93e957a75c25da86cea5e171/p/uploads/2020/12/2c8cf196.png" alt="" width="700" height="300"/></p>
<p>In fact, they&#8217;re so far ahead in the laptop space that <a href="https://www.macworld.co.uk/news/apple-m1-runs-windows-faster-3798990/#:~:text=Apple%27s%20new%20M1%20processor%20can,Microsoft%27s%20Surface%20Pro%20X%20series.&amp;text=When%20running%20the%20ARM%20version,multi%2Dcore%20rating%20of%204%2C769.">Windows on the M1 Macbook runs faster than the Surface Pro X</a>, despite Windows on ARM only running <em>through an emulator.</em> And as if that wasn&#8217;t humiliating enough, it absolutely crushes it with a Geekbench Single-Core score of 1,390 compared the Surface&#8217;s 802, which is laughably bad in comparison. The M1 is seriously fast.</p>
<p>Microsoft is also <a href="https://arstechnica.com/gadgets/2020/12/microsoft-may-be-developing-its-own-in-house-arm-cpu-designs/">rumored to be developing their own in-house ARM processor</a>, and though that rumor comes from the Azure server space, they&#8217;d likely use the same chip for the Surface if they can match Apple&#8217;s performance.</p>
<h2 role="heading" aria-level="2">What&#8217;s The Difference Between ARM and x86?</h2>
<p>At the end of the day, there isn&#8217;t too much of a difference between ARM and x86. You can still run Google Chrome and watch YouTube on either one. In fact, you may be doing so right now, as nearly all Androids and every iPhone uses an ARM-based processor.</p>
<p>The biggest difference for most people is that older applications meant for x86 will need to be recompiled to run on ARM as well. For some things this is easy, but not everything will be supported, especially legacy software. However, even that <a href="https://blogs.windows.com/windows-insider/2020/12/10/introducing-x64-emulation-in-preview-for-windows-10-on-arm-pcs-to-the-windows-insider-program/">can usually run through x86 emulation</a>, which Windows is starting to support.</p>
<p>For developers, there are a lot of differences in how applications get compiled, but these days, most compilers do a good job of supporting the major instruction sets, and you won&#8217;t really have to make many changes to get it compiling for multiple platforms.</p>
<h2 role="heading" aria-level="2">But How is ARM Running Faster?</h2>
<p>To answer this question, we&#8217;ll have to delve deeper into how CPUs work under the hood.</p>
<p>ARM and x86 are both <em>instruction sets</em>, also known as <em>architectures, </em>which basically are a list of micro-code &#8220;programs&#8221; that the CPU supports. This is why you don&#8217;t need to worry about running a Windows app on a specific AMD or Intel CPU; they&#8217;re both x86 CPUs, and while the exact designs are different (and perform differently), they both support the same instructions. This means any program compiled for x86 will, in general, support both CPUs.</p>
<p>CPUs basically execute operations sequentially, like a machine given a list of tasks to do. Each instruction is known as an <em>opcode,</em> and architectures like x86 have a lot of opcodes, especially considering they&#8217;ve been around for decades. Because of this complexity, x86 is known as a &#8220;Complex Instruction Set,&#8221; or CISC.</p>
<p>CISC architectures generally take the design approach of packing a lot of stuff into a single instruction. For example, an instruction for multiplication may move data from a memory bank to a register, then perform the steps for the multiplication, and shuffle the results around in memory. All in one instruction.</p>
<p>Under the hood though, this instruction gets unpacked into many &#8220;micro-ops,&#8221; which the CPU executes. The benefit of CISC is memory usage, and since back in the day it was at a premium, CISC used to be better.</p>
<p><img class="alignnone size-full wp-image-8688" src="https://www.cloudsavvyit.com/thumbcache/0/0/3ce26cb700b6882c7823fbd0b1d2982e/p/uploads/2020/12/a2d0d6b9.png" alt="" width="700" height="375"/></p>
<p>However, that&#8217;s not the bottleneck anymore, and this is where RISC comes into play. RISC, or Reduced Instruction Set, basically does away with complex multi-part instructions. Each instruction mostly can execute in a single clock cycle, though many long operations will need to wait on results from other areas of the CPU or memory.</p>
<p>While this seems like going backwards, it has huge implications for CPU design. CPUs need to load all their instructions from RAM and execute them as fast as possible. It turns out it&#8217;s far easier to do that when you have many simple instructions versus a lot of complex ones. The CPU runs faster when the instruction buffer can be filled up, and that&#8217;s a lot easier to do when the instructions are smaller and easier to process.</p>
<p>RISC also has the benefit of something called Out-of-Order execution, or OoOE. Essentially, the CPU has a unit inside of it that reorders and optimizes instructions coming into it. For example, if an application needs to calculate two things, but they don&#8217;t depend on each other, the CPU can execute both in parallel. Usually, parallel code is very complicated for developers to write, but at the lowest levels of the CPU, it can make use of multi-tasking to speed things up. The Apple M1 chip uses OoOE to great effect.</p>
<p>If you&#8217;re interested in the inner workings, you should <a href="https://debugger.medium.com/why-is-apples-m1-chip-so-fast-3262b158cba2">read this fantastic write-up by Erik Engheim on what makes the Apple M1 chip so fast</a>. In short, it makes heavy usage of specialized silicon, Out-of-order execution, and having way more instruction decoders to support its speed.</p>
<h2 role="heading" aria-level="2">Is ARM Going To Replace x86?</h2>
<p><img class="alignnone size-full wp-image-8697" src="https://www.cloudsavvyit.com/thumbcache/0/0/af5a8e78ed9a6789030f327b9912bee9/p/uploads/2020/12/9a116768.png" alt="" width="700" height="318"/></p>
<p>The honest answer is, <strong>probably</strong>. Intel has been feeling the end of Moore&#8217;s law for years now, and while AMD has been able to make performance leaps in recent years, they&#8217;re not far ahead.</p>
<p>This isn&#8217;t to say that x86 will die off anytime soon, but it&#8217;s clear that ARM has more potential than just being a mobile architecture&#8212;a stigma which is no longer valid given the current direction of the industry. The benefits of RISC architectures are clear, and with how much the Apple M1 chip has already improved, the future of the industry looks promising.</p>
<p>Plus, ARM isn&#8217;t the only RISC architecture out there. It&#8217;s still proprietary, though ARM licenses its designs to third-party designers, like Qualcomm, Samsung, and Apple. RISC-V is open source, and is similarly promising. It&#8217;s a standardized instruction set architecture, leaving the exact implementations up to the manufacturer. If the industry does move towards RISC in general, there will be open and closed source implementations available.</p>
</div><!-- .entry-content -->
</article><!-- #post-8669 -->
<style>
			#content ul#nextuplist {list-style-type: none;margin-left:0px;padding-left:0px;}
			#content ul#nextuplist li {margin-bottom:10px;}
			#content ul#nextuplist li a {text-decoration:none;}
		</style>
<div class="nextup">
<span id="nextuplabel" role="heading" aria-level="2">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/">What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8647/why-do-they-spell-phishing-with-ph-an-unlikely-homage/">Why Do They Spell Phishing With &#8216;ph?&#8217; An Unlikely Homage</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8629/getting-started-with-gitlabs-continuous-integration-deployment-pipelines-ci-cd/">Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/7152/how-to-rotate-and-delete-old-elasticsearch-records-after-a-month/">How To Rotate and Delete Old Elasticsearch Records After a Month</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8549/from-lone-wolf-to-organised-crime-where-cyber-threats-come-from/">From Lone Wolf to Organised Crime &#8211; Where Cyber Threats Come From</a></li>
</ul>
</div>
<style>
.shortbioauthor {

	font-weight: bold;
    text-transform: uppercase;
    font-size: 20px;
    text-decoration:none;
    padding-top: 0;
    margin-top: 0;
    line-height: 20px;
}
.shortbioauthor span {
	color:#1d55a9;	
	padding-top: 0;
	margin-top: 0;
}
.shortbioauthordiv {
	border: 1px solid #eee;
	padding: 15px;
	margin-bottom: 20px;
}
.shortbioauthordiv .biotext {
	font-size: 15px;
}
.shortbioauthordiv .biomore {
	text-transform: uppercase;
	font-size: 13px;
	font-weight: bold;
	color:#1d55a9;		
}
</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/b61217adbd4c46bbe0a1cdb699fa5a4f/p/uploads/2019/11/ecebbecf.jpg" alt="Anthony Heddings"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="shortbioauthor"><span>Anthony Heddings</span></a>
<br style="margin-top: 10px;">
<span class="biotext">Anthony Heddings is the resident cloud engineer for LifeSavvy Media, a technical writer, programmer, and an expert at Amazon's AWS platform. He's written hundreds of articles for How-To Geek and CloudSavvy IT that have been read millions of times.
<a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a title="Share on Facebook" aria-label="Share on Facebook" class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a title="Share on Twitter" aria-label="Share on Twitter" class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=What+Are+ARM+CPUs%2C+and+Are+They+Going+To+Replace+x86+%28Intel%29%3F+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>
#content .comments p.share-heading {
	font-size: 14px;
    font-weight: bold;
    margin-top: 0;
    line-height: 36px;
    text-decoration: none;
    text-transform: uppercase;
    border: 1px solid #333333;
    background: #333333;
    border-radius: 4px;
    color: #FFF;
    padding-left: 8px;
    padding-right: 8px;
}

@media screen and (max-width: 768px) {
	#content .comments p.share-heading {
		line-height:27px;
	}

}

</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<span class="article-footer-heading">Recently Popular</span>
<article id="post-8669">
<header class="entry-header" style="min-height:100px;" aria-label="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" aria-label="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/3d82ed90643e54441a244dad28f16ae6/p/uploads/2020/12/81524717.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" aria-label="What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?" href="https://www.cloudsavvyit.com/8669/what-are-arm-cpus-and-are-they-going-to-replace-x86-intel/">
<span class="entry-title article-header">What Are ARM CPUs, and Are They Going To Replace x86 (Intel)?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-23T08:00:19-05:00">December 23rd</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-4145">
<header class="entry-header" style="min-height:100px;" aria-label="How Do SSL Certificates Secure the Web?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="How Do SSL Certificates Secure the Web?" aria-label="How Do SSL Certificates Secure the Web?" href="https://www.cloudsavvyit.com/4145/how-do-ssl-certificates-secure-the-web/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/f4fe97a9cbf94d313607d605b9b6c389/p/uploads/2020/03/93b8da07.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="How Do SSL Certificates Secure the Web?" aria-label="How Do SSL Certificates Secure the Web?" href="https://www.cloudsavvyit.com/4145/how-do-ssl-certificates-secure-the-web/">
<span class="entry-title article-header">How Do SSL Certificates Secure the Web?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/mikesherman/" class="p-author vcard author post-author"><span class="fn">Mike Sherman</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-16T09:00:19-05:00">December 16th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8569">
<header class="entry-header" style="min-height:100px;" aria-label="What Does An Interface Do in Object-Oriented Programming?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="What Does An Interface Do in Object-Oriented Programming?" aria-label="What Does An Interface Do in Object-Oriented Programming?" href="https://www.cloudsavvyit.com/8569/what-does-an-interface-do-in-object-oriented-programming/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/af9261eb9d614144988213c6daf13f16/p/uploads/2020/08/b476fc9b.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="What Does An Interface Do in Object-Oriented Programming?" aria-label="What Does An Interface Do in Object-Oriented Programming?" href="https://www.cloudsavvyit.com/8569/what-does-an-interface-do-in-object-oriented-programming/">
<span class="entry-title article-header">What Does An Interface Do in Object-Oriented Programming?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-15T09:00:42-05:00">December 15th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-2097">
<header class="entry-header" style="min-height:100px;" aria-label="How Much Performance Does Your Cloud Server Really Need?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="How Much Performance Does Your Cloud Server Really Need?" aria-label="How Much Performance Does Your Cloud Server Really Need?" href="https://www.cloudsavvyit.com/2097/how-much-performance-does-your-cloud-server-really-need/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/9569d61aa5dabc7daec2e7e9459fb206/p/uploads/2020/06/83469162.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="How Much Performance Does Your Cloud Server Really Need?" aria-label="How Much Performance Does Your Cloud Server Really Need?" href="https://www.cloudsavvyit.com/2097/how-much-performance-does-your-cloud-server-really-need/">
<span class="entry-title article-header">How Much Performance Does Your Cloud Server Really Need?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-01T11:00:25-04:00">June 1st</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8629">
<header class="entry-header" style="min-height:100px;" aria-label="Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)" aria-label="Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)" href="https://www.cloudsavvyit.com/8629/getting-started-with-gitlabs-continuous-integration-deployment-pipelines-ci-cd/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/70da8b28855d4dd953491ebfd82973ad/p/uploads/2019/10/73a5aadf.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)" aria-label="Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)" href="https://www.cloudsavvyit.com/8629/getting-started-with-gitlabs-continuous-integration-deployment-pipelines-ci-cd/">
<span class="entry-title article-header">Getting Started With GitLab&#8217;s Continuous Integration &#038; Deployment Pipelines (CI/CD)</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-21T08:00:52-05:00">December 21st</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8514">
<header class="entry-header" style="min-height:100px;" aria-label="Why Cyber Criminals Love Cellphones" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="Why Cyber Criminals Love Cellphones" aria-label="Why Cyber Criminals Love Cellphones" href="https://www.cloudsavvyit.com/8514/why-cyber-criminals-love-cellphones/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/ff957368900535c68915078296c6e9c5/p/uploads/2020/12/125d19da.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="Why Cyber Criminals Love Cellphones" aria-label="Why Cyber Criminals Love Cellphones" href="https://www.cloudsavvyit.com/8514/why-cyber-criminals-love-cellphones/">
<span class="entry-title article-header">Why Cyber Criminals Love Cellphones</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/davidmckay/" class="p-author vcard author post-author"><span class="fn">Dave McKay</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-14T08:00:46-05:00">December 14th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
</div>
<script type='text/javascript'>
			var htg = -1;
			var htgm = document.cookie.match('htg=([0-9]*)');
			if (htgm && htgm.length == 2) {
				htg = htgm[1];
			}
			document.write('<img src="https://www.cloudsavvyit.com/lambda-uploads/cloudsavvy/8669/' + htg + '/logo.gif?1608732535" alt="" id="htgstats" style="display:none" />');
		</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1', false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?p=8669&v=1608732000" defer async></script>
</div>
<div id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1', false);});</script></div>
</aside>
<script type="text/javascript">
	document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";

	window.onload = function() {
		//document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";
	}
</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" class="adslot adslot970 ">
<div id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1', false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a aria-label="CloudSavvy IT" title="CloudSavvy IT" href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo" alt="" role="presentation">
</a>
<div class="social">
<a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg aria-hidden="true" tabindex="-1" focusable="false" role="presentation" id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1" focusable="false"><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/" aria-hidden="true" tabindex="-1" focusable="false">
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" class="rss-link" href="https://www.linkedin.com/company/cloudsavvy-it/">
<div class="rss" style="background-color:#325f93">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1" focusable="false"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
<p>LinkedIn</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}

</style>
<div class="footer-email">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="postid" value="8669">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="tr" value="cloudsavvy-footer">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<a href="/about"><li role="menuitem">About</li></a>
<a href="/ethics"><li role="menuitem">Ethics</li></a>
<a href="/privacy-policy"><li role="menuitem">Privacy</li></a>
<a href="/terms-of-use"><li role="menuitem">Terms</li></a>
<li role="menuitem" aria-label="Privacy Policy">
<div id="show-do-not-sell-info-container"/>
</li>
<style>
					.darkModeToggle {
						-webkit-appearance: none;
						-moz-appearance: none;
						appearance: none;
						width: 62px;
						height: 32px;
						display: inline-block;
						position: relative;
						border-radius: 50px;
						overflow: hidden;
						outline: none;
						border: none;
						cursor: pointer;
						background-color: #707070;
						transition: background-color ease 0.3s;
					}

					.darkModeToggle:before {
						content: "on off";
						display: block;
						position: absolute;
						z-index: 2;
						width: 28px;
						height: 28px;
						background: #fff;
						left: 2px;
						top: 2px;
						border-radius: 50%;
						font: 10px/28px Helvetica;
						text-transform: uppercase;
						font-weight: bold;
						text-indent: -22px;
						word-spacing: 37px;
						color: #fff;
						text-shadow: -1px -1px rgba(0,0,0,0.15);
						white-space: nowrap;
						box-shadow: 0 1px 2px rgba(0,0,0,0.2);
						transition: all cubic-bezier(0.3, 1.5, 0.7, 1) 0.3s;
					}

					.darkModeToggle {
						color: white;
					}
					.darkModeToggle:checked {
						background-color: #1c8554;
					}

					.darkModeToggle:checked:before {
						left: 32px;
					}

					body.darkmode .darkModeToggleLabel {
						color: #01bdc3;
					}
				</style>
<li role="menuitem" aria-label="Dark Mode Toggle">
<label class="darkModeToggleLabel" for="darkModeToggle">Dark Mode:</label><br/><input class="darkModeToggle" id="darkModeToggle" aria-label="Toggle Dark Mode" type="checkbox" onclick="if (document.body.classList.contains('darkmode')) { document.body.classList.remove('darkmode'); document.cookie = 'enabledarkmode=no; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; } else { document.body.classList.add('darkmode'); document.cookie = 'enabledarkmode=yes; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; }"/>
</li>
<script>
					if (document.getElementById('moka_no_dark_mode')) {
						// Disable dark mode (and toggle!) on this page
						[].forEach.call(document.getElementsByClassName('darkModeToggle'), a => a.remove());
						[].forEach.call(document.getElementsByClassName('darkModeToggleLabel'), a => a.remove());
					} else {
						let useDarkMode = false;
						if ( document.cookie.includes('enabledarkmode=yes') ) {
							useDarkMode = true;
						} else if ( document.cookie.includes('enabledarkmode=no') ) {
							useDarkMode = false;
						} else {
							// Use system default preference
							if (window.matchMedia && window.matchMedia('(prefers-color-scheme: dark)').matches ) {
								useDarkMode = true;
							}
						}

						if (useDarkMode) {
							document.body.classList.add('darkmode');
							document.getElementById('darkModeToggle').checked = true;
						}
					}
				</script>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2020 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-16');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page', false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1', false);});</script></div>
<script type="text/javascript">
let mokaFindParentAnchor = function(elem) {
    if (elem.href) return elem;
    if (elem.parentElement) return mokaFindParentAnchor(elem.parentElement);
    return null;
}
window.addEventListener("click", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null ) {
		e.preventDefault();

		let xmlhttp = new XMLHttpRequest();
	    xmlhttp.onreadystatechange = function() {
	        if (xmlhttp.readyState == XMLHttpRequest.DONE) {
	        	self.location = trueAnchorElem.href;
	        }
	    };

		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/8669/' + htg + '/' + amzLink;
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
		
		document.body.style.cursor = 'wait';
	}
});
window.addEventListener("contextmenu", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null) {
		// No need for preventdefault on this version - and no need to listen for finish
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/8669/' + htg + '/' + amzLink;
		let xmlhttp = new XMLHttpRequest();
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});

let handleHtgHash = function() {
	if (document.location.hash.indexOf('#htg=') != -1) {
		let htgid = document.location.hash.match(/htg=([0-9]*)/);
		let uid = 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, (c) => {
			var r = Math.random() * 16 | 0, v = c == 'x' ? r : (r & 0x3 | 0x8);
			return v.toString(16);
		});
		if (htgid.length == 2) {
			document.cookie = 'htg=' + htgid[1] + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htgreader=' + uid + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htg_newsletter_subform_hide=1; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
		}

		history.pushState('', document.title, window.location.pathname);
	}
}();
</script>
<script>
	// Load all lazy-loaded images before someone prints:
	let loadAllLazy = () => {
		var imgs = document.querySelectorAll('[data-pagespeed-lazy-src]');
		imgs.forEach(e => e.src = e.attributes['data-pagespeed-lazy-src'].value);
	}
	// IE and FireFox:
	window.onbeforeprint = loadAllLazy;
	// Chrome and Safari:
	let mediaQueryList = window.matchMedia('print');
	mediaQueryList.addListener((mql) => {
    	if (mql.matches) loadAllLazy();
	});
</script>
</body>
</html>
