<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>
		document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});	</script>
<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);	</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-16x16.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<style type="text/css">
/*
   Copyright 2009-2015, Jan-Philip Gehrcke (http://gehrcke.de)

   Tested with Firefox 39 and Chrome 43 on the following themes:

    - Twenty Ten (version 1.9)
    - Twenty Eleven (version 2.1)
    - Twenty Twelve (version 1.7)
    - Twenty Thirteen (version 1.5)
    - Twenty Fourteen (version 1.4)
    - Twenty Fifteen (version 1.2)

   Also tested with a number of popular non-official themes, such as

    - Vantage
    - Customizr
    - ColorWay
    - Zerif Lite
    - Responsive
    - Storefront
    - Virtue
    - evolve
    - Make
    - Sparkling
    - Spacious
    - Enigma
    - Sydney
    - Point
    - Interface
    - SinglePage

   Ensuring a nice and normalized visual appearance out-of-the-box with a
   number of themes requires to make certain compromises. It turned out that
   forcing the font size to an absolute value is key component, as well as
   using the !important flag for crucial componenta like font-size, margins,
   line-height (many themes apply id-based selectors to pre-blocks, which
   have a significantly higher specificity than the class-based styles
   applied here).

   I tried to cover/normalize the style via many relevant selectors. However,
   certain themes might define styles with a high specificity that affect the
   code block appearance negatively. It is difficult to impossible to anticipate
   these cases in advance, so I expect this to happen (and the past has proven
   me right in this regard). So, I need you to look out for these situations!
   In these cases, you need to identify the corresponding selectors and override
   your theme's styles by adjusting this file (wp-geshi-highlight.css), and
   placing it in your in your theme's directory. There, it survives updates of
   this plugin. It would also be great if you could contact me in these cases,
   so that I can improve this file in future releases.
*/

.wp-geshi-highlight pre, .wp-geshi-highlight span {
    color: #444;
    overflow: visible;
    margin: 0 !important;
    padding: 0;
    border: none;
    box-shadow: none;
    background: none;
    font-size: 12px !important;
    line-height: 20px !important;
    font-family: Consolas, Monaco, 'Lucida Console', monospace;
    word-wrap: normal; /* Otherwise Chrome wraps lines */
    white-space: pre;
}

.wp-geshi-highlight ol {
    margin: 0 !important;
    padding: 0 !important;
    list-style-type: decimal !important;
}

.wp-geshi-highlight ol > li {
    position: relative; /* Create a positioning context */
    margin: 0 0 0 40px; /* Give each list item a left margin to make room for the numbers */
}

.wp-geshi-highlight li {
    padding-left: 2px;
    font-family: Consolas, Monaco, 'Lucida Console', monospace !important;
    font-size: 12px !important;
    line-height: 20px !important;
    list-style: decimal !important;
    }

.wp-geshi-highlight {
    padding: 7px 10px 7px 15px;
    margin: 2px 0 30px 0;
    overflow-x: auto;
    border-bottom: 1px solid #ccc;
    border-top: 1px solid #ccc;
    background-color: #fdfdfd;
    box-shadow: 0 8px 7px -10px #CCC, 0 -8px 7px -10px #CCC;
}

/* Enforce background-color in some non-official themes when using numbering */
.wp-geshi-highlight div ol li {
    background-color: #fdfdfd;
}


</style>
<style type="text/css">
/**
 * GeSHi Dynamically Generated Stylesheet
 * --------------------------------------
 * Dynamically generated stylesheet for php
 * CSS class: , CSS id: 
 * GeSHi (C) 2004 - 2007 Nigel McNie, 2007 - 2014 Benny Baumann
 * (http://qbnz.com/highlighter/ and http://geshi.org/)
 * --------------------------------------
 */
.php .de1, .php .de2 {}
.php  {font-family:monospace;}
.php .imp {font-weight: bold; color: red;}
.php li, .php .li1 {font-weight: normal; vertical-align:top;}
.php .ln {width:1px;text-align:right;margin:0;padding:0 2px;vertical-align:top;}
.php .li2 {font-weight: bold; vertical-align:top;}
.php .kw1 {color: #b1b100;}
.php .kw2 {color: #000000; font-weight: bold;}
.php .kw3 {color: #990000;}
.php .kw4 {color: #009900; font-weight: bold;}
.php .co1 {color: #666666; font-style: italic;}
.php .co2 {color: #666666; font-style: italic;}
.php .co3 {color: #0000cc; font-style: italic;}
.php .co4 {color: #009933; font-style: italic;}
.php .coMULTI {color: #666666; font-style: italic;}
.php .es0 {color: #000099; font-weight: bold;}
.php .es1 {color: #000099; font-weight: bold;}
.php .es2 {color: #660099; font-weight: bold;}
.php .es3 {color: #660099; font-weight: bold;}
.php .es4 {color: #006699; font-weight: bold;}
.php .es5 {color: #006699; font-weight: bold; font-style: italic;}
.php .es6 {color: #009933; font-weight: bold;}
.php .es_h {color: #000099; font-weight: bold;}
.php .br0 {color: #009900;}
.php .sy0 {color: #339933;}
.php .sy1 {color: #000000; font-weight: bold;}
.php .st0 {color: #0000ff;}
.php .st_h {color: #0000ff;}
.php .nu0 {color: #cc66cc;}
.php .nu8 {color: #208080;}
.php .nu12 {color: #208080;}
.php .nu19 {color:#800080;}
.php .me1 {color: #004000;}
.php .me2 {color: #004000;}
.php .re0 {color: #000088;}
.php .ln-xtra, .php li.ln-xtra, .php div.ln-xtra {background-color: #ffc;}
.php span.xtra { display:block; }
</style>
<link rel="canonical" href="https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/8890\/how-to-statically-analyse-php-projects-with-phpstan\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"How to Statically Analyse PHP Projects with PHPStan","name":"How to Statically Analyse PHP Projects with PHPStan","datePublished":"2021-01-11T09:00:32-05:00","dateModified":"2021-01-11T00:35:48-05:00","author":{"@type":"Person","name":"James Walker"},"description":"PHPStan is a static analysis system for PHP projects. It finds bugs in your codebase by inspecting the source files. You don&#8217;t need to run your code or manually write tests to discover issues!","image":["https:\/\/www.cloudsavvyit.com\/thumbcache\/2\/200\/0ee4d827633010353e6f7372f67e6d2a\/p\/uploads\/2021\/01\/78f4c01e.jpg"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="How to Statically Analyse PHP Projects with PHPStan">
<meta name="twitter:description" content="PHPStan is a static analysis system for PHP projects. It finds bugs in your codebase by inspecting the source files. You don&#8217;t need to run your code or manually write tests to discover issues!">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/thumbcache/600/340/b4b6190ac4f047f611ea453129d466c8/p/uploads/2021/01/78f4c01e.jpg">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="How to Statically Analyse PHP Projects with PHPStan"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="PHPStan is a static analysis system for PHP projects. It finds bugs in your codebase by inspecting the source files. You don&#8217;t need to run your code or manually write tests to discover issues!"/>
<meta property="og:image" content="https://www.cloudsavvyit.com/p/uploads/2021/01/78f4c01e.jpg"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/">
<meta name="description" content="PHPStan is a static analysis system for PHP projects. It finds bugs in your codebase by inspecting the source files. You don&#8217;t need to run your code or manually write tests to discover issues!"/>
<title>How to Statically Analyse PHP Projects with PHPStan &#8211; CloudSavvy IT</title>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 , .related-articles, .affiliate-disclosure, .article-share-widgets {display:none !important;}
	#page::before {
	    content: "CloudSavvy IT";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}


</style>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<script>
var tmntag = tmntag || {};
tmntag.cmd = tmntag.cmd || [];
(function() {
var tmnhead = document.createElement('script');
tmnhead.async = true;
tmnhead.type = 'text/javascript';
tmnhead.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//ads.servebom.com/tmnhead.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(tmnhead, node);
})();
tmntag.cmd.push(function() {
tmntag.placement(3999);
tmntag.start();
});
</script>
</head>
<body class="post-template-default single single-post postid-8890 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a aria-hidden="true" tabindex="-1" focusable="false" href="https://www.cloudsavvyit.com">
<img aria-hidden="true" tabindex="-1" focusable="false" role="presentation" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" role="img" aria-label="Search Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/" title="RSS Feed" aria-label="RSS Feed"><svg role="img" aria-label="RSS Feed Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="linkedin">
<a title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/company/cloudsavvy-it/">
<svg role="img" aria-label="LinkedIn Icon" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1" focusable="false"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
</a>
</span>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/cloudsavvyit"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="-1">Subscribe</div>
<ul id="topmenu" role="menu">
<li role="menuitem" id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li role="menuitem" id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul id="menu-header-column-1" class="menu"><li role="menuitem" id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul id="menu-header-column-2" class="menu"><li role="menuitem" id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul id="menu-header-column-3" class="menu"><li role="menuitem" id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li role="menuitem" id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
<li role="menuitem" id="menu-item-7620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7620"><a href="https://www.cloudsavvyit.com/newsletter">Newsletter</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul id="menu-header-column-4" class="menu"><li role="menuitem" id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li role="menuitem" id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li role="menuitem" id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<strong class="popsearchheading" role="heading" aria-level="1">Popular Searches</strong>
<div class="menu-header-column-1-container"><ul id="menu-header-column-5" class="menu"><li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu" data-nosnippet="data-nosnippet">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="postid" id="header_transient_postid" value="-1">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
<div style="text-align: center;">
<img style="max-height: 38px; float: right; max-width: 300px; margin-right: 25%;" src=" data:image/gif;base64,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" alt="" role="presentation">
</div>
</div>
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<script>
			let header_transient_postid = document.getElementById('header_transient_postid');
			if (header_transient_postid) {
				header_transient_postid.value = 8890;
			}
		</script>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" class="adslot adslot970 ">
<div id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1', false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>
.commercemessage {
	width:100%;
	margin:20px 0px;
	padding-left:8px;
	font-size:13px;
	color:#555;
	border-left:3px solid #888;
}
@media screen and (min-width: 1025px) {
	.commercemessage {
		width:1020px;
		line-height:15px;
	}
}
</style>
<article id="post-8890" class="post-8890 post type-post status-publish format-standard hentry category-programming tag-php">
<!-- UNCACHED CONTENT -->
<header id="article-header-area" class="entry-header" aria-label="How to Statically Analyse PHP Projects with PHPStan" role="heading" aria-level="2">
<h1 class="entry-title" style="">How to Statically Analyse PHP Projects with PHPStan</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;" data-nosnippet="data-nosnippet">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/705347dffc4feb6b0f88ee994f81991b/p/uploads/2020/12/d373f5e3.png" alt="" role="presentation">
<span>
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/jameswalker/">James Walker</a></span>
<br/>
<a aria-label="&lt;time style=&quot;font-size:12px;text-transform:uppercase;color:#666;&quot; class=&quot;entry-date published&quot; datetime=&quot;2021-01-11T09:00:32-05:00&quot;&gt;January 11, 2021, 9:00am EDT &lt;/time&gt;&lt;time class=&quot;updated&quot; datetime=&quot;2021-01-11T00:35:48-05:00&quot;&gt;January 11, 2021, 12:35am EDT &lt;/time&gt;" href="https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/" rel="bookmark"><time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2021-01-11T09:00:32-05:00">January 11, 2021, 9:00am EDT </time><time class="updated" datetime="2021-01-11T00:35:48-05:00">January 11, 2021, 12:35am EDT </time></a>	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="alignnone size-full wp-image-8891" src="https://www.cloudsavvyit.com/thumbcache/0/0/01da48fae324e5f2af86fc7d46cd8a92/p/uploads/2021/01/78f4c01e.jpg" alt="PHPStan logo" width="1600" height="900"/></p>
<p><a href="https://phpstan.org/">PHPStan</a> is a static analysis system for PHP projects. It finds bugs in your codebase by inspecting the source files. You don&#8217;t need to run your code or manually write tests to discover issues!</p>
<p>The term &#8220;static analysis&#8221; is defined as debugging code without actually executing it. It&#8217;s most often used with interpreted languages, such as PHP, as the issues it finds tend to surface at the compilation stage in compiled languages.</p>
<p>Static analysis works best when run within a well-structured, strongly-typed codebase. This is particularly important in the case of PHPStan as it&#8217;s technically a hybrid analysis tool.</p>
<p>Contrary to our definition of static analysis, <a href="https://phpstan.org/blog/zero-config-analysis-with-static-reflection">PHPStan will actually load</a> and run your source files. This is because it partially utilises PHP&#8217;s <a href="https://www.php.net/manual/en/book.reflection.php">built-in introspective capabilities</a> to analyse your project.</p>
<p>Consequently, side effects at the root of the script will end up being executed:</p>
<div class="wp-geshi-highlight-wrap5"><div class="wp-geshi-highlight-wrap4"><div class="wp-geshi-highlight-wrap3"><div class="wp-geshi-highlight-wrap2"><div class="wp-geshi-highlight-wrap"><div class="wp-geshi-highlight"><div class="php"><pre class="de1"><span class="kw2">function</span> example<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="sy0">:</span> void <span class="br0">&#123;</span>
    <span class="kw1">echo</span> <span class="st0">&quot;Example output&quot;</span><span class="sy0">;</span>
<span class="br0">&#125;</span>
&nbsp;
example<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span></pre></div></div></div></div></div></div></div>
<p>Were PHPStan to analyse the file shown above, you would observe <code>Example output</code> being emitted to the console. For this reason, it&#8217;s best to run PHPStan against inert source files (containing only classes and functions) which do not present side effects when loaded.</p>
<h2 id="adding-phpstan-to-your-project">Adding PHPStan to Your Project</h2>
<p>To run PHPStan, you&#8217;ll need to have PHP 7.1 or newer. This requirement only applies to the version of PHP used to execute PHPStan itself. The tool is capable of analysing source files targeting older versions of PHP.</p>
<p>It&#8217;s recommended you use Composer to add PHPStan as a dependency:</p>
<pre>composer require --dev phpstan/phpstan</pre>
<p>The PHPStan binary will be added to your project at <code>vendor/bin/phpstan</code>. You can now use it to analyse your codebase for the first time:</p>
<pre>vendor/bin/phpstan analyse src</pre>
<p>The command shown above will run PHPStan&#8217;s tests against all the source files in your <code>src</code> directory. Depending on the size of your codebase, this might take a few minutes to complete.</p>
<p><img class="alignnone size-full wp-image-8897" src="https://www.cloudsavvyit.com/thumbcache/0/0/d8157499d444407b05054223dd7d427e/p/uploads/2021/01/6c9b9ecf.jpeg" alt="A successful PHPStan run" width="600" height="260"/></p>
<p>You&#8217;ll see a green &#8220;[OK] No errors&#8221; message if all the tests pass. Otherwise, the list of errors encountered will be displayed. Follow the guidance shown to resolve each error before re-running PHPStan.</p>
<h2 id="error-types-and-levels">Error Types and Levels</h2>
<p>PHPStan includes a plethora of checks covering a wide variety of possible codebase issues. Some of the most common ones you&#8217;ll encounter include the following:</p>
<ul>
<li><strong>Type system issues</strong> &#8211; Assigning a typed property an invalid value, or passing incorrectly typed parameters to a method. This also includes contract issues, such as a class incorrectly implementing an interface.</li>
<li><strong>Function invocations</strong> &#8211; Passing too many, or not enough, parameters when calling a function or method (e.g. 3 instead of 4).</li>
<li><strong>Unknown classes, methods and functions</strong> &#8211; Trying to use something which doesn&#8217;t exist within the codebase.</li>
<li><strong>Access to undefined/possiby undefined variables</strong> &#8211; Trying to use a variable that is not defined in a given scope, or that which may not always have a value but is used in a context where one is assumed.</li>
<li><strong>Dead code checking</strong> &#8211; Flagging of useless code, such as boolean comparisons which will always resolve to the same value and code branches which will not never get executed (e.g. code following a <code>return</code> statement within functions).</li>
</ul>
<p>Rules are sorted into 9 different &#8220;levels&#8221;, labelled from 0 to 8. The special level <code>max</code> acts as an alias for the highest possible level. Over time, PHPStan may add additional numerical levels, so using <code>max</code> ensures you always get the strictest possible checks.</p>
<p><img class="alignnone size-full wp-image-8898" src="https://www.cloudsavvyit.com/thumbcache/0/0/9cd768eb2c10a3996d0fddaceba5991a/p/uploads/2021/01/4e9ba80b.jpeg" alt="A failed PHPStan run" width="740" height="280"/></p>
<p>By default, PHPStan executes level 0. This includes only the most fundamental of tests. It&#8217;s a good idea to get your codebase passing each level individually before advancing to the next one. Mature projects are likely to run into another set of issues with each new level.</p>
<p>To change the level PHPStan uses, you can pass the <code>--level</code> command line parameter:</p>
<p><code>vendor/bin/phpstan analyse src --level 8</code></p>
<p>In addition to the built-in checks, PHPStan extensions are available to add even more functionality. You can also write your own rules from scratch. This is useful when you&#8217;re deprecating functionality that developers should no longer use in any new code. We&#8217;ll cover creating custom rules in a future article.</p>
<h2 id="configuring-phpstan">Configuring PHPStan</h2>
<p>Beyond initial experimentation, using PHPStan&#8217;s command-line interface can quickly become tiresome. It&#8217;s best to add a configuration file to your project which can then be committed to source control for all your developers to use.</p>
<p>PHPStan uses the <a href="https://ne-on.org/">Neon</a> configuration file format, which has a syntax very similar to YAML. Create a <code>phpstan.neon</code> file in your project&#8217;s root directory. This file is automatically loaded whenever PHPStan starts, so you can now run the <code>analyse</code> command with no further arguments:</p>
<pre>vendor/bin/phpstan analyse</pre>
<p>To override the configuration file which is used, pass the <code>--configuration</code> flag:</p>
<pre>vendor/bin/phpstan analyse --configuration /phpstan-config.neon</pre>
<p>You now need to populate your <code>phpstan.neon</code> file with some content. A good starting point might look like this:</p>
<div class="wp-geshi-highlight-wrap5"><div class="wp-geshi-highlight-wrap4"><div class="wp-geshi-highlight-wrap3"><div class="wp-geshi-highlight-wrap2"><div class="wp-geshi-highlight-wrap"><div class="wp-geshi-highlight"><div class="yml"><pre class="de1">parameters:
  level: 0
  paths:
    - src</pre></div></div></div></div></div></div></div>
<p>This basic configuration file should give the same output as the command-line invocation shown earlier. You can add additional directories to scan as new lines in the <code>paths</code> section. To exclude files and directories, add them to an <code>excludes_analyse</code> leaf within the same <code>parameters</code> section.</p>
<h2 id="ignoring-errors">Ignoring Errors</h2>
<p>Occasionally, PHPStan may surface an issue which is unavoidable. If there&#8217;s a problem which you cannot immediately address, you may wish to explicitly ignore it in order to allow the tests to pass.</p>
<p>This is particularly important when you want to move up to another level of checks, or you&#8217;re using PHPStan in a CI environment where a failed run will stop your build deploying. Even so, don&#8217;t take this course of action lightly &#8211; you should only choose to ignore a reported error if you&#8217;re certain it will be safe to do so.</p>
<p>Once you&#8217;ve made the decision, add a new <code>ignoreErrors</code> section within the <code>parameters</code> of your configuration file. You have to define the message to match, as a regex, and the paths to apply the exclusion to:</p>
<div class="wp-geshi-highlight-wrap5"><div class="wp-geshi-highlight-wrap4"><div class="wp-geshi-highlight-wrap3"><div class="wp-geshi-highlight-wrap2"><div class="wp-geshi-highlight-wrap"><div class="wp-geshi-highlight"><div class="yml"><pre class="de1">parameters:
  level: 0
  paths:
    - src
  ignoreErrors:
    - message: '/Return type string of method ExampleClass::example() is not covariant(.*).'
      path: src/ExampleClass.php</pre></div></div></div></div></div></div></div>
<p>You can optionally specify <code>paths</code> as an array of paths, replacing the single <code>path</code> key shown above.</p>
<h2 id="optional-rules">Optional Rules</h2>
<p>PHPStan&#8217;s strictness can be adjusted by a series of configuration variables. These allow you to finetune the checks which are made, outside of the levels system described above. Some of these are potentially controversial or unlikely to align with all private style guides, hence they&#8217;re off by default.</p>
<p>A few settings which might be worth enabling include:</p>
<ul>
<li><code>checkAlwaysTrueInstanceof</code> &#8211; Flags uses of <code>instanceof</code> which will always evaluate to <code>true</code>.</li>
<li><code>checkAlwaysTrueStrictComparison</code> &#8211; Flags when an expression using <code>===</code> or <code>!==</code> will always evaluate to <code>true</code>.</li>
<li><code>checkFunctionNameCase</code> &#8211; Ensures the casing of function names matches their definition when called throughout the codebase.</li>
<li><code>polluteScopeWithLoopInitialAssignments</code> &#8211; When set to <code>false</code> (it&#8217;s <code>true</code> by default), variables declared in initial loop statements (e.g. <code>$i</code> in <code>$for ($i = 1; $i &lt; 10; $i++)</code>) are prevented from being accessed outside the loop&#8217;s code block, avoiding possible pollution of the parent scope.</li>
<li><code>reportStaticMethodSignatures</code> &#8211; Enforces full type checking for parameters and return types in static methods when overridden by a child class.</li>
</ul>
<p>Complete details on these optional settings &#8211; and many more &#8211; can be found within PHPStan&#8217;s <a href="https://phpstan.org/config-reference">configuration reference</a>.</p>
<h2 id="conclusion">Conclusion</h2>
<p>That&#8217;s the end of our introduction to <a href="https://phpstan.org/">PHPStan</a>. It helps you have confidence in your codebase and highlights possible issues before they become a problem in production.</p>
<p>PHPStan is so quick to setup that there&#8217;s really no reason not to use it, especially when working with a modern strongly-typed codebase. Don&#8217;t be tricked into thinking it can replace manual testing though. PHPStan may boast a large assortment of checks but it cannot identify logical issues and does not understand your project&#8217;s business rules. It&#8217;s merely another asset in your toolbox when assessing a codebase&#8217;s health, serving alongside trusted companions such as unit tests and end-to-end functionality tests.</p>
</div><!-- .entry-content -->
</article><!-- #post-8890 -->
<style>
			#content ul#nextuplist {list-style-type: none;margin-left:0px;padding-left:0px;}
			#content ul#nextuplist li {margin-bottom:10px;}
			#content ul#nextuplist li a {text-decoration:none;}
		</style>
<div class="nextup">
<span id="nextuplabel" role="heading" aria-level="2">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8875/the-trickbot-botnet-is-dead-or-is-it/">The Trickbot Botnet is Dead &#8211; Or Is It?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8793/how-to-create-a-managed-kubernetes-cluster-on-digitalocean/">How to Create a Managed Kubernetes Cluster on DigitalOcean</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8757/8-top-new-features-in-php-8/">8 Top New Features in PHP 8</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8769/should-you-use-react-for-your-next-website/">Should You Use React for Your Next Website?</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/8722/using-psreadline-in-powershell/">Using PSReadLine in PowerShell</a></li>
</ul>
</div>
<style>
.shortbioauthor {

	font-weight: bold;
    text-transform: uppercase;
    font-size: 20px;
    text-decoration:none;
    padding-top: 0;
    margin-top: 0;
    line-height: 20px;
}
.shortbioauthor span {
	color:#1d55a9;	
	padding-top: 0;
	margin-top: 0;
}
.shortbioauthordiv {
	border: 1px solid #eee;
	padding: 15px;
	margin-bottom: 20px;
}
.shortbioauthordiv .biotext {
	font-size: 15px;
}
.shortbioauthordiv .biomore {
	text-transform: uppercase;
	font-size: 13px;
	font-weight: bold;
	color:#1d55a9;		
}
</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/jameswalker/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/f4f014836f3a864d12475af8b247b7c2/p/uploads/2020/12/d373f5e3.png" alt="James Walker"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="shortbioauthor"><span>James Walker</span></a>
<br style="margin-top: 10px;">
<span class="biotext">James Walker is a contributor to CloudSavvy IT. He is the founder of <a href="https://www.heron-web.com" rel="noopener" target="_blank">Heron Web</a>, a UK-based digital agency providing bespoke software development services to SMEs. He has experience of managing complete end-to-end web development workflows, using technologies including Linux, GitLab, Docker and Kubernetes.
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a title="Share on Facebook" aria-label="Share on Facebook" class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a title="Share on Twitter" aria-label="Share on Twitter" class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=How+to+Statically+Analyse+PHP+Projects+with+PHPStan+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/8890/how-to-statically-analyse-php-projects-with-phpstan/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1" focusable="false"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>
#content .comments p.share-heading {
	font-size: 14px;
    font-weight: bold;
    margin-top: 0;
    line-height: 36px;
    text-decoration: none;
    text-transform: uppercase;
    border: 1px solid #333333;
    background: #333333;
    border-radius: 4px;
    color: #FFF;
    padding-left: 8px;
    padding-right: 8px;
}

@media screen and (max-width: 768px) {
	#content .comments p.share-heading {
		line-height:27px;
	}

}

</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<span class="article-footer-heading">Recently Popular</span>
<article id="post-8757">
<header class="entry-header" style="min-height:100px;" aria-label="8 Top New Features in PHP 8" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="8 Top New Features in PHP 8" aria-label="8 Top New Features in PHP 8" href="https://www.cloudsavvyit.com/8757/8-top-new-features-in-php-8/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/8b0a93a9a4f07519d584f4511b2c767f/p/uploads/2017/08/1ac500da.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="8 Top New Features in PHP 8" aria-label="8 Top New Features in PHP 8" href="https://www.cloudsavvyit.com/8757/8-top-new-features-in-php-8/">
<span class="entry-title article-header">8 Top New Features in PHP 8</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-06T08:00:20-05:00">January 6th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8769">
<header class="entry-header" style="min-height:100px;" aria-label="Should You Use React for Your Next Website?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="Should You Use React for Your Next Website?" aria-label="Should You Use React for Your Next Website?" href="https://www.cloudsavvyit.com/8769/should-you-use-react-for-your-next-website/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/fce6b22e0a47d2ae46a53cb179bcde6b/p/uploads/2021/01/24b43beb.jpg" alt="" role="presentation">	</a>
<div class="article-text">
<a title="Should You Use React for Your Next Website?" aria-label="Should You Use React for Your Next Website?" href="https://www.cloudsavvyit.com/8769/should-you-use-react-for-your-next-website/">
<span class="entry-title article-header">Should You Use React for Your Next Website?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-05T08:00:03-05:00">January 5th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8817">
<header class="entry-header" style="min-height:100px;" aria-label="How to Use Pass, a Command-Line Password Manager for Linux Systems" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="How to Use Pass, a Command-Line Password Manager for Linux Systems" aria-label="How to Use Pass, a Command-Line Password Manager for Linux Systems" href="https://www.cloudsavvyit.com/8817/how-to-use-pass-a-command-line-password-manager-for-linux-systems/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/e73c9a6e868a44b1cd92aed73adfdbbd/p/uploads/2021/01/1590ce55.jpeg" alt="" role="presentation">	</a>
<div class="article-text">
<a title="How to Use Pass, a Command-Line Password Manager for Linux Systems" aria-label="How to Use Pass, a Command-Line Password Manager for Linux Systems" href="https://www.cloudsavvyit.com/8817/how-to-use-pass-a-command-line-password-manager-for-linux-systems/">
<span class="entry-title article-header">How to Use Pass, a Command-Line Password Manager for Linux Systems</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-06T09:00:34-05:00">January 6th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8716">
<header class="entry-header" style="min-height:100px;" aria-label="Scopes in PowerShell" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="Scopes in PowerShell" aria-label="Scopes in PowerShell" href="https://www.cloudsavvyit.com/8716/scopes-in-powershell/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/07a01615e833cfa572cb495b86c82552/p/uploads/2020/03/23e4a5a4.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="Scopes in PowerShell" aria-label="Scopes in PowerShell" href="https://www.cloudsavvyit.com/8716/scopes-in-powershell/">
<span class="entry-title article-header">Scopes in PowerShell</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/adambertram/" class="p-author vcard author post-author"><span class="fn">Adam Bertram</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-12-29T08:00:13-05:00">December 29th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8875">
<header class="entry-header" style="min-height:100px;" aria-label="The Trickbot Botnet is Dead &#8211; Or Is It?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="The Trickbot Botnet is Dead &#8211; Or Is It?" aria-label="The Trickbot Botnet is Dead &#8211; Or Is It?" href="https://www.cloudsavvyit.com/8875/the-trickbot-botnet-is-dead-or-is-it/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/689a847c0aeeb5fab4e1b7a5a2fe1bb6/p/uploads/2021/01/05c2d700.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="The Trickbot Botnet is Dead &#8211; Or Is It?" aria-label="The Trickbot Botnet is Dead &#8211; Or Is It?" href="https://www.cloudsavvyit.com/8875/the-trickbot-botnet-is-dead-or-is-it/">
<span class="entry-title article-header">The Trickbot Botnet is Dead &#8211; Or Is It?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/davidmckay/" class="p-author vcard author post-author"><span class="fn">Dave McKay</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-11T08:00:54-05:00">January 11th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article id="post-8844">
<header class="entry-header" style="min-height:100px;" aria-label="Why Are Some Network Ports Risky, And How Do You Secure Them?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" focusable="false" title="Why Are Some Network Ports Risky, And How Do You Secure Them?" aria-label="Why Are Some Network Ports Risky, And How Do You Secure Them?" href="https://www.cloudsavvyit.com/8844/why-are-some-ports-risky-and-how-do-you-secure-them/">
<img loading="lazy" src="https://www.cloudsavvyit.com/thumbcache/240/140/1db1ca0a0b97ef0e33c7e6adf71cc56c/p/uploads/2021/01/93942e4b.png" alt="" role="presentation">	</a>
<div class="article-text">
<a title="Why Are Some Network Ports Risky, And How Do You Secure Them?" aria-label="Why Are Some Network Ports Risky, And How Do You Secure Them?" href="https://www.cloudsavvyit.com/8844/why-are-some-ports-risky-and-how-do-you-secure-them/">
<span class="entry-title article-header">Why Are Some Network Ports Risky, And How Do You Secure Them?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/davidmckay/" class="p-author vcard author post-author"><span class="fn">Dave McKay</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-08T08:00:23-05:00">January 8th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
</div>
<script type='text/javascript'>
			var htg = -1;
			var htgm = document.cookie.match('htg=([0-9]*)');
			if (htgm && htgm.length == 2) {
				htg = htgm[1];
			}
			document.write('<img src="https://www.cloudsavvyit.com/lambda-uploads/cloudsavvy/8890/' + htg + '/logo.gif?1610373725" alt="" id="htgstats" style="display:none" />');
		</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1', false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?v=1610373600" defer async></script>
</div>
<div id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1', false);});</script></div>
</aside>
<script type="text/javascript">
	document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";

	window.onload = function() {
		//document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";
	}
</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" class="adslot adslot970 ">
<div id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1', false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a aria-label="CloudSavvy IT" title="CloudSavvy IT" href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT" class="logo" alt="" role="presentation">
</a>
<div class="social">
<a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg aria-hidden="true" tabindex="-1" focusable="false" role="presentation" id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1" focusable="false"><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" version="1.1" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/" aria-hidden="true" tabindex="-1" focusable="false">
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" class="rss-link" href="https://www.linkedin.com/company/cloudsavvy-it/">
<div class="rss" style="background-color:#325f93">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1" focusable="false"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
<p>LinkedIn</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}

</style>
<div class="footer-email" data-nosnippet="data-nosnippet">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="postid" value="8890">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" focusable="false" type="hidden" name="tr" value="cloudsavvy-footer">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<a href="/about"><li role="menuitem">About</li></a>
<a href="/ethics"><li role="menuitem">Ethics</li></a>
<a href="/privacy-policy"><li role="menuitem">Privacy</li></a>
<a href="/terms-of-use"><li role="menuitem">Terms</li></a>
<li role="menuitem" aria-label="Privacy Policy">
<div id="show-do-not-sell-info-container"/>
</li>
<style>
					.darkModeToggle {
						-webkit-appearance: none;
						-moz-appearance: none;
						appearance: none;
						width: 62px;
						height: 32px;
						display: inline-block;
						position: relative;
						border-radius: 50px;
						overflow: hidden;
						outline: none;
						border: none;
						cursor: pointer;
						background-color: #707070;
						transition: background-color ease 0.3s;
					}

					.darkModeToggle:before {
						content: "on off";
						display: block;
						position: absolute;
						z-index: 2;
						width: 28px;
						height: 28px;
						background: #fff;
						left: 2px;
						top: 2px;
						border-radius: 50%;
						font: 10px/28px Helvetica;
						text-transform: uppercase;
						font-weight: bold;
						text-indent: -22px;
						word-spacing: 37px;
						color: #fff;
						text-shadow: -1px -1px rgba(0,0,0,0.15);
						white-space: nowrap;
						box-shadow: 0 1px 2px rgba(0,0,0,0.2);
						transition: all cubic-bezier(0.3, 1.5, 0.7, 1) 0.3s;
					}

					.darkModeToggle {
						color: white;
					}
					.darkModeToggle:checked {
						background-color: #1c8554;
					}

					.darkModeToggle:checked:before {
						left: 32px;
					}

					body.darkmode .darkModeToggleLabel {
						color: #01bdc3;
					}
				</style>
<li role="menuitem" aria-label="Dark Mode Toggle">
<label class="darkModeToggleLabel" for="darkModeToggle">Dark Mode:</label><br/><input class="darkModeToggle" id="darkModeToggle" aria-label="Toggle Dark Mode" type="checkbox" onclick="if (document.body.classList.contains('darkmode')) { document.body.classList.remove('darkmode'); document.cookie = 'enabledarkmode=no; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; } else { document.body.classList.add('darkmode'); document.cookie = 'enabledarkmode=yes; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; }"/>
</li>
<script>
					if (document.getElementById('moka_no_dark_mode')) {
						// Disable dark mode (and toggle!) on this page
						[].forEach.call(document.getElementsByClassName('darkModeToggle'), a => a.remove());
						[].forEach.call(document.getElementsByClassName('darkModeToggleLabel'), a => a.remove());
					} else {
						let useDarkMode = false;
						if ( document.cookie.includes('enabledarkmode=yes') ) {
							useDarkMode = true;
						} else if ( document.cookie.includes('enabledarkmode=no') ) {
							useDarkMode = false;
						} else {
							// Use system default preference
							if (window.matchMedia && window.matchMedia('(prefers-color-scheme: dark)').matches ) {
								useDarkMode = true;
							}
						}

						if (useDarkMode) {
							document.body.classList.add('darkmode');
							document.getElementById('darkModeToggle').checked = true;
						}
					}
				</script>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2021 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-16');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page', false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1', false);});</script></div>
<script type="text/javascript">
let mokaFindParentAnchor = function(elem) {
    if (elem.href) return elem;
    if (elem.parentElement) return mokaFindParentAnchor(elem.parentElement);
    return null;
}
window.addEventListener("click", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null ) {
		e.preventDefault();

		let xmlhttp = new XMLHttpRequest();
	    xmlhttp.onreadystatechange = function() {
	        if (xmlhttp.readyState == XMLHttpRequest.DONE) {
	        	self.location = trueAnchorElem.href;
	        }
	    };

		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/8890/' + htg + '/' + amzLink;
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
		
		document.body.style.cursor = 'wait';
	}
});
window.addEventListener("contextmenu", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null) {
		// No need for preventdefault on this version - and no need to listen for finish
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/8890/' + htg + '/' + amzLink;
		let xmlhttp = new XMLHttpRequest();
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});

let handleHtgHash = function() {
	if (document.location.hash.indexOf('#htg=') != -1) {
		let htgid = document.location.hash.match(/htg=([0-9]*)/);
		let uid = 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, (c) => {
			var r = Math.random() * 16 | 0, v = c == 'x' ? r : (r & 0x3 | 0x8);
			return v.toString(16);
		});
		if (htgid.length == 2) {
			document.cookie = 'htg=' + htgid[1] + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htgreader=' + uid + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htg_newsletter_subform_hide=1; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
		}

		history.pushState('', document.title, window.location.pathname);
	}
}();
</script>
<script>
	// Load all lazy-loaded images before someone prints:
	let loadAllLazy = () => {
		var imgs = document.querySelectorAll('[data-pagespeed-lazy-src]');
		imgs.forEach(e => e.src = e.attributes['data-pagespeed-lazy-src'].value);
	}
	// IE and FireFox:
	window.onbeforeprint = loadAllLazy;
	// Chrome and Safari:
	let mediaQueryList = window.matchMedia('print');
	mediaQueryList.addListener((mql) => {
    	if (mql.matches) loadAllLazy();
	});
</script>
</body>
</html>
