<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="dns-prefetch" href="//fonts.gstatic.com">
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin>
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content">
<style type="text/css">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</style>
<script>
		document.addEventListener("DOMContentLoaded",function(e){function s(e){var s=void 0!==window.pageYOffset?window.pageYOffset:(document.documentElement||document.body.parentNode||document.body).scrollTop;o[0].classList.remove("visible"),n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.remove("is-active");var t=Math.max(document.documentElement.clientHeight,document.body.scrollHeight,document.documentElement.scrollHeight,document.body.offsetHeight,document.documentElement.offsetHeight);Math.abs(b-s)<=f||(s>b&&s>g?(y.classList.remove("nav-down"),y.classList.add("nav-up")):s+window.innerHeight<t&&(y.classList.remove("nav-up"),y.classList.add("nav-down")),b=s)}function t(e,s,t){if(t){var i=new Date;i.setTime(i.getTime()+24*t*60*60*1e3);l="; expires="+i.toGMTString()}else var l="";document.cookie=e+"="+s+l+"; path=/"}var i=document.querySelectorAll(".more-info-hover")[0];i&&(i.addEventListener("mouseenter",function(e){document.querySelectorAll(".rating-info")[0].style.display="block"}),i.addEventListener("mouseleave",function(e){document.querySelectorAll(".rating-info")[0].style.display="none"}),i.addEventListener("click",function(e){"block"==document.querySelectorAll(".rating-info")[0].style.display?document.querySelectorAll(".rating-info")[0].style.display="none":document.querySelectorAll(".rating-info")[0].style.display="block"}));var l=document.querySelectorAll(".htg-hamburger"),c=document.querySelectorAll(".subscribe-menu"),n=document.querySelectorAll(".full-screen-menu.search-menu"),o=document.querySelectorAll(".full-screen-menu.category-menu"),a=document.querySelectorAll("#topmenu .categories"),r=document.querySelectorAll(".subscribe-button"),d=document.querySelectorAll("#masthead .search"),v=document.querySelectorAll(".htg-close");v[0].addEventListener("click",function(e){n[0].classList.remove("visible")}),v[1].addEventListener("click",function(e){c[0].classList.remove("visible")}),d[0]&&d[0].addEventListener("click",function(e){n[0].classList.contains("visible")?n[0].classList.remove("visible"):(n[0].classList.add("visible"),l[0].classList.remove("is-active"),o[0].classList.remove("visible"),c[0].classList.remove("visible"))}),a[0].addEventListener("click",function(e){return c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible")),e.preventDefault(),!1}),l[0].addEventListener("click",function(e){c[0].classList.remove("visible"),l[0].classList.contains("is-active")?(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),c[0].classList.remove("visible")):(n[0].classList.remove("visible"),c[0].classList.remove("visible"),l[0].classList.add("is-active"),o[0].classList.add("visible"))}),r[0].addEventListener("click",function(e){c[0].classList.contains("visible")?c[0].classList.remove("visible"):(o[0].classList.remove("visible"),l[0].classList.remove("is-active"),n[0].classList.remove("visible"),c[0].classList.add("visible"))}),c[0].addEventListener("click",function(e){e.target==c[0]&&c[0].classList.remove("visible")}),n[0].addEventListener("click",function(e){e.target==n[0]&&n[0].classList.remove("visible")}),o[0].addEventListener("click",function(e){e.target==o[0]&&(o[0].classList.remove("visible"),l[0].classList.remove("is-active"))});var u=document.querySelectorAll("#light-slider img")[0];if(u){var m=u.getAttribute("data-src");u.src=m}var L,b=0,f=5,y=document.querySelectorAll("#masthead")[0],g=y.offsetHeight;document.addEventListener("scroll",function(){L=!0},!1),setInterval(function(){L&&(s(),L=!1)},100),document.onkeydown=function(e){if(27==(e=e||window.event).keyCode){var s=document.querySelectorAll(".subscribe-menu"),t=document.querySelectorAll(".full-screen-menu");s[0].classList.remove("visible"),t[0].classList.remove("visible")}};var S=[];document.onkeydown=function(e){S.push(e.keyCode),S.toString().indexOf("38,38,40,40,37,39,37,39,66,65")>=0&&(alert("Welcome to the Dark Side"),t("enabledarkmode","yes",365),document.querySelector("body").classList.add("darkmode"),S=[])}});	</script>
<script>
		/(trident|msie)/i.test(navigator.userAgent)&&document.getElementById&&window.addEventListener&&window.addEventListener("hashchange",function(){var t,e=location.hash.substring(1);/^[A-z0-9_-]+$/.test(e)&&(t=document.getElementById(e))&&(/^(?:a|select|input|button|textarea)$/i.test(t.tagName)||(t.tabIndex=-1),t.focus())},!1);	</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/favicon-16x16.png">
<link rel="manifest" href="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/manifest.json">
<meta name="msapplication-TileColor" content="#2d6095">
<meta name="msapplication-TileImage" content="https://www.cloudsavvyit.com/wp-content/themes/lsm/icons/cloudsavvy/ms-icon-144x144.png">
<meta name="theme-color" content="#2d6095">
<meta property="fb:app_id" content="1206958639448107"/>
<meta property="fb:op-recirculation-ads" content="placement_id=139068613408866_139068626742198">
<link rel="canonical" href="https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/"/>
<link rel="alternate" type="application/json" title="JSON Feed" href="https://www.cloudsavvyit.com/feed/json/"/>	<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<link rel="amphtml" href="https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/amp/"/> <script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","id":"https:\/\/www.cloudsavvyit.com\/9173\/how-to-attach-extra-storage-to-your-digitalocean-droplets\/"},"publisher":{"@type":"Organization","name":"CloudSavvy IT","logo":{"@type":"ImageObject","url":"https:\/\/www.cloudsavvyit.com\/wp-content\/themes\/lsm\/img\/csit_light_t.png","height":60,"width":221}},"headline":"How to Attach Extra Storage to Your DigitalOcean Droplets","name":"How to Attach Extra Storage to Your DigitalOcean Droplets","datePublished":"2021-02-04T09:00:21-05:00","dateModified":"2021-02-04T02:47:56-05:00","author":{"@type":"Person","name":"James Walker"},"description":"DigitalOcean droplets come with a limited amount of SSD storage. Here&#8217;s how you can add more disk capacity without breaking the bank, using DigitalOcean&#8217;s dedicated storage solution.","image":["https:\/\/www.cloudsavvyit.com\/p\/uploads\/2020\/01\/4d4b63f7.png?height=200p&trim=2,2,2,2"]}</script> <meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@cloudsavvyit">
<meta name="twitter:title" content="How to Attach Extra Storage to Your DigitalOcean Droplets">
<meta name="twitter:description" content="DigitalOcean droplets come with a limited amount of SSD storage. Here&#8217;s how you can add more disk capacity without breaking the bank, using DigitalOcean&#8217;s dedicated storage solution.">
<meta name="twitter:image:src" content="https://www.cloudsavvyit.com/p/uploads/2020/01/4d4b63f7.png?width=600&height=340&fit=crop&trim=2,2,2,2">
<meta name="twitter:image:width" content="600">
<meta name="twitter:image:height" content="340">
<meta property="og:title" name="title" content="How to Attach Extra Storage to Your DigitalOcean Droplets"/>
<meta property="og:type" content="article"/>
<meta property="og:description" name="og:description" content="DigitalOcean droplets come with a limited amount of SSD storage. Here&#8217;s how you can add more disk capacity without breaking the bank, using DigitalOcean&#8217;s dedicated storage solution."/>
<meta property="og:image" content="https://www.cloudsavvyit.com/p/uploads/2020/01/4d4b63f7.png"/>
<meta property="og:url" content="https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/">
<meta name="description" content="DigitalOcean droplets come with a limited amount of SSD storage. Here&#8217;s how you can add more disk capacity without breaking the bank, using DigitalOcean&#8217;s dedicated storage solution."/>
<title>How to Attach Extra Storage to Your DigitalOcean Droplets &#8211; CloudSavvy IT</title>
<style>
@media print {
	#masthead, .full-screen-menu, .adslot, .site-footer, #secondary , #purch_N_C_0_1, .social-media-buttons, .article-bottom, .jw-loaded, #purch_N_C_0_1 , .related-articles, .affiliate-disclosure, .article-share-widgets {display:none !important;}
	#page::before {
	    content: "CloudSavvy IT";
	    font-size: 24px;
	    font-weight: bold;
	    padding-left: 20px;
	    width: 700px;
	    border-bottom: 1px solid black;
	    display: block;
	    margin: 10px auto;
	}
}


</style>
<script>
	window.showDoNotSellInfo = function() {
		var link = document.createElement('a');
		link.href = '#';
		link.innerText = 'Do not sell my info';
		var container = document.getElementById('show-do-not-sell-info-container');
		container.appendChild(link);
		return link;
	}

	window.validateAriaEmail = function(elem) {
		var re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/;
	    if (re.test(elem.value)) {
			elem.setAttribute('aria-invalid', false);
		} else {
			elem.setAttribute('aria-invalid', true);
		}
	}
</script>
<script>
var tmntag = tmntag || {};
tmntag.cmd = tmntag.cmd || [];
(function() {
var tmnhead = document.createElement('script');
tmnhead.async = true;
tmnhead.type = 'text/javascript';
tmnhead.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//ads.servebom.com/tmnhead.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(tmnhead, node);
})();
tmntag.cmd.push(function() {
tmntag.placement(3999);
tmntag.start();
});
</script>
</head>
<body class="post-template-default single single-post postid-9173 single-format-standard">
<div id="fb-root"></div>
<div id="page" class="site">
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header " style="top:0">
<div class="container">
<div class="site-branding">
<a aria-hidden="true" tabindex="-1" href="https://www.cloudsavvyit.com">
<img src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT Logo" class="logo">
</a>
</div>
<button class="htg-hamburger hamburger hamburger--slider" type="button" aria-label="Expand Menu">
<span class="hamburger-box" role="presentation">
<span class="hamburger-inner" role="presentation"></span>
</span>
</button>
<svg class="search" role="img" aria-label="Search Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1216 832q0-185-131.5-316.5t-316.5-131.5-316.5 131.5-131.5 316.5 131.5 316.5 316.5 131.5 316.5-131.5 131.5-316.5zm512 832q0 52-38 90t-90 38q-54 0-90-38l-343-342q-179 124-399 124-143 0-273.5-55.5t-225-150-150-225-55.5-273.5 55.5-273.5 150-225 225-150 273.5-55.5 273.5 55.5 225 150 150 225 55.5 273.5q0 220-124 399l343 343q37 37 37 90z" fill="#555"/></svg>
<span class="rss"><a href="/feed/" title="RSS Feed" aria-label="RSS Feed"><svg role="img" aria-label="RSS Feed Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #F06530;" aria-hidden="true" tabindex="-1"><path d="M576 1344q0 80-56 136t-136 56-136-56-56-136 56-136 136-56 136 56 56 136zm512 123q2 28-17 48-18 21-47 21h-135q-25 0-43-16.5t-20-41.5q-22-229-184.5-391.5t-391.5-184.5q-25-2-41.5-20t-16.5-43v-135q0-29 21-47 17-17 43-17h5q160 13 306 80.5t259 181.5q114 113 181.5 259t80.5 306zm512 2q2 27-18 47-18 20-46 20h-143q-26 0-44.5-17.5t-19.5-42.5q-12-215-101-408.5t-231.5-336-336-231.5-408.5-102q-25-1-42.5-19.5t-17.5-43.5v-143q0-28 20-46 18-18 44-18h3q262 13 501.5 120t425.5 294q187 186 294 425.5t120 501.5z"/></svg></a></span>
<span class="linkedin">
<a title="LinkedIn" aria-label="LinkedIn" href="https://www.linkedin.com/company/cloudsavvy-it/">
<svg role="img" aria-label="LinkedIn Icon" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
</a>
</span>
<span class="twitter"><a title="Twitter" aria-label="Twitter" href="https://twitter.com/cloudsavvyit"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></a></span>
<span class="facebook"><a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></a></span>
<span class="twitter-mobile"><svg role="img" aria-label="Twitter Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #2AA3EF;" aria-hidden="true" tabindex="-1"><path d="M1684 408q-67 98-162 167 1 14 1 42 0 130-38 259.5t-115.5 248.5-184.5 210.5-258 146-323 54.5q-271 0-496-145 35 4 78 4 225 0 401-138-105-2-188-64.5t-114-159.5q33 5 61 5 43 0 85-11-112-23-185.5-111.5t-73.5-205.5v-4q68 38 146 41-66-44-105-115t-39-154q0-88 44-163 121 149 294.5 238.5t371.5 99.5q-8-38-8-74 0-134 94.5-228.5t228.5-94.5q140 0 236 102 109-21 205-78-37 115-142 178 93-10 186-50z"/></svg></span>
<span class="facebook-mobile"><svg role="img" aria-label="Facebook Icon" width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #3B5998;" aria-hidden="true" tabindex="-1"><path d="M1343 12v264h-157q-86 0-116 36t-30 108v189h293l-39 296h-254v759h-306v-759h-255v-296h255v-218q0-186 104-288.5t277-102.5q147 0 228 12z"/></svg></span>
<div class="subscribe-button" tabindex="-1">Subscribe</div>
<ul id="topmenu" role="menu">
<li role="menuitem" id="menu-item-22" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-22"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-23" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
<li role="menuitem" id="menu-item-4070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4070"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
<li role="menuitem"><a class="categories" href="/">Explore</a></li>
</ul>
</div>
</header><!-- #masthead -->
<div class="full-screen-menu category-menu">
<div class="full-screen-menu-inner">
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-header-column-1-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4076" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/">AWS</a></li>
<li role="menuitem" id="menu-item-4086" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/">Microsoft</a></li>
</ul></div>
<div class="menu-header-column-2-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4077" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4077"><a href="https://www.cloudsavvyit.com/c/linux/">Linux</a></li>
</ul></div>
<div class="menu-header-column-3-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4083" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4083"><a href="https://www.cloudsavvyit.com/about/">About Us</a></li>
<li role="menuitem" id="menu-item-4084" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4084"><a href="https://www.cloudsavvyit.com/about/#contact">Contact Us</a></li>
<li role="menuitem" id="menu-item-4085" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4085"><a href="https://www.cloudsavvyit.com/privacy/">Privacy Policy</a></li>
<li role="menuitem" id="menu-item-7620" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7620"><a href="https://www.cloudsavvyit.com/newsletter">Newsletter</a></li>
</ul></div>
<div class="menu-header-column-4-container"><ul class="menu" role="menu"><li role="menuitem" id="menu-item-4079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4079"><a href="https://www.howtogeek.com">How-To Geek</a></li>
<li role="menuitem" id="menu-item-4081" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4081"><a href="https://www.lifesavvy.com">LifeSavvy</a></li>
<li role="menuitem" id="menu-item-4080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4080"><a href="https://www.reviewgeek.com">Review Geek</a></li>
</ul></div>
</nav><!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu search-menu">
<div class="full-screen-menu-inner">
<div class="htg-close">X</div>
<div class="inner">
<form role="search" method="get" class="searchform" action="/">
<input type="search" class="search" placeholder="Enter Search Term" name="s" value="" aria-label="Enter Search Term">
<input type="submit" value="Go">
</form>
<strong class="popsearchheading" role="heading" aria-level="1">Popular Searches</strong>
<div class="menu-header-column-1-container"><ul class="menu" role="menu"><li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4076"><a href="https://www.cloudsavvyit.com/c/cloud/aws/" aria-label="Search for AWS">AWS</a></li>
<li role="menuitem" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4086"><a href="https://www.cloudsavvyit.com/c/microsoft/" aria-label="Search for Microsoft">Microsoft</a></li>
</ul></div>
<!-- #site-navigation -->
</div>
</div>
</div>
<div class="full-screen-menu subscribe-menu" data-nosnippet="data-nosnippet">
<div class="subscribe-wrap">
<div class="htg-close">X</div>
<div class="inner">
<div class="left">
<span style="height: 100px;width: 100px;float: left;margin-right: 20px;margin-top: -10px;"><svg width="100" height="100" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" style="fill: #999;" aria-hidden="true" tabindex="-1"><path d="M1792 710v794q0 66-47 113t-113 47h-1472q-66 0-113-47t-47-113v-794q44 49 101 87 362 246 497 345 57 42 92.5 65.5t94.5 48 110 24.5h2q51 0 110-24.5t94.5-48 92.5-65.5q170-123 498-345 57-39 100-87zm0-294q0 79-49 151t-122 123q-376 261-468 325-10 7-42.5 30.5t-54 38-52 32.5-57.5 27-50 9h-2q-23 0-50-9t-57.5-27-52-32.5-54-38-42.5-30.5q-91-64-262-182.5t-205-142.5q-62-42-117-115.5t-55-136.5q0-78 41.5-130t118.5-52h1472q65 0 112.5 47t47.5 113z"></path></svg></span>
<span class="emailsubheader">Cloud Expertise for IT Pros</span><p>Join 5,000 subscribers and get a periodic digest of news, articles, and more.</p>	</div>
<div class="content right">
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" id="header_transient_postid" value="-1">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-subscribemenu">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Your email">
<input aria-label="Go" type="submit" class="ftemsub" value="Go">
</form>
<div style="text-align: center;">
<img style="max-height: 38px; float: right; max-width: 300px; margin-right: 25%;" src=" data:image/gif;base64,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" alt="" role="presentation">
</div>
</div>
<p class="email_signup_disclaimer">By submitting your email, you agree to the <a href="/terms-of-use">Terms of Use</a> and <a href="/privacy-policy">Privacy Policy</a>.</p>
</div>
</div>
</div>
<script>
			let header_transient_postid = document.getElementById('header_transient_postid');
			if (header_transient_postid) {
				header_transient_postid.value = 9173;
			}
		</script>
<div id="content" class="site-content">
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:90px;margin-bottom:20px" aria-hidden="true" class="adslot adslot970 ">
<div aria-hidden="true" id='purch_Y_L_1_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_1_1', false);});</script></div>
</div>
<div id="primary" class="content-area">
<main id="main" class="site-main">
<style>
.commercemessage {
	width:100%;
	margin:20px 0px;
	padding-left:8px;
	font-size:13px;
	color:#555;
	border-left:3px solid #888;
}
@media screen and (min-width: 1025px) {
	.commercemessage {
		width:1020px;
		line-height:15px;
	}
}
</style>
<article id="post-9173" class="post-9173 post type-post status-publish format-standard hentry category-cloud">
<header id="article-header-area" class="entry-header" aria-label="How to Attach Extra Storage to Your DigitalOcean Droplets">
<h1 class="entry-title" style="">How to Attach Extra Storage to Your DigitalOcean Droplets</h1>
<div class="entry-meta" style="padding-top:15px;font-size:12px;" data-nosnippet="data-nosnippet">
<img loading="lazy" width="36" height="36" style="float: left;margin-right: 8px;border-radius: 18px;" src="https://www.cloudsavvyit.com/thumbcache/100/100/705347dffc4feb6b0f88ee994f81991b/p/uploads/2020/12/d373f5e3.png" alt="" role="presentation">
<span style="display: inline-block;">
<span class="author vcard"><a style="font-weight:bold;text-transform:uppercase;font-size:13px;" class="lsmauthorname url fn n" href="https://www.cloudsavvyit.com/author/jameswalker/">James Walker</a></span>
<br/>
<time style="font-size:12px;text-transform:uppercase;color:#666;" class="entry-date published" datetime="2021-02-04T09:00:21-05:00">Feb 4, 2021, 9:00 am EST</time>
| 4 min read
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="James Walker">
<meta name="twitter:label2" content="Est. Reading Time">
<meta name="twitter:data2" content="4 minutes">	</span>
</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div id="article-content-area" class="entry-content">
<p><img class="alignnone wp-image-5322 size-full" src="https://www.cloudsavvyit.com/thumbcache/0/0/88746de0fac00d6fcbee4f2a1c813c9e/p/uploads/2020/01/4d4b63f7.png" alt="Digital Ocean logo" width="700" height="300"/></p>
<p>DigitalOcean droplets come with a limited amount of SSD storage. Here&#8217;s how you can add more disk capacity without breaking the bank, using DigitalOcean&#8217;s dedicated storage solution.</p>
<p>Before we continue, you should check whether resizing your droplet might be an alternative option. Switching to a <a href="https://www.digitalocean.com/pricing/">larger droplet type</a> can get you more storage space as well as a bump in CPU and RAM. This can be ideal if you&#8217;re in need of all three now but don&#8217;t expect your storage requirements to grow much further in the near future.</p>
<p><img class="alignnone size-full wp-image-9175" src="https://www.cloudsavvyit.com/thumbcache/0/0/7107e742468aa054301b49b8bbe7e6ad/p/uploads/2021/01/e1cc5a18.jpg" alt="" width="1027" height="537"/></p>
<p>You can resize droplets in the DigitalOcean control panel by selecting your droplet and then clicking &#8220;Resize&#8221;. Choose &#8220;Disk, CPU and RAM&#8221; and then select the plan to upgrade to. You will need to shut your droplet down while the change is applied. Resizes involving disk capacity cannot be reversed.</p>
<h2 id="attaching-a-block-storage-volume">Attaching a Block Storage Volume</h2>
<p>Droplet resizes aside, DigitalOcean&#8217;s Block Storage Volumes are the simplest way to add extra storage to your servers. Volumes are SSD-driven storage units. When you add a volume to a droplet, it&#8217;s akin to connecting a physical removable drive.</p>
<p>The droplet will now have two storage systems available &#8211; its regular SSD and the newly created volume. You define the capacity of each volume, allowing you to tailor your storage solution. Pricing is a fixed $0.10 per GB.</p>
<p><img class="alignnone size-full wp-image-9176" src="https://www.cloudsavvyit.com/thumbcache/0/0/df1521c2ad9ef90dbbe394b0a6f29f72/p/uploads/2021/01/5bb4e838.jpg" alt="" width="1268" height="658"/></p>
<p>You can create a volume by logging into the DigitalOcean control panel and clicking the &#8220;Volumes&#8221; link in the left sidebar. Click the blue &#8220;Create Volume&#8221; button at the top-right of the screen.</p>
<p><img class="alignnone size-full wp-image-9177" src="https://www.cloudsavvyit.com/thumbcache/0/0/602953733380537c8cb4f92b73598ac5/p/uploads/2021/01/5ba68e77.jpg" alt="" width="761" height="738"/></p>
<p>Begin by specifying the volume size to create. Use one of the prefilled defaults or click &#8220;Enter size in GB&#8221; to customise. Next, name your volume and select the droplet you&#8217;d like to attach it to.</p>
<h2 id="formatting-and-mounting-volumes">Formatting and Mounting Volumes</h2>
<p>You&#8217;ll now need to choose how to mount your volume. Most of the time, &#8220;Automatically Format &amp; Mount&#8221; will get you setup with sane defaults. When this option is selected, DigitalOcean will create a formatted volume, attach it to your droplet and then mount it into the filesystem. You&#8217;re able to choose the mount point after you click &#8220;Create Volume&#8221;. DigitalOcean supports the Ext4 and XFS filesystems. Ext4 is usually the best choice, although XFS is preferred for Red Hat systems.</p>
<p>Choose the &#8220;Manually Format &amp; Mount&#8221; option if you need a different filesystem. This will also give you more control over the mounting configuration as you&#8217;ll need to set it up yourself, within your droplet.</p>
<p><img class="alignnone size-full wp-image-9178" src="https://www.cloudsavvyit.com/thumbcache/0/0/b5e7179f4b9d3a540c943cb0931e4333/p/uploads/2021/01/54d52432.jpg" alt="" width="756" height="254"/></p>
<p>You can use the following command to mount a volume to <code>/mnt/example-mount</code>:</p>
<pre>mount -o defaults,nofail,discard,noatime /dev/sda /mnt/example-mount</pre>
<p>We&#8217;re assuming our volume is assigned the <code>sda</code> device identifier. This will usually be true of the first volume you attach to a DigitalOcean droplet. The mounting options we supply are taken from DigitalOcean&#8217;s <a href="https://www.digitalocean.com/docs/volumes/how-to/mount/">recommended approach</a> to mounting volumes.</p>
<h2 id="using-your-volume">Using Your Volume</h2>
<p>Once attached, formatted and mounted, volumes become just another filesystem location on your droplet. You can copy files onto your volume with commands such as <code>cp example-file.txt /mnt/example-volume/example-file.txt</code> &#8211; substitute in the path you mounted your volume to.</p>
<p>This is no different to using any other form of mountable storage device. Anything saved within the mount location will get stored to the volume. The remainder of your droplet&#8217;s filesystem remains on its dedicated SSD as usual.</p>
<p>To check the disk space remaining on your droplet and volume, use the <code>df -h</code> command. The line with a mount point of <code>/</code> represents your droplet&#8217;s SSD. Your volume&#8217;s mount point will be listed too, allowing you to see how much capacity you&#8217;ve got remaining.</p>
<h2 id="managing-your-volumes">Managing Your Volumes</h2>
<p>Volumes can only be attached to one droplet at a time. It is possible to reconnect to a different droplet at any point. This is useful if you&#8217;ve moving resources between droplets or decommissioning one in favour of another.</p>
<p>Use the Volumes page in the Control Panel to find your volume. Hover over the name of the droplet it&#8217;s connected to and click &#8220;Edit&#8221;. You can now choose a new droplet to mount the volume to.</p>
<p><img class="alignnone size-full wp-image-9179" src="https://www.cloudsavvyit.com/thumbcache/0/0/00d974d83b2a2816e1bb83e4e99f0788/p/uploads/2021/01/bd6b40da.jpg" alt="" width="1029" height="450"/></p>
<p>Volumes are resized by clicking the &#8220;More&#8221; button to the right of the table. Choose &#8220;Increase size&#8221; and select the new capacity to use. Volumes can only ever be resized upwards so the change will not be reversible.</p>
<h2 id="volume-backups">Volume Backups</h2>
<p>Volumes support DigitalOcean&#8217;s Snapshots system for backups. This mechanism lets you save a complete disk image into your DigitalOcean account.</p>
<p>Click the &#8220;More&#8221; button next to any volume and click &#8220;Take snapshot&#8221;. Use the dialog to name your snapshot and then press &#8220;Take Snapshot&#8221; to confirm. The process may take several minutes to complete. Larger droplets will require much more time.</p>
<p><img class="alignnone size-full wp-image-9180" src="https://www.cloudsavvyit.com/thumbcache/0/0/7652d6227306899bc3abf783f166e130/p/uploads/2021/01/befadf3d.jpg" alt="" width="1030" height="392"/></p>
<p>You can use snapshots to recover your data at any future time. Click the &#8220;Images&#8221; link in the sidebar and find the snapshot you want to use. You can restore the snapshot to the volume it originated from or create a new volume with the snapshot as its base.</p>
<p>Snapshots you create are stored in perpetutity in your account. They&#8217;re billed at $0.05/GB/mo. You only pay for the data within each snapshot, not the size of the volume it originated from.</p>
<h2 id="conclusion">Conclusion</h2>
<p>DigitalOcean&#8217;s Volumes allow you to easily add more storage to an existing droplet. The automated formatting and mounting process makes setup an extremely straightforward process.</p>
<p>Volumes aren&#8217;t the only approach to gaining more disk capacity. Depending on your requirements, <a href="https://www.cloudsavvyit.com/5891/how-to-use-digitalocean-spaces-for-s3-alternative-object-storage/">DigitalOcean Spaces</a> might be a viable alternative. It&#8217;s a remote object storage system akin to Amazon S3. Spaces is much more affordable when storing large volumes of data &#8211; $5/mo for 250GB &#8211; but does not directly connect to your droplet&#8217;s filesystem. It has to be accessed over HTTP so it&#8217;s best used for static assets and long-term archives.</p>
</div><!-- .entry-content -->
</article><!-- #post-9173 -->
<style>
			#content ul#nextuplist {list-style-type: none;margin-left:0px;padding-left:0px;}
			#content ul#nextuplist li {margin-bottom:10px;}
			#content ul#nextuplist li a {text-decoration:none;}
		</style>
<div class="nextup">
<span id="nextuplabel" role="heading" aria-level="2">READ NEXT</span>
<ul id="nextuplist">
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/9323/how-to-apply-your-own-patches-to-composer-packages/">How to Apply Your Own Patches to Composer Packages</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/9246/how-to-set-up-a-wordpress-site-on-your-own-servers-with-ubuntu-nginx/">How To Set Up A WordPress Site On Your Own Servers (With Ubuntu &#038; NGINX)</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/9353/how-to-create-a-gitlab-ci-pipeline-to-statically-analyse-php-projects/">How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/9283/how-to-defend-yourself-against-rootkits/">How To Defend Yourself Against Rootkits</a></li>
<li>&rsaquo; <a href="https://www.cloudsavvyit.com/9290/bash-process-termination-hacks/">Bash Process Termination Hacks</a></li>
</ul>
</div>
<style>
.shortbioauthor {

	font-weight: bold;
    text-transform: uppercase;
    font-size: 20px;
    text-decoration:none;
    padding-top: 0;
    margin-top: 0;
    line-height: 20px;
}
.shortbioauthor span {
	color:#1d55a9;	
	padding-top: 0;
	margin-top: 0;
}
.shortbioauthordiv {
	border: 1px solid #eee;
	padding: 15px;
	margin-bottom: 20px;
}
.shortbioauthordiv .biotext {
	font-size: 15px;
}
.shortbioauthordiv .biomore {
	text-transform: uppercase;
	font-size: 13px;
	font-weight: bold;
	color:#1d55a9;		
}
</style>
<div class="shortbioauthordiv">
<a href="https://www.cloudsavvyit.com/author/jameswalker/"><img style="float:left;margin-right:15px;margin-bottom:15px;width:100px;" src="https://www.cloudsavvyit.com/thumbcache/200/200/f4f014836f3a864d12475af8b247b7c2/p/uploads/2020/12/d373f5e3.png" alt="James Walker"></a>
<span>
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="shortbioauthor"><span>James Walker</span></a>
<br style="margin-top: 10px;">
<span class="biotext">James Walker is a contributor to CloudSavvy IT. He is the founder of <a href="https://www.heron-web.com" rel="noopener" target="_blank">Heron Web</a>, a UK-based digital agency providing bespoke software development services to SMEs. He has experience of managing complete end-to-end web development workflows, using technologies including Linux, GitLab, Docker and Kubernetes.
<a href="https://www.cloudsavvyit.com/author/jameswalker/" class="biomore">Read Full Bio »</a></span>
</span>
<div style="clear:both;"></div>
</div>
<div class="article-share-widgets">
<div class="social-wrapper">
<a title="Share on Facebook" aria-label="Share on Facebook" class="facebook social-share" href='javascript:window.open("https://www.facebook.com/sharer/sharer.php?u=https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/","facebookshare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1376 128q119 0 203.5 84.5t84.5 203.5v960q0 119-84.5 203.5t-203.5 84.5h-188v-595h199l30-232h-229v-148q0-56 23.5-84t91.5-28l122-1v-207q-63-9-178-9-136 0-217.5 80t-81.5 226v171h-200v232h200v595h-532q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960z"/></svg></a>
</div>
<div class="social-wrapper">
<a title="Share on Twitter" aria-label="Share on Twitter" class="twitter social-share" href='javascript:window.open("https://twitter.com/intent/tweet?text=How+to+Attach+Extra+Storage+to+Your+DigitalOcean+Droplets+via+%40cloudsavvyit+-+https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/","twittershare", "menubar=0,resizable=0,width=700,height=500");'><svg width="1792" height="1792" viewBox="0 0 1792 1792" xmlns="http://www.w3.org/2000/svg" aria-hidden="true" tabindex="-1"><path d="M1408 610q-56 25-121 34 68-40 93-117-65 38-134 51-61-66-153-66-87 0-148.5 61.5t-61.5 148.5q0 29 5 48-129-7-242-65t-192-155q-29 50-29 106 0 114 91 175-47-1-100-26v2q0 75 50 133.5t123 72.5q-29 8-51 8-13 0-39-4 21 63 74.5 104t121.5 42q-116 90-261 90-26 0-50-3 148 94 322 94 112 0 210-35.5t168-95 120.5-137 75-162 24.5-168.5q0-18-1-27 63-45 105-109zm256-194v960q0 119-84.5 203.5t-203.5 84.5h-960q-119 0-203.5-84.5t-84.5-203.5v-960q0-119 84.5-203.5t203.5-84.5h960q119 0 203.5 84.5t84.5 203.5z"/></svg></a>
</div>
<style>
#content .comments p.share-heading {
	font-size: 14px;
    font-weight: bold;
    margin-top: 0;
    line-height: 36px;
    text-decoration: none;
    text-transform: uppercase;
    border: 1px solid #333333;
    background: #333333;
    border-radius: 4px;
    color: #FFF;
    padding-left: 8px;
    padding-right: 8px;
}

@media screen and (max-width: 768px) {
	#content .comments p.share-heading {
		line-height:27px;
	}

}

</style>
<div style="clear:both;"></div>
</div>
<hr>
<p class="affiliate-disclosure" id="fire-all-lawyers-from-a-cannon-into-the-sun">The above article may contain affiliate links, which help support CloudSavvy IT.</p>
<hr>
<div class="related-articles">
<strong class="article-footer-heading">Recently Popular</strong>
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" aria-label="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" href="https://www.cloudsavvyit.com/9353/how-to-create-a-gitlab-ci-pipeline-to-statically-analyse-php-projects/">
<img alt="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2021/01/0ee9c227.jpg?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" aria-label="How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects" href="https://www.cloudsavvyit.com/9353/how-to-create-a-gitlab-ci-pipeline-to-statically-analyse-php-projects/">
<span class="entry-title article-header">How to Create A GitLab CI Pipeline to Statically Analyse PHP Projects</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-02-02T08:00:06-05:00">February 2nd</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Attach Extra Storage to Your DigitalOcean Droplets" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Attach Extra Storage to Your DigitalOcean Droplets" aria-label="How to Attach Extra Storage to Your DigitalOcean Droplets" href="https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/">
<img alt="How to Attach Extra Storage to Your DigitalOcean Droplets" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2020/01/4d4b63f7.png?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="How to Attach Extra Storage to Your DigitalOcean Droplets" aria-label="How to Attach Extra Storage to Your DigitalOcean Droplets" href="https://www.cloudsavvyit.com/9173/how-to-attach-extra-storage-to-your-digitalocean-droplets/">
<span class="entry-title article-header">How to Attach Extra Storage to Your DigitalOcean Droplets</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-02-04T09:00:21-05:00">February 4th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="Constructor Property Promotion in PHP 8" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="Constructor Property Promotion in PHP 8" aria-label="Constructor Property Promotion in PHP 8" href="https://www.cloudsavvyit.com/9378/constructor-property-promotion-in-php-8/">
<img alt="Constructor Property Promotion in PHP 8" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2017/08/1ac500da.png?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="Constructor Property Promotion in PHP 8" aria-label="Constructor Property Promotion in PHP 8" href="https://www.cloudsavvyit.com/9378/constructor-property-promotion-in-php-8/">
<span class="entry-title article-header">Constructor Property Promotion in PHP 8</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-02-02T09:00:02-05:00">February 2nd</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How Much Performance Does Your Cloud Server Really Need?" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How Much Performance Does Your Cloud Server Really Need?" aria-label="How Much Performance Does Your Cloud Server Really Need?" href="https://www.cloudsavvyit.com/2097/how-much-performance-does-your-cloud-server-really-need/">
<img alt="How Much Performance Does Your Cloud Server Really Need?" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2020/06/83469162.png?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="How Much Performance Does Your Cloud Server Really Need?" aria-label="How Much Performance Does Your Cloud Server Really Need?" href="https://www.cloudsavvyit.com/2097/how-much-performance-does-your-cloud-server-really-need/">
<span class="entry-title article-header">How Much Performance Does Your Cloud Server Really Need?</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/anthonyheddings/" class="p-author vcard author post-author"><span class="fn">Anthony Heddings</span></a> | <time style="display:inline-block" class="post-date published" datetime="2020-06-01T11:00:25-04:00">June 1st</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Install and Use Composer, PHP&#8217;s Dependency Manager" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Install and Use Composer, PHP&#8217;s Dependency Manager" aria-label="How to Install and Use Composer, PHP&#8217;s Dependency Manager" href="https://www.cloudsavvyit.com/9125/how-to-install-and-use-composer-phps-dependency-manager/">
<img alt="How to Install and Use Composer, PHP&#8217;s Dependency Manager" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2017/08/1ac500da.png?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="How to Install and Use Composer, PHP&#8217;s Dependency Manager" aria-label="How to Install and Use Composer, PHP&#8217;s Dependency Manager" href="https://www.cloudsavvyit.com/9125/how-to-install-and-use-composer-phps-dependency-manager/">
<span class="entry-title article-header">How to Install and Use Composer, PHP&#8217;s Dependency Manager</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-01-29T09:00:57-05:00">January 29th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
<article>
<header class="entry-header" style="min-height:100px;" aria-label="How to Apply Your Own Patches to Composer Packages" role="heading" aria-level="2">
<a aria-hidden="true" tabindex="-1" title="How to Apply Your Own Patches to Composer Packages" aria-label="How to Apply Your Own Patches to Composer Packages" href="https://www.cloudsavvyit.com/9323/how-to-apply-your-own-patches-to-composer-packages/">
<img alt="How to Apply Your Own Patches to Composer Packages" loading="lazy" src="https://www.cloudsavvyit.com/p/uploads/2017/08/1ac500da.png?width=240&height=140&fit=crop&trim=2,2,2,2"/>	</a>
<div class="article-text">
<a title="How to Apply Your Own Patches to Composer Packages" aria-label="How to Apply Your Own Patches to Composer Packages" href="https://www.cloudsavvyit.com/9323/how-to-apply-your-own-patches-to-composer-packages/">
<span class="entry-title article-header">How to Apply Your Own Patches to Composer Packages</span>	</a>
<div class="entry-meta"><a href="https://www.cloudsavvyit.com/author/jameswalker/" class="p-author vcard author post-author"><span class="fn">James Walker</span></a> | <time style="display:inline-block" class="post-date published" datetime="2021-02-04T08:00:20-05:00">February 4th</time></div>
</div>
</header><!-- .entry-header -->
<div style="clear:both;"></div>
</article><!-- #post-## -->
</div>
<script type='text/javascript'>
			var htg = -1;
			var htgm = document.cookie.match('htg=([0-9]*)');
			if (htgm && htgm.length == 2) {
				htg = htgm[1];
			}
			document.write('<img src="https://www.cloudsavvyit.com/lambda-uploads/cloudsavvy/9173/' + htg + '/logo.gif?1612458497" alt="" id="htgstats" style="display:none" />');
		</script>
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area sidebar-article" role="complementary" style="">
<div aria-hidden="true" id='purch_Y_R_1_1' style="min-height:270px;padding-bottom:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_R_1_1', false);});</script></div>
<div class="sidebar-popular popular-posts">
<script src="/p/sidebar.js?v=1612458000" defer async></script>
</div>
<div aria-hidden="true" id='purch_Y_S_0_1' style="min-height:270px;padding-top:20px;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_S_0_1', false);});</script></div>
</aside>
<script type="text/javascript">
	document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";

	window.onload = function() {
		//document.getElementById("secondary").style.paddingTop = (document.getElementById("article-content-area").getBoundingClientRect().top - document.getElementById("main").getBoundingClientRect().top + 15)+"px";
	}
</script>
</div><!-- #content -->
</div><!-- #page -->
<div style="text-align:center;margin-right:auto;margin-left:auto;position:relative;width:100vw;left: 50%;right: 50%;margin-left: -50vw;margin-right: -50vw;min-height:110px;margin-bottom:20px;" aria-hidden="true" class="adslot adslot970 ">
<div aria-hidden="true" id='purch_Y_L_0_1' style="text-align:center;"><script>tmntag.cmd.push(function(){tmntag.adTag('purch_Y_L_0_1', false);});</script></div>
</div>
<footer id="colophon" class="site-footer">
<div class="container">
<div class="logo">
<a aria-label="CloudSavvy IT" title="CloudSavvy IT" href="https://www.cloudsavvyit.com">
<img loading="lazy" src="https://www.cloudsavvyit.com/wp-content/themes/lsm/img/csit_dark_t.png" alt="CloudSavvy IT Logo" class="logo">
</a>
<div class="social">
<a title="Facebook" aria-label="Facebook" href="https://www.facebook.com/cloudsavvyit/">
<div class="facebook">
<svg id="icon-facebook" viewBox="0 0 43.8 34" width="100%" height="100%" aria-hidden="true" tabindex="-1"><title>Facebook Icon</title><g><path id="f_6_" fill="#FFFFFF" d="M22.4,30.1V18.9h3.7l0.6-4.4h-4.3v-2.8c0-1.3,0.3-2.1,2.2-2.1h2.3V5.8c-0.4-0.1-1.8-0.2-3.4-0.2c-3.3,0-5.6,2-5.6,5.7v3.2h-3.8v4.4h3.8v11.2L22.4,30.1L22.4,30.1z"></path></g></svg>
<p>Facebook</p>
</div>
</a>
<a title="Twitter" href="https://www.twitter.com/cloudsavvyit">
<div class="twitter">
<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 300.00006 244.18703" height="244.19" width="300" aria-hidden="true" tabindex="-1">
<title>Twitter Icon</title>
<g style="" transform="translate(-539.18 -568.86)">
<path d="m633.9 812.04c112.46 0 173.96-93.168 173.96-173.96 0-2.6463-0.0539-5.2806-0.1726-7.903 11.938-8.6302 22.314-19.4 30.498-31.66-10.955 4.8694-22.744 8.1474-35.111 9.6255 12.623-7.5693 22.314-19.543 26.886-33.817-11.813 7.0031-24.895 12.093-38.824 14.841-11.157-11.884-27.041-19.317-44.629-19.317-33.764 0-61.144 27.381-61.144 61.132 0 4.7978 0.5364 9.4646 1.5854 13.941-50.815-2.5569-95.874-26.886-126.03-63.88-5.2508 9.0354-8.2785 19.531-8.2785 30.73 0 21.212 10.794 39.938 27.208 50.893-10.031-0.30992-19.454-3.0635-27.69-7.6468-0.009 0.25652-0.009 0.50661-0.009 0.78077 0 29.61 21.075 54.332 49.051 59.934-5.1376 1.4006-10.543 2.1516-16.122 2.1516-3.9336 0-7.766-0.38716-11.491-1.1026 7.7838 24.293 30.355 41.971 57.115 42.465-20.926 16.402-47.287 26.171-75.937 26.171-4.929 0-9.7983-0.28036-14.584-0.84634 27.059 17.344 59.189 27.464 93.722 27.464" fill="#ffffff"/>
</g>
</svg>
<p>Twitter</p>
</div>
</a>
<a title="LinkedIn" class="rss-link" href="https://www.linkedin.com/company/cloudsavvy-it/">
<div class="rss" style="background-color:#325f93">
<svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" tabindex="-1"><title>LinkedIn Icon</title><path d="M19 0h-14c-2.761 0-5 2.239-5 5v14c0 2.761 2.239 5 5 5h14c2.762 0 5-2.239 5-5v-14c0-2.761-2.238-5-5-5zm-11 19h-3v-11h3v11zm-1.5-12.268c-.966 0-1.75-.79-1.75-1.764s.784-1.764 1.75-1.764 1.75.79 1.75 1.764-.783 1.764-1.75 1.764zm13.5 12.268h-3v-5.604c0-3.368-4-3.113-4 0v5.604h-3v-11h3v1.765c1.396-2.586 7-2.777 7 2.476v6.759z"/></svg>
<p>LinkedIn</p>
</div>
</a>
</div>
</div>
<style>
.footer-email {
	display: inline-block;
    float: left;
    width: 33%;	
}

#footer-email-text {
	margin-bottom: 5px;
	font-size: 16px;
	font-family: "Open Sans", sans-serif;
	margin-top:0px;
}
.footer-email form {margin-bottom:10px;}
.footer-email #ftemtxt, .footer-email .ftemtxt {
    border-radius: 0;
    font-size: 16px;
    padding: 8px;
    height: 40px;
    margin-right: 0px;
    border: 0;
    width: 250px;	
}
.footer-email #ftemsub, .footer-email .ftemsub {

    border: 0;
    border-radius: 0;
    font-size: 14px;
    padding: 8px;
    height: 40px;
    margin-left: 0px;
    background: #f79826;
    color: #000;
    font-weight: bold;
}
@media screen and (max-width: 768px) {
	.footer-email {
		display: block;
		text-align: center;
		width: 100%;
		border-top: 1px solid #999;
    	margin-top: 20px;
    	padding-top:15px;
	}
}

</style>
<div class="footer-email" data-nosnippet="data-nosnippet">
<p id="footer-email-text">Cloud wisdom in your inbox</p>
<form action="/em/subscribe" method="post">
<input aria-hidden="true" tabindex="-1" type="hidden" name="postid" value="9173">
<input aria-hidden="true" tabindex="-1" type="hidden" name="list" value="cloudsavvy">
<input aria-hidden="true" tabindex="-1" type="hidden" name="tr" value="cloudsavvy-footer">
<input aria-hidden="true" tabindex="-1" type="hidden" name="moka-pagerefer" value="">
<input aria-label="Enter Your Email" aria-required="true" aria-invalid="false" onkeypress="validateAriaEmail(this)" type="text" name="email" class="ftemtxt" placeholder="Enter Your Email">
<input aria-label="Sign Up" type="submit" class="ftemsub" value="Sign Up">
</form>
<p style="font-size: small;">By submitting your email, you agree to the <a style="display: inline; text-decoration: underline" href="/terms-of-use">Terms of Use</a> and <a style="display: inline; text-decoration: underline;" href="/privacy-policy">Privacy Policy</a>.</p>
</div>
<div class="pages">
<ul id="menu-footer" class="menu" role="menu">
<a href="/about"><li role="menuitem">About</li></a>
<a href="/ethics"><li role="menuitem">Ethics</li></a>
<a href="/privacy-policy"><li role="menuitem">Privacy</li></a>
<a href="/terms-of-use"><li role="menuitem">Terms</li></a>
<a href="/accessibility"><li role="menuitem">Accessibility</li></a>
<li role="menuitem" aria-label="Do not sell my info">
<div id="show-do-not-sell-info-container"></div>
</li>
<li role="menuitem">
<input class="darkModeToggle" id="darkModeToggle" aria-label="Toggle Dark Mode" type="checkbox" onclick="if (document.body.classList.contains('darkmode')) { document.body.classList.remove('darkmode'); document.cookie = 'enabledarkmode=no; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; } else { document.body.classList.add('darkmode'); document.cookie = 'enabledarkmode=yes; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/'; }"/> <label class="darkModeToggleLabel" for="darkModeToggle">Toggle Dark Mode</label>
</li>
</ul>
</div>
</div>
<a class="copyright" href="https://www.lifesavvymedia.com">© 2021 LifeSavvy Media. All Rights Reserved</a>
</footer><!-- #colophon -->
<script>
		if (document.getElementById('moka_no_dark_mode')) {
			// Disable dark mode (and toggle!) on this page
			[].forEach.call(document.getElementsByClassName('darkModeToggle'), a => a.remove());
			[].forEach.call(document.getElementsByClassName('darkModeToggleLabel'), a => a.remove());
		} else {
			let useDarkMode = false;
			if ( document.cookie.includes('enabledarkmode=yes') ) {
				useDarkMode = true;
			} else if ( document.cookie.includes('enabledarkmode=no') ) {
				useDarkMode = false;
			} else {
				// Use system default preference
				if (window.matchMedia && window.matchMedia('(prefers-color-scheme: dark)').matches ) {
					useDarkMode = true;
				}
			}

			if (useDarkMode) {
				document.body.classList.add('darkmode');
				document.getElementById('darkModeToggle').checked = true;
			}
		}
	</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1113647-16"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1113647-16');
</script>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-dPPj_fTCprdm0"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-dPPj_fTCprdm0.gif" border="0" height="1" width="1" alt=""/>
</div>
</noscript>
<!-- End Quantcast tag --><div id='out-of-page'><script>tmntag.cmd.push(function(){tmntag.adTag('out-of-page', false);});</script></div>
<div id='1x1'><script>tmntag.cmd.push(function(){tmntag.adTag('1x1', false);});</script></div>
<script type="text/javascript">
let mokaFindParentAnchor = function(elem) {
    if (elem.href) return elem;
    if (elem.parentElement) return mokaFindParentAnchor(elem.parentElement);
    return null;
}
window.addEventListener("click", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null ) {
		e.preventDefault();

		let xmlhttp = new XMLHttpRequest();
	    xmlhttp.onreadystatechange = function() {
	        if (xmlhttp.readyState == XMLHttpRequest.DONE) {
	        	self.location = trueAnchorElem.href;
	        }
	    };

		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/9173/' + htg + '/' + amzLink;
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
		
		document.body.style.cursor = 'wait';
	}
});
window.addEventListener("contextmenu", function(e) {
	var trueAnchorElem = mokaFindParentAnchor(e.target);
	if (trueAnchorElem && trueAnchorElem.href && trueAnchorElem.href.indexOf('amazon.com') != -1 && trueAnchorElem.getAttribute('data-skiptrack') === null) {
		// No need for preventdefault on this version - and no need to listen for finish
		var amzLink = trueAnchorElem.href.replace(/https?:\/\/(www.)?amazon.com\//, '');
		var htg = -1;
		var htgm = document.cookie.match('htg=([0-9]*)');
		if (htgm && htgm.length == 2) {
			htg = htgm[1];
		}
		var trackDest = 'https://2htg.com/a/cloudsavvy/9173/' + htg + '/' + amzLink;
		let xmlhttp = new XMLHttpRequest();
		xmlhttp.open("GET", trackDest, true);
	    xmlhttp.send();
	}
});

let handleHtgHash = function() {
	if (document.location.hash.indexOf('#htg=') != -1) {
		let htgid = document.location.hash.match(/htg=([0-9]*)/);
		let uid = 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, (c) => {
			var r = Math.random() * 16 | 0, v = c == 'x' ? r : (r & 0x3 | 0x8);
			return v.toString(16);
		});
		if (htgid.length == 2) {
			document.cookie = 'htg=' + htgid[1] + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htgreader=' + uid + '; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
			document.cookie = 'htg_newsletter_subform_hide=1; expires=Sun, 1 Jan 2023 00:00:00 UTC; path=/';
		}

		history.pushState('', document.title, window.location.pathname);
	}
}();
</script>
<script>
	// Load all lazy-loaded images before someone prints:
	let loadAllLazy = () => {
		var imgs = document.querySelectorAll('[data-pagespeed-lazy-src]');
		imgs.forEach(e => e.src = e.attributes['data-pagespeed-lazy-src'].value);
	}
	// IE and FireFox:
	window.onbeforeprint = loadAllLazy;
	// Chrome and Safari:
	let mediaQueryList = window.matchMedia('print');
	mediaQueryList.addListener((mql) => {
    	if (mql.matches) loadAllLazy();
	});
</script>
<script type="text/javascript">
	(function() {
		if (document.referrer) {
			var x = document.getElementsByName('moka-pagerefer');
			for (var i = 0; i < x.length; i++) {
				x[i].value = document.referrer;
			}
		}
	})();
</script>
</body>
</html>
